summaryrefslogtreecommitdiffstats
path: root/third_party/rust/bit-set/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/bit-set/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/bit-set/Cargo.toml')
-rw-r--r--third_party/rust/bit-set/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/third_party/rust/bit-set/Cargo.toml b/third_party/rust/bit-set/Cargo.toml
new file mode 100644
index 0000000000..b9539b691f
--- /dev/null
+++ b/third_party/rust/bit-set/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "bit-set"
+version = "0.5.3"
+authors = ["Alexis Beingessner <a.beingessner@gmail.com>"]
+description = "A set of bits"
+homepage = "https://github.com/contain-rs/bit-set"
+documentation = "https://contain-rs.github.io/bit-set/bit_set"
+readme = "README.md"
+keywords = [
+ "data-structures",
+ "bitset",
+]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/contain-rs/bit-set"
+
+[dependencies.bit-vec]
+version = "0.6.1"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.3"
+
+[features]
+default = ["std"]
+std = ["bit-vec/std"]