summaryrefslogtreecommitdiffstats
path: root/third_party/rust/chunky-vec
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/chunky-vec
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/chunky-vec')
-rw-r--r--third_party/rust/chunky-vec/.cargo-checksum.json1
-rw-r--r--third_party/rust/chunky-vec/Cargo.toml24
-rw-r--r--third_party/rust/chunky-vec/LICENSE-APACHE201
-rw-r--r--third_party/rust/chunky-vec/LICENSE-MIT27
-rw-r--r--third_party/rust/chunky-vec/README.md6
-rw-r--r--third_party/rust/chunky-vec/src/lib.rs343
6 files changed, 602 insertions, 0 deletions
diff --git a/third_party/rust/chunky-vec/.cargo-checksum.json b/third_party/rust/chunky-vec/.cargo-checksum.json
new file mode 100644
index 0000000000..8d85d17e6d
--- /dev/null
+++ b/third_party/rust/chunky-vec/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"3ab88cdacffa2756abe4460dda1ef403b304e79f814a2ec71b9c9a013dce2bf6","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"ea4a2543160e8e33d4e2d2b40339c90e0ab2960cfa59a65264b66782d7f9e35f","README.md":"382da770bccf4ebe07dded523a9ab5e4daead902edbbbffd20740404e73ee3d5","src/lib.rs":"01dc7e2a981fc95825584916d320fd60232b07fc88761126c89b12da3e3f20e5"},"package":"bb7bdea464ae038f09197b82430b921c53619fc8d2bcaf7b151013b3ca008017"} \ No newline at end of file
diff --git a/third_party/rust/chunky-vec/Cargo.toml b/third_party/rust/chunky-vec/Cargo.toml
new file mode 100644
index 0000000000..f436628b35
--- /dev/null
+++ b/third_party/rust/chunky-vec/Cargo.toml
@@ -0,0 +1,24 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "chunky-vec"
+version = "0.1.0"
+authors = ["Dan Glastonbury <dan.glastonbury@gmail.com>"]
+description = "A pin safe, append only vector never moves the backing store for an element.\n"
+keywords = ["data-structure", "vector", "pin"]
+categories = ["data-structures"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/djg/chunky-vec"
+
+[dependencies]
diff --git a/third_party/rust/chunky-vec/LICENSE-APACHE b/third_party/rust/chunky-vec/LICENSE-APACHE
new file mode 100644
index 0000000000..16fe87b06e
--- /dev/null
+++ b/third_party/rust/chunky-vec/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/third_party/rust/chunky-vec/LICENSE-MIT b/third_party/rust/chunky-vec/LICENSE-MIT
new file mode 100644
index 0000000000..f79cf5d3d2
--- /dev/null
+++ b/third_party/rust/chunky-vec/LICENSE-MIT
@@ -0,0 +1,27 @@
+MIT License
+
+Copyright (c) 2020 Daniel Glastonbury
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/third_party/rust/chunky-vec/README.md b/third_party/rust/chunky-vec/README.md
new file mode 100644
index 0000000000..e57317c013
--- /dev/null
+++ b/third_party/rust/chunky-vec/README.md
@@ -0,0 +1,6 @@
+# Chunky Vec
+
+[![License: MIT/Apache-2.0](https://img.shields.io/crates/l/chunky-vec.svg)](#license)
+
+This crate provides a pin-safe, append-only vector which guarantees never
+to move the storage for an element once it has been allocated.
diff --git a/third_party/rust/chunky-vec/src/lib.rs b/third_party/rust/chunky-vec/src/lib.rs
new file mode 100644
index 0000000000..dc81552553
--- /dev/null
+++ b/third_party/rust/chunky-vec/src/lib.rs
@@ -0,0 +1,343 @@
+//! This crate provides a pin-safe, append-only vector which guarantees never
+//! to move the storage for an element once it has been allocated.
+
+use std::{
+ ops::{Index, IndexMut},
+ slice,
+};
+
+struct Chunk<T> {
+ /// The elements of this chunk.
+ elements: Vec<T>,
+}
+
+impl<T> Chunk<T> {
+ fn with_capacity(capacity: usize) -> Self {
+ let elements = Vec::with_capacity(capacity);
+ assert_eq!(elements.capacity(), capacity);
+ Self { elements }
+ }
+
+ fn len(&self) -> usize {
+ self.elements.len()
+ }
+
+ /// Returns the number of available empty elements.
+ fn available(&self) -> usize {
+ self.elements.capacity() - self.elements.len()
+ }
+
+ /// Returns a shared reference to the element at the given index.
+ ///
+ /// # Panics
+ ///
+ /// Panics if the index is out of bounds.
+ pub fn get(&self, index: usize) -> Option<&T> {
+ self.elements.get(index)
+ }
+
+ /// Returns an exclusive reference to the element at the given index.
+ ///
+ /// # Panics
+ ///
+ /// Panics if the index is out of bounds.
+ pub fn get_mut(&mut self, index: usize) -> Option<&mut T> {
+ self.elements.get_mut(index)
+ }
+
+ /// Pushes a new value into the fixed capacity entry.
+ ///
+ /// # Panics
+ ///
+ /// If the entry is already at its capacity.
+ /// Note that this panic should never happen since the entry is only ever
+ /// accessed by its outer chunk vector that checks before pushing.
+ pub fn push(&mut self, new_value: T) {
+ if self.available() == 0 {
+ panic!("No available elements.")
+ }
+ self.elements.push(new_value);
+ }
+
+ pub fn push_get(&mut self, new_value: T) -> &mut T {
+ self.push(new_value);
+ unsafe {
+ let last = self.elements.len() - 1;
+ self.elements.get_unchecked_mut(last)
+ }
+ }
+
+ /// Returns an iterator over the elements of the chunk.
+ pub fn iter(&self) -> slice::Iter<T> {
+ self.elements.iter()
+ }
+
+ /// Returns an iterator over the elements of the chunk.
+ pub fn iter_mut(&mut self) -> slice::IterMut<T> {
+ self.elements.iter_mut()
+ }
+}
+
+impl<T> Index<usize> for Chunk<T> {
+ type Output = T;
+
+ fn index(&self, index: usize) -> &Self::Output {
+ self.get(index).expect("index out of bounds")
+ }
+}
+
+impl<T> IndexMut<usize> for Chunk<T> {
+ fn index_mut(&mut self, index: usize) -> &mut Self::Output {
+ self.get_mut(index).expect("index out of bounds")
+ }
+}
+
+/// Pin safe vector
+///
+/// An append only vector that never moves the backing store for each element.
+pub struct ChunkyVec<T> {
+ /// The chunks holding elements
+ chunks: Vec<Chunk<T>>,
+}
+
+impl<T> Default for ChunkyVec<T> {
+ fn default() -> Self {
+ Self {
+ chunks: Vec::default(),
+ }
+ }
+}
+
+impl<T> Unpin for ChunkyVec<T> {}
+
+impl<T> ChunkyVec<T> {
+ const DEFAULT_CAPACITY: usize = 32;
+
+ pub fn len(&self) -> usize {
+ if self.chunks.is_empty() {
+ 0
+ } else {
+ // # Safety - There is at least one chunk here.
+ (self.chunks.len() - 1) * Self::DEFAULT_CAPACITY + self.chunks.last().unwrap().len()
+ }
+ }
+
+ pub fn is_empty(&self) -> bool {
+ // # Safety - Since it's impossible to pop, at least one chunk means we're not empty.
+ self.chunks.is_empty()
+ }
+
+ /// Returns an iterator that yields shared references to the elements of the bucket vector.
+ pub fn iter(&self) -> Iter<T> {
+ Iter::new(self)
+ }
+
+ /// Returns an iterator that yields exclusive reference to the elements of the bucket vector.
+ pub fn iter_mut(&mut self) -> IterMut<T> {
+ IterMut::new(self)
+ }
+
+ /// Returns a shared reference to the element at the given index if any.
+ pub fn get(&self, index: usize) -> Option<&T> {
+ let (x, y) = (
+ index / Self::DEFAULT_CAPACITY,
+ index % Self::DEFAULT_CAPACITY,
+ );
+ self.chunks.get(x).and_then(|chunk| chunk.get(y))
+ }
+
+ /// Returns an exclusive reference to the element at the given index if any.
+ pub fn get_mut(&mut self, index: usize) -> Option<&mut T> {
+ let (x, y) = (
+ index / Self::DEFAULT_CAPACITY,
+ index % Self::DEFAULT_CAPACITY,
+ );
+ self.chunks.get_mut(x).and_then(|chunk| chunk.get_mut(y))
+ }
+
+ /// Pushes a new element onto the bucket vector.
+ ///
+ /// # Note
+ ///
+ /// This operation will never move other elements, reallocates or otherwise
+ /// invalidate pointers of elements contained by the bucket vector.
+ pub fn push(&mut self, new_value: T) {
+ self.push_get(new_value);
+ }
+
+ pub fn push_get(&mut self, new_value: T) -> &mut T {
+ if self.chunks.last().map(Chunk::available).unwrap_or_default() == 0 {
+ self.chunks.push(Chunk::with_capacity(Self::DEFAULT_CAPACITY));
+ }
+ // Safety: Guaranteed to have a chunk with available elements
+ unsafe {
+ let last = self.chunks.len() - 1;
+ self.chunks.get_unchecked_mut(last).push_get(new_value)
+ }
+ }
+}
+
+impl<T> Index<usize> for ChunkyVec<T> {
+ type Output = T;
+
+ fn index(&self, index: usize) -> &Self::Output {
+ self.get(index).expect("index out of bounds")
+ }
+}
+
+impl<T> IndexMut<usize> for ChunkyVec<T> {
+ fn index_mut(&mut self, index: usize) -> &mut Self::Output {
+ self.get_mut(index).expect("index out of bounds")
+ }
+}
+
+/// An iterator yielding shared references to the elements of a ChunkyVec.
+#[derive(Clone)]
+pub struct Iter<'a, T> {
+ /// Chunks iterator.
+ chunks: slice::Iter<'a, Chunk<T>>,
+ /// Forward iterator for `next`.
+ iter: Option<slice::Iter<'a, T>>,
+ /// Number of elements that are to be yielded by the iterator.
+ len: usize,
+}
+
+impl<'a, T> Iter<'a, T> {
+ /// Creates a new iterator over the ChunkyVec
+ pub(crate) fn new(vec: &'a ChunkyVec<T>) -> Self {
+ let len = vec.len();
+ Self {
+ chunks: vec.chunks.iter(),
+ iter: None,
+ len,
+ }
+ }
+}
+
+impl<'a, T> Iterator for Iter<'a, T> {
+ type Item = &'a T;
+
+ fn next(&mut self) -> Option<Self::Item> {
+ loop {
+ if let Some(ref mut iter) = self.iter {
+ if let front @ Some(_) = iter.next() {
+ self.len -= 1;
+ return front;
+ }
+ }
+ self.iter = Some(self.chunks.next()?.iter());
+ }
+ }
+
+ fn size_hint(&self) -> (usize, Option<usize>) {
+ (self.len(), Some(self.len()))
+ }
+}
+
+impl<'a, T> ExactSizeIterator for Iter<'a, T> {
+ fn len(&self) -> usize {
+ self.len
+ }
+}
+
+/// An iterator yielding exclusive references to the elements of a ChunkVec.
+pub struct IterMut<'a, T> {
+ /// Chunks iterator.
+ chunks: slice::IterMut<'a, Chunk<T>>,
+ /// Forward iterator for `next`.
+ iter: Option<slice::IterMut<'a, T>>,
+ /// Number of elements that are to be yielded by the iterator.
+ len: usize,
+}
+
+impl<'a, T> IterMut<'a, T> {
+ /// Creates a new iterator over the bucket vector.
+ pub(crate) fn new(vec: &'a mut ChunkyVec<T>) -> Self {
+ let len = vec.len();
+ Self {
+ chunks: vec.chunks.iter_mut(),
+ iter: None,
+ len,
+ }
+ }
+}
+
+impl<'a, T> Iterator for IterMut<'a, T> {
+ type Item = &'a mut T;
+
+ fn next(&mut self) -> Option<Self::Item> {
+ loop {
+ if let Some(ref mut iter) = self.iter {
+ if let front @ Some(_) = iter.next() {
+ self.len -= 1;
+ return front;
+ }
+ }
+ self.iter = Some(self.chunks.next()?.iter_mut());
+ }
+ }
+
+ fn size_hint(&self) -> (usize, Option<usize>) {
+ (self.len(), Some(self.len()))
+ }
+}
+
+impl<'a, T> ExactSizeIterator for IterMut<'a, T> {
+ fn len(&self) -> usize {
+ self.len
+ }
+}
+impl<'a, T> IntoIterator for &'a ChunkyVec<T> {
+ type Item = &'a T;
+ type IntoIter = Iter<'a, T>;
+
+ fn into_iter(self) -> Iter<'a, T> {
+ self.iter()
+ }
+}
+
+impl<'a, T> IntoIterator for &'a mut ChunkyVec<T> {
+ type Item = &'a mut T;
+ type IntoIter = IterMut<'a, T>;
+
+ fn into_iter(self) -> IterMut<'a, T> {
+ self.iter_mut()
+ }
+}
+
+#[cfg(test)]
+mod tests {
+ use super::*;
+
+ #[test]
+ fn iterate_empty() {
+ let v = ChunkyVec::<usize>::default();
+ for i in &v {
+ println!("{:?}", i);
+ }
+ }
+
+ #[test]
+ fn iterate_multiple_chunks() {
+ let mut v = ChunkyVec::<usize>::default();
+ for i in 0..33 {
+ v.push(i);
+ }
+ let mut iter = v.iter();
+ for _ in 0..32 {
+ iter.next();
+ }
+ assert_eq!(iter.next(), Some(&32));
+ assert_eq!(iter.next(), None);
+ }
+
+ #[test]
+ fn index_multiple_chunks() {
+ let mut v = ChunkyVec::<usize>::default();
+ for i in 0..33 {
+ v.push(i);
+ }
+ assert_eq!(v.get(32), Some(&32));
+ assert_eq!(v[32], 32);
+ }
+}