summaryrefslogtreecommitdiffstats
path: root/third_party/rust/clap_lex
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/clap_lex
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/clap_lex')
-rw-r--r--third_party/rust/clap_lex/.cargo-checksum.json1
-rw-r--r--third_party/rust/clap_lex/Cargo.toml82
-rw-r--r--third_party/rust/clap_lex/LICENSE-APACHE201
-rw-r--r--third_party/rust/clap_lex/LICENSE-MIT21
-rw-r--r--third_party/rust/clap_lex/README.md19
-rw-r--r--third_party/rust/clap_lex/src/ext.rs312
-rw-r--r--third_party/rust/clap_lex/src/lib.rs468
7 files changed, 1104 insertions, 0 deletions
diff --git a/third_party/rust/clap_lex/.cargo-checksum.json b/third_party/rust/clap_lex/.cargo-checksum.json
new file mode 100644
index 0000000000..a9ef7b4bde
--- /dev/null
+++ b/third_party/rust/clap_lex/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"b1006bd900af6c0a9efe8481169654ab2e2e59f6a120ac7557bfaa83735c11af","LICENSE-APACHE":"c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4","LICENSE-MIT":"0d687e1f07b58fe68bda74668ff6326125e5e5efa184cce755cd84ac535b7058","README.md":"8950086b49f28a26cd9e91dca52a0562a31765275e412909fec859151182e601","src/ext.rs":"f16c249c340d3c42aa566f2ff279878f807cbc74f17de19dc388f8ab352f8f1d","src/lib.rs":"db7106a744428be0915f94f4c053d04c5dd5332a1f8f57ca54a5aa7d566bae47"},"package":"cd7cc57abe963c6d3b9d8be5b06ba7c8957a930305ca90304f24ef040aa6f961"} \ No newline at end of file
diff --git a/third_party/rust/clap_lex/Cargo.toml b/third_party/rust/clap_lex/Cargo.toml
new file mode 100644
index 0000000000..01a944e02a
--- /dev/null
+++ b/third_party/rust/clap_lex/Cargo.toml
@@ -0,0 +1,82 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.70.0"
+name = "clap_lex"
+version = "0.5.1"
+include = [
+ "build.rs",
+ "src/**/*",
+ "Cargo.toml",
+ "LICENSE*",
+ "README.md",
+ "benches/**/*",
+ "examples/**/*",
+]
+description = "Minimal, flexible command line parser"
+readme = "README.md"
+keywords = [
+ "argument",
+ "cli",
+ "arg",
+ "parser",
+ "parse",
+]
+categories = ["command-line-interface"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/clap-rs/clap/tree/master/clap_lex"
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+min = 1
+replace = "{{version}}"
+search = "Unreleased"
+
+[[package.metadata.release.pre-release-replacements]]
+exactly = 1
+file = "CHANGELOG.md"
+replace = "...{{tag_name}}"
+search = '\.\.\.HEAD'
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+min = 1
+replace = "{{date}}"
+search = "ReleaseDate"
+
+[[package.metadata.release.pre-release-replacements]]
+exactly = 1
+file = "CHANGELOG.md"
+replace = """
+<!-- next-header -->
+## [Unreleased] - ReleaseDate
+"""
+search = "<!-- next-header -->"
+
+[[package.metadata.release.pre-release-replacements]]
+exactly = 1
+file = "CHANGELOG.md"
+replace = """
+<!-- next-url -->
+[Unreleased]: https://github.com/clap-rs/clap/compare/{{tag_name}}...HEAD"""
+search = "<!-- next-url -->"
+
+[[package.metadata.release.pre-release-replacements]]
+exactly = 4
+file = "README.md"
+prerelease = true
+replace = "github.com/clap-rs/clap/blob/{{tag_name}}/"
+search = "github.com/clap-rs/clap/blob/[^/]+/"
+
+[lib]
+bench = false
diff --git a/third_party/rust/clap_lex/LICENSE-APACHE b/third_party/rust/clap_lex/LICENSE-APACHE
new file mode 100644
index 0000000000..261eeb9e9f
--- /dev/null
+++ b/third_party/rust/clap_lex/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
+ APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+ Copyright [yyyy] [name of copyright owner]
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
diff --git a/third_party/rust/clap_lex/LICENSE-MIT b/third_party/rust/clap_lex/LICENSE-MIT
new file mode 100644
index 0000000000..7b05b8453e
--- /dev/null
+++ b/third_party/rust/clap_lex/LICENSE-MIT
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2015-2022 Kevin B. Knapp and Clap Contributors
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/third_party/rust/clap_lex/README.md b/third_party/rust/clap_lex/README.md
new file mode 100644
index 0000000000..4b7cc3eb14
--- /dev/null
+++ b/third_party/rust/clap_lex/README.md
@@ -0,0 +1,19 @@
+<!-- omit in TOC -->
+# clap_lex
+
+> **Minimal, flexible command line parser**
+
+[![Crates.io](https://img.shields.io/crates/v/clap_lex?style=flat-square)](https://crates.io/crates/clap_lex)
+[![Crates.io](https://img.shields.io/crates/d/clap_lex?style=flat-square)](https://crates.io/crates/clap_lex)
+[![License](https://img.shields.io/badge/license-Apache%202.0-blue?style=flat-square)](https://github.com/clap-rs/clap/blob/clap_lex-v0.5.1/LICENSE-APACHE)
+[![License](https://img.shields.io/badge/license-MIT-blue?style=flat-square)](https://github.com/clap-rs/clap/blob/clap_lex-v0.5.1/LICENSE-MIT)
+
+Dual-licensed under [Apache 2.0](LICENSE-APACHE) or [MIT](LICENSE-MIT).
+
+1. [About](#about)
+2. [API Reference](https://docs.rs/clap_lex)
+3. [Questions & Discussions](https://github.com/clap-rs/clap/discussions)
+4. [CONTRIBUTING](https://github.com/clap-rs/clap/blob/clap_lex-v0.5.1/clap_lex/CONTRIBUTING.md)
+5. [Sponsors](https://github.com/clap-rs/clap/blob/clap_lex-v0.5.1/README.md#sponsors)
+
+## About
diff --git a/third_party/rust/clap_lex/src/ext.rs b/third_party/rust/clap_lex/src/ext.rs
new file mode 100644
index 0000000000..a2de707e2b
--- /dev/null
+++ b/third_party/rust/clap_lex/src/ext.rs
@@ -0,0 +1,312 @@
+use std::ffi::OsStr;
+
+pub trait OsStrExt: private::Sealed {
+ /// Converts to a string slice.
+ fn try_str(&self) -> Result<&str, std::str::Utf8Error>;
+ /// Returns `true` if the given pattern matches a sub-slice of
+ /// this string slice.
+ ///
+ /// Returns `false` if it does not.
+ ///
+ /// # Examples
+ ///
+ /// ```rust
+ /// use clap_lex::OsStrExt as _;
+ /// let bananas = std::ffi::OsStr::new("bananas");
+ ///
+ /// assert!(bananas.contains("nana"));
+ /// assert!(!bananas.contains("apples"));
+ /// ```
+ fn contains(&self, needle: &str) -> bool;
+ /// Returns the byte index of the first character of this string slice that
+ /// matches the pattern.
+ ///
+ /// Returns [`None`] if the pattern doesn't match.
+ ///
+ /// # Examples
+ ///
+ /// ```rust
+ /// use clap_lex::OsStrExt as _;
+ /// let s = std::ffi::OsStr::new("Löwe 老虎 Léopard Gepardi");
+ ///
+ /// assert_eq!(s.find("L"), Some(0));
+ /// assert_eq!(s.find("é"), Some(14));
+ /// assert_eq!(s.find("par"), Some(17));
+ /// ```
+ ///
+ /// Not finding the pattern:
+ ///
+ /// ```rust
+ /// use clap_lex::OsStrExt as _;
+ /// let s = std::ffi::OsStr::new("Löwe 老虎 Léopard");
+ ///
+ /// assert_eq!(s.find("1"), None);
+ /// ```
+ fn find(&self, needle: &str) -> Option<usize>;
+ /// Returns a string slice with the prefix removed.
+ ///
+ /// If the string starts with the pattern `prefix`, returns substring after the prefix, wrapped
+ /// in `Some`.
+ ///
+ /// If the string does not start with `prefix`, returns `None`.
+ ///
+ /// # Examples
+ ///
+ /// ```
+ /// use std::ffi::OsStr;
+ /// use clap_lex::OsStrExt as _;
+ /// assert_eq!(OsStr::new("foo:bar").strip_prefix("foo:"), Some(OsStr::new("bar")));
+ /// assert_eq!(OsStr::new("foo:bar").strip_prefix("bar"), None);
+ /// assert_eq!(OsStr::new("foofoo").strip_prefix("foo"), Some(OsStr::new("foo")));
+ /// ```
+ fn strip_prefix(&self, prefix: &str) -> Option<&OsStr>;
+ /// Returns `true` if the given pattern matches a prefix of this
+ /// string slice.
+ ///
+ /// Returns `false` if it does not.
+ ///
+ /// # Examples
+ ///
+ /// ```
+ /// use clap_lex::OsStrExt as _;
+ /// let bananas = std::ffi::OsStr::new("bananas");
+ ///
+ /// assert!(bananas.starts_with("bana"));
+ /// assert!(!bananas.starts_with("nana"));
+ /// ```
+ fn starts_with(&self, prefix: &str) -> bool;
+ /// An iterator over substrings of this string slice, separated by
+ /// characters matched by a pattern.
+ ///
+ /// # Examples
+ ///
+ /// Simple patterns:
+ ///
+ /// ```
+ /// use std::ffi::OsStr;
+ /// use clap_lex::OsStrExt as _;
+ /// let v: Vec<_> = OsStr::new("Mary had a little lamb").split(" ").collect();
+ /// assert_eq!(v, [OsStr::new("Mary"), OsStr::new("had"), OsStr::new("a"), OsStr::new("little"), OsStr::new("lamb")]);
+ ///
+ /// let v: Vec<_> = OsStr::new("").split("X").collect();
+ /// assert_eq!(v, [OsStr::new("")]);
+ ///
+ /// let v: Vec<_> = OsStr::new("lionXXtigerXleopard").split("X").collect();
+ /// assert_eq!(v, [OsStr::new("lion"), OsStr::new(""), OsStr::new("tiger"), OsStr::new("leopard")]);
+ ///
+ /// let v: Vec<_> = OsStr::new("lion::tiger::leopard").split("::").collect();
+ /// assert_eq!(v, [OsStr::new("lion"), OsStr::new("tiger"), OsStr::new("leopard")]);
+ /// ```
+ ///
+ /// If a string contains multiple contiguous separators, you will end up
+ /// with empty strings in the output:
+ ///
+ /// ```
+ /// use std::ffi::OsStr;
+ /// use clap_lex::OsStrExt as _;
+ /// let x = OsStr::new("||||a||b|c");
+ /// let d: Vec<_> = x.split("|").collect();
+ ///
+ /// assert_eq!(d, &[OsStr::new(""), OsStr::new(""), OsStr::new(""), OsStr::new(""), OsStr::new("a"), OsStr::new(""), OsStr::new("b"), OsStr::new("c")]);
+ /// ```
+ ///
+ /// Contiguous separators are separated by the empty string.
+ ///
+ /// ```
+ /// use std::ffi::OsStr;
+ /// use clap_lex::OsStrExt as _;
+ /// let x = OsStr::new("(///)");
+ /// let d: Vec<_> = x.split("/").collect();
+ ///
+ /// assert_eq!(d, &[OsStr::new("("), OsStr::new(""), OsStr::new(""), OsStr::new(")")]);
+ /// ```
+ ///
+ /// Separators at the start or end of a string are neighbored
+ /// by empty strings.
+ ///
+ /// ```
+ /// use std::ffi::OsStr;
+ /// use clap_lex::OsStrExt as _;
+ /// let d: Vec<_> = OsStr::new("010").split("0").collect();
+ /// assert_eq!(d, &[OsStr::new(""), OsStr::new("1"), OsStr::new("")]);
+ /// ```
+ ///
+ /// When the empty string is used as a separator, it panics
+ ///
+ /// ```should_panic
+ /// use std::ffi::OsStr;
+ /// use clap_lex::OsStrExt as _;
+ /// let f: Vec<_> = OsStr::new("rust").split("").collect();
+ /// assert_eq!(f, &[OsStr::new(""), OsStr::new("r"), OsStr::new("u"), OsStr::new("s"), OsStr::new("t"), OsStr::new("")]);
+ /// ```
+ ///
+ /// Contiguous separators can lead to possibly surprising behavior
+ /// when whitespace is used as the separator. This code is correct:
+ ///
+ /// ```
+ /// use std::ffi::OsStr;
+ /// use clap_lex::OsStrExt as _;
+ /// let x = OsStr::new(" a b c");
+ /// let d: Vec<_> = x.split(" ").collect();
+ ///
+ /// assert_eq!(d, &[OsStr::new(""), OsStr::new(""), OsStr::new(""), OsStr::new(""), OsStr::new("a"), OsStr::new(""), OsStr::new("b"), OsStr::new("c")]);
+ /// ```
+ ///
+ /// It does _not_ give you:
+ ///
+ /// ```,ignore
+ /// assert_eq!(d, &[OsStr::new("a"), OsStr::new("b"), OsStr::new("c")]);
+ /// ```
+ ///
+ /// Use [`split_whitespace`] for this behavior.
+ ///
+ /// [`split_whitespace`]: str::split_whitespace
+ fn split<'s, 'n>(&'s self, needle: &'n str) -> Split<'s, 'n>;
+ /// Splits the string on the first occurrence of the specified delimiter and
+ /// returns prefix before delimiter and suffix after delimiter.
+ ///
+ /// # Examples
+ ///
+ /// ```
+ /// use std::ffi::OsStr;
+ /// use clap_lex::OsStrExt as _;
+ /// assert_eq!(OsStr::new("cfg").split_once("="), None);
+ /// assert_eq!(OsStr::new("cfg=").split_once("="), Some((OsStr::new("cfg"), OsStr::new(""))));
+ /// assert_eq!(OsStr::new("cfg=foo").split_once("="), Some((OsStr::new("cfg"), OsStr::new("foo"))));
+ /// assert_eq!(OsStr::new("cfg=foo=bar").split_once("="), Some((OsStr::new("cfg"), OsStr::new("foo=bar"))));
+ /// ```
+ fn split_once(&self, needle: &'_ str) -> Option<(&OsStr, &OsStr)>;
+}
+
+impl OsStrExt for OsStr {
+ fn try_str(&self) -> Result<&str, std::str::Utf8Error> {
+ let bytes = to_bytes(self);
+ std::str::from_utf8(bytes)
+ }
+
+ fn contains(&self, needle: &str) -> bool {
+ self.find(needle).is_some()
+ }
+
+ fn find(&self, needle: &str) -> Option<usize> {
+ let bytes = to_bytes(self);
+ (0..=self.len().checked_sub(needle.len())?)
+ .find(|&x| bytes[x..].starts_with(needle.as_bytes()))
+ }
+
+ fn strip_prefix(&self, prefix: &str) -> Option<&OsStr> {
+ let bytes = to_bytes(self);
+ bytes.strip_prefix(prefix.as_bytes()).map(|s| {
+ // SAFETY:
+ // - This came from `to_bytes`
+ // - Since `prefix` is `&str`, any split will be along UTF-8 boundarie
+ unsafe { to_os_str_unchecked(s) }
+ })
+ }
+ fn starts_with(&self, prefix: &str) -> bool {
+ let bytes = to_bytes(self);
+ bytes.starts_with(prefix.as_bytes())
+ }
+
+ fn split<'s, 'n>(&'s self, needle: &'n str) -> Split<'s, 'n> {
+ assert_ne!(needle, "");
+ Split {
+ haystack: Some(self),
+ needle,
+ }
+ }
+
+ fn split_once(&self, needle: &'_ str) -> Option<(&OsStr, &OsStr)> {
+ let start = self.find(needle)?;
+ let end = start + needle.len();
+ let haystack = to_bytes(self);
+ let first = &haystack[0..start];
+ let second = &haystack[end..];
+ // SAFETY:
+ // - This came from `to_bytes`
+ // - Since `needle` is `&str`, any split will be along UTF-8 boundarie
+ unsafe { Some((to_os_str_unchecked(first), to_os_str_unchecked(second))) }
+ }
+}
+
+mod private {
+ pub trait Sealed {}
+
+ impl Sealed for std::ffi::OsStr {}
+}
+
+/// Allow access to raw bytes
+///
+/// As the non-UTF8 encoding is not defined, the bytes only make sense when compared with
+/// 7-bit ASCII or `&str`
+///
+/// # Compatibility
+///
+/// There is no guarantee how non-UTF8 bytes will be encoded, even within versions of this crate
+/// (since its dependent on rustc)
+fn to_bytes(s: &OsStr) -> &[u8] {
+ // SAFETY:
+ // - Lifetimes are the same
+ // - Types are compatible (`OsStr` is effectively a transparent wrapper for `[u8]`)
+ // - The primary contract is that the encoding for invalid surrogate code points is not
+ // guaranteed which isn't a problem here
+ //
+ // There is a proposal to support this natively (https://github.com/rust-lang/rust/pull/95290)
+ // but its in limbo
+ unsafe { std::mem::transmute(s) }
+}
+
+/// Restore raw bytes as `OsStr`
+///
+/// # Safety
+///
+/// - `&[u8]` must either by a `&str` or originated with `to_bytes` within the same binary
+/// - Any splits of the original `&[u8]` must be done along UTF-8 boundaries
+unsafe fn to_os_str_unchecked(s: &[u8]) -> &OsStr {
+ // SAFETY:
+ // - Lifetimes are the same
+ // - Types are compatible (`OsStr` is effectively a transparent wrapper for `[u8]`)
+ // - The primary contract is that the encoding for invalid surrogate code points is not
+ // guaranteed which isn't a problem here
+ //
+ // There is a proposal to support this natively (https://github.com/rust-lang/rust/pull/95290)
+ // but its in limbo
+ std::mem::transmute(s)
+}
+
+pub struct Split<'s, 'n> {
+ haystack: Option<&'s OsStr>,
+ needle: &'n str,
+}
+
+impl<'s, 'n> Iterator for Split<'s, 'n> {
+ type Item = &'s OsStr;
+
+ fn next(&mut self) -> Option<Self::Item> {
+ let haystack = self.haystack?;
+ match haystack.split_once(self.needle) {
+ Some((first, second)) => {
+ if !haystack.is_empty() {
+ debug_assert_ne!(haystack, second);
+ }
+ self.haystack = Some(second);
+ Some(first)
+ }
+ None => {
+ self.haystack = None;
+ Some(haystack)
+ }
+ }
+ }
+}
+
+/// Split an `OsStr`
+///
+/// # Safety
+///
+/// `index` must be at a valid UTF-8 boundary
+pub(crate) unsafe fn split_at(os: &OsStr, index: usize) -> (&OsStr, &OsStr) {
+ let bytes = to_bytes(os);
+ let (first, second) = bytes.split_at(index);
+ (to_os_str_unchecked(first), to_os_str_unchecked(second))
+}
diff --git a/third_party/rust/clap_lex/src/lib.rs b/third_party/rust/clap_lex/src/lib.rs
new file mode 100644
index 0000000000..d519a10c56
--- /dev/null
+++ b/third_party/rust/clap_lex/src/lib.rs
@@ -0,0 +1,468 @@
+//! Minimal, flexible command-line parser
+//!
+//! As opposed to a declarative parser, this processes arguments as a stream of tokens. As lexing
+//! a command-line is not context-free, we rely on the caller to decide how to interpret the
+//! arguments.
+//!
+//! # Examples
+//!
+//! ```rust
+//! use std::path::PathBuf;
+//! use std::ffi::OsStr;
+//!
+//! type BoxedError = Box<dyn std::error::Error + Send + Sync>;
+//!
+//! #[derive(Debug)]
+//! struct Args {
+//! paths: Vec<PathBuf>,
+//! color: Color,
+//! verbosity: usize,
+//! }
+//!
+//! #[derive(Debug)]
+//! enum Color {
+//! Always,
+//! Auto,
+//! Never,
+//! }
+//!
+//! impl Color {
+//! fn parse(s: Option<&OsStr>) -> Result<Self, BoxedError> {
+//! let s = s.map(|s| s.to_str().ok_or(s));
+//! match s {
+//! Some(Ok("always")) | Some(Ok("")) | None => {
+//! Ok(Color::Always)
+//! }
+//! Some(Ok("auto")) => {
+//! Ok(Color::Auto)
+//! }
+//! Some(Ok("never")) => {
+//! Ok(Color::Never)
+//! }
+//! Some(invalid) => {
+//! Err(format!("Invalid value for `--color`, {invalid:?}").into())
+//! }
+//! }
+//! }
+//! }
+//!
+//! fn parse_args(
+//! raw: impl IntoIterator<Item=impl Into<std::ffi::OsString>>
+//! ) -> Result<Args, BoxedError> {
+//! let mut args = Args {
+//! paths: Vec::new(),
+//! color: Color::Auto,
+//! verbosity: 0,
+//! };
+//!
+//! let raw = clap_lex::RawArgs::new(raw);
+//! let mut cursor = raw.cursor();
+//! raw.next(&mut cursor); // Skip the bin
+//! while let Some(arg) = raw.next(&mut cursor) {
+//! if arg.is_escape() {
+//! args.paths.extend(raw.remaining(&mut cursor).map(PathBuf::from));
+//! } else if arg.is_stdio() {
+//! args.paths.push(PathBuf::from("-"));
+//! } else if let Some((long, value)) = arg.to_long() {
+//! match long {
+//! Ok("verbose") => {
+//! if let Some(value) = value {
+//! return Err(format!("`--verbose` does not take a value, got `{value:?}`").into());
+//! }
+//! args.verbosity += 1;
+//! }
+//! Ok("color") => {
+//! args.color = Color::parse(value)?;
+//! }
+//! _ => {
+//! return Err(
+//! format!("Unexpected flag: --{}", arg.display()).into()
+//! );
+//! }
+//! }
+//! } else if let Some(mut shorts) = arg.to_short() {
+//! while let Some(short) = shorts.next_flag() {
+//! match short {
+//! Ok('v') => {
+//! args.verbosity += 1;
+//! }
+//! Ok('c') => {
+//! let value = shorts.next_value_os();
+//! args.color = Color::parse(value)?;
+//! }
+//! Ok(c) => {
+//! return Err(format!("Unexpected flag: -{c}").into());
+//! }
+//! Err(e) => {
+//! return Err(format!("Unexpected flag: -{}", e.to_string_lossy()).into());
+//! }
+//! }
+//! }
+//! } else {
+//! args.paths.push(PathBuf::from(arg.to_value_os().to_owned()));
+//! }
+//! }
+//!
+//! Ok(args)
+//! }
+//!
+//! let args = parse_args(["bin", "--hello", "world"]);
+//! println!("{args:?}");
+//! ```
+
+mod ext;
+
+use std::ffi::OsStr;
+use std::ffi::OsString;
+
+pub use std::io::SeekFrom;
+
+pub use ext::OsStrExt;
+
+/// Command-line arguments
+#[derive(Default, Clone, Debug, PartialEq, Eq)]
+pub struct RawArgs {
+ items: Vec<OsString>,
+}
+
+impl RawArgs {
+ //// Create an argument list to parse
+ ///
+ /// **NOTE:** The argument returned will be the current binary.
+ ///
+ /// # Example
+ ///
+ /// ```rust,no_run
+ /// # use std::path::PathBuf;
+ /// let raw = clap_lex::RawArgs::from_args();
+ /// let mut cursor = raw.cursor();
+ /// let _bin = raw.next_os(&mut cursor);
+ ///
+ /// let mut paths = raw.remaining(&mut cursor).map(PathBuf::from).collect::<Vec<_>>();
+ /// println!("{paths:?}");
+ /// ```
+ pub fn from_args() -> Self {
+ Self::new(std::env::args_os())
+ }
+
+ //// Create an argument list to parse
+ ///
+ /// # Example
+ ///
+ /// ```rust,no_run
+ /// # use std::path::PathBuf;
+ /// let raw = clap_lex::RawArgs::new(["bin", "foo.txt"]);
+ /// let mut cursor = raw.cursor();
+ /// let _bin = raw.next_os(&mut cursor);
+ ///
+ /// let mut paths = raw.remaining(&mut cursor).map(PathBuf::from).collect::<Vec<_>>();
+ /// println!("{paths:?}");
+ /// ```
+ pub fn new(iter: impl IntoIterator<Item = impl Into<std::ffi::OsString>>) -> Self {
+ let iter = iter.into_iter();
+ Self::from(iter)
+ }
+
+ /// Create a cursor for walking the arguments
+ ///
+ /// # Example
+ ///
+ /// ```rust,no_run
+ /// # use std::path::PathBuf;
+ /// let raw = clap_lex::RawArgs::new(["bin", "foo.txt"]);
+ /// let mut cursor = raw.cursor();
+ /// let _bin = raw.next_os(&mut cursor);
+ ///
+ /// let mut paths = raw.remaining(&mut cursor).map(PathBuf::from).collect::<Vec<_>>();
+ /// println!("{paths:?}");
+ /// ```
+ pub fn cursor(&self) -> ArgCursor {
+ ArgCursor::new()
+ }
+
+ /// Advance the cursor, returning the next [`ParsedArg`]
+ pub fn next(&self, cursor: &mut ArgCursor) -> Option<ParsedArg<'_>> {
+ self.next_os(cursor).map(ParsedArg::new)
+ }
+
+ /// Advance the cursor, returning a raw argument value.
+ pub fn next_os(&self, cursor: &mut ArgCursor) -> Option<&OsStr> {
+ let next = self.items.get(cursor.cursor).map(|s| s.as_os_str());
+ cursor.cursor = cursor.cursor.saturating_add(1);
+ next
+ }
+
+ /// Return the next [`ParsedArg`]
+ pub fn peek(&self, cursor: &ArgCursor) -> Option<ParsedArg<'_>> {
+ self.peek_os(cursor).map(ParsedArg::new)
+ }
+
+ /// Return a raw argument value.
+ pub fn peek_os(&self, cursor: &ArgCursor) -> Option<&OsStr> {
+ self.items.get(cursor.cursor).map(|s| s.as_os_str())
+ }
+
+ /// Return all remaining raw arguments, advancing the cursor to the end
+ ///
+ /// # Example
+ ///
+ /// ```rust,no_run
+ /// # use std::path::PathBuf;
+ /// let raw = clap_lex::RawArgs::new(["bin", "foo.txt"]);
+ /// let mut cursor = raw.cursor();
+ /// let _bin = raw.next_os(&mut cursor);
+ ///
+ /// let mut paths = raw.remaining(&mut cursor).map(PathBuf::from).collect::<Vec<_>>();
+ /// println!("{paths:?}");
+ /// ```
+ pub fn remaining(&self, cursor: &mut ArgCursor) -> impl Iterator<Item = &OsStr> {
+ let remaining = self.items[cursor.cursor..].iter().map(|s| s.as_os_str());
+ cursor.cursor = self.items.len();
+ remaining
+ }
+
+ /// Adjust the cursor's position
+ pub fn seek(&self, cursor: &mut ArgCursor, pos: SeekFrom) {
+ let pos = match pos {
+ SeekFrom::Start(pos) => pos,
+ SeekFrom::End(pos) => (self.items.len() as i64).saturating_add(pos).max(0) as u64,
+ SeekFrom::Current(pos) => (cursor.cursor as i64).saturating_add(pos).max(0) as u64,
+ };
+ let pos = (pos as usize).min(self.items.len());
+ cursor.cursor = pos;
+ }
+
+ /// Inject arguments before the [`RawArgs::next`]
+ pub fn insert(
+ &mut self,
+ cursor: &ArgCursor,
+ insert_items: impl IntoIterator<Item = impl Into<OsString>>,
+ ) {
+ self.items.splice(
+ cursor.cursor..cursor.cursor,
+ insert_items.into_iter().map(Into::into),
+ );
+ }
+
+ /// Any remaining args?
+ pub fn is_end(&self, cursor: &ArgCursor) -> bool {
+ self.peek_os(cursor).is_none()
+ }
+}
+
+impl<I, T> From<I> for RawArgs
+where
+ I: Iterator<Item = T>,
+ T: Into<OsString>,
+{
+ fn from(val: I) -> Self {
+ Self {
+ items: val.map(|x| x.into()).collect(),
+ }
+ }
+}
+
+/// Position within [`RawArgs`]
+#[derive(Clone, Debug, PartialEq, Eq, PartialOrd, Ord)]
+pub struct ArgCursor {
+ cursor: usize,
+}
+
+impl ArgCursor {
+ fn new() -> Self {
+ Self { cursor: 0 }
+ }
+}
+
+/// Command-line Argument
+#[derive(Clone, Debug, PartialEq, Eq, PartialOrd, Ord, Hash)]
+pub struct ParsedArg<'s> {
+ inner: &'s OsStr,
+}
+
+impl<'s> ParsedArg<'s> {
+ fn new(inner: &'s OsStr) -> Self {
+ Self { inner }
+ }
+
+ /// Argument is length of 0
+ pub fn is_empty(&self) -> bool {
+ self.inner.is_empty()
+ }
+
+ /// Does the argument look like a stdio argument (`-`)
+ pub fn is_stdio(&self) -> bool {
+ self.inner == "-"
+ }
+
+ /// Does the argument look like an argument escape (`--`)
+ pub fn is_escape(&self) -> bool {
+ self.inner == "--"
+ }
+
+ /// Does the argument look like a number
+ pub fn is_number(&self) -> bool {
+ self.to_value()
+ .map(|s| s.parse::<f64>().is_ok())
+ .unwrap_or_default()
+ }
+
+ /// Treat as a long-flag
+ pub fn to_long(&self) -> Option<(Result<&str, &OsStr>, Option<&OsStr>)> {
+ let raw = self.inner;
+ let remainder = raw.strip_prefix("--")?;
+ if remainder.is_empty() {
+ debug_assert!(self.is_escape());
+ return None;
+ }
+
+ let (flag, value) = if let Some((p0, p1)) = remainder.split_once("=") {
+ (p0, Some(p1))
+ } else {
+ (remainder, None)
+ };
+ let flag = flag.to_str().ok_or(flag);
+ Some((flag, value))
+ }
+
+ /// Can treat as a long-flag
+ pub fn is_long(&self) -> bool {
+ self.inner.starts_with("--") && !self.is_escape()
+ }
+
+ /// Treat as a short-flag
+ pub fn to_short(&self) -> Option<ShortFlags<'_>> {
+ if let Some(remainder_os) = self.inner.strip_prefix("-") {
+ if remainder_os.starts_with("-") {
+ None
+ } else if remainder_os.is_empty() {
+ debug_assert!(self.is_stdio());
+ None
+ } else {
+ Some(ShortFlags::new(remainder_os))
+ }
+ } else {
+ None
+ }
+ }
+
+ /// Can treat as a short-flag
+ pub fn is_short(&self) -> bool {
+ self.inner.starts_with("-") && !self.is_stdio() && !self.inner.starts_with("--")
+ }
+
+ /// Treat as a value
+ ///
+ /// **NOTE:** May return a flag or an escape.
+ pub fn to_value_os(&self) -> &OsStr {
+ self.inner
+ }
+
+ /// Treat as a value
+ ///
+ /// **NOTE:** May return a flag or an escape.
+ pub fn to_value(&self) -> Result<&str, &OsStr> {
+ self.inner.to_str().ok_or(self.inner)
+ }
+
+ /// Safely print an argument that may contain non-UTF8 content
+ ///
+ /// This may perform lossy conversion, depending on the platform. If you would like an implementation which escapes the path please use Debug instead.
+ pub fn display(&self) -> impl std::fmt::Display + '_ {
+ self.inner.to_string_lossy()
+ }
+}
+
+/// Walk through short flags within a [`ParsedArg`]
+#[derive(Clone, Debug)]
+pub struct ShortFlags<'s> {
+ inner: &'s OsStr,
+ utf8_prefix: std::str::CharIndices<'s>,
+ invalid_suffix: Option<&'s OsStr>,
+}
+
+impl<'s> ShortFlags<'s> {
+ fn new(inner: &'s OsStr) -> Self {
+ let (utf8_prefix, invalid_suffix) = split_nonutf8_once(inner);
+ let utf8_prefix = utf8_prefix.char_indices();
+ Self {
+ inner,
+ utf8_prefix,
+ invalid_suffix,
+ }
+ }
+
+ /// Move the iterator forward by `n` short flags
+ pub fn advance_by(&mut self, n: usize) -> Result<(), usize> {
+ for i in 0..n {
+ self.next().ok_or(i)?.map_err(|_| i)?;
+ }
+ Ok(())
+ }
+
+ /// No short flags left
+ pub fn is_empty(&self) -> bool {
+ self.invalid_suffix.is_none() && self.utf8_prefix.as_str().is_empty()
+ }
+
+ /// Does the short flag look like a number
+ ///
+ /// Ideally call this before doing any iterator
+ pub fn is_number(&self) -> bool {
+ self.invalid_suffix.is_none() && self.utf8_prefix.as_str().parse::<f64>().is_ok()
+ }
+
+ /// Advance the iterator, returning the next short flag on success
+ ///
+ /// On error, returns the invalid-UTF8 value
+ pub fn next_flag(&mut self) -> Option<Result<char, &'s OsStr>> {
+ if let Some((_, flag)) = self.utf8_prefix.next() {
+ return Some(Ok(flag));
+ }
+
+ if let Some(suffix) = self.invalid_suffix {
+ self.invalid_suffix = None;
+ return Some(Err(suffix));
+ }
+
+ None
+ }
+
+ /// Advance the iterator, returning everything left as a value
+ pub fn next_value_os(&mut self) -> Option<&'s OsStr> {
+ if let Some((index, _)) = self.utf8_prefix.next() {
+ self.utf8_prefix = "".char_indices();
+ self.invalid_suffix = None;
+ // SAFETY: `char_indices` ensures `index` is at a valid UTF-8 boundary
+ let remainder = unsafe { ext::split_at(self.inner, index).1 };
+ return Some(remainder);
+ }
+
+ if let Some(suffix) = self.invalid_suffix {
+ self.invalid_suffix = None;
+ return Some(suffix);
+ }
+
+ None
+ }
+}
+
+impl<'s> Iterator for ShortFlags<'s> {
+ type Item = Result<char, &'s OsStr>;
+
+ fn next(&mut self) -> Option<Self::Item> {
+ self.next_flag()
+ }
+}
+
+fn split_nonutf8_once(b: &OsStr) -> (&str, Option<&OsStr>) {
+ match b.try_str() {
+ Ok(s) => (s, None),
+ Err(err) => {
+ // SAFETY: `char_indices` ensures `index` is at a valid UTF-8 boundary
+ let (valid, after_valid) = unsafe { ext::split_at(b, err.valid_up_to()) };
+ let valid = valid.try_str().unwrap();
+ (valid, Some(after_valid))
+ }
+ }
+}