summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cssparser/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
commit8dd16259287f58f9273002717ec4d27e97127719 (patch)
tree3863e62a53829a84037444beab3abd4ed9dfc7d0 /third_party/rust/cssparser/Cargo.toml
parentReleasing progress-linux version 126.0.1-1~progress7.99u1. (diff)
downloadfirefox-8dd16259287f58f9273002717ec4d27e97127719.tar.xz
firefox-8dd16259287f58f9273002717ec4d27e97127719.zip
Merging upstream version 127.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cssparser/Cargo.toml')
-rw-r--r--third_party/rust/cssparser/Cargo.toml41
1 files changed, 23 insertions, 18 deletions
diff --git a/third_party/rust/cssparser/Cargo.toml b/third_party/rust/cssparser/Cargo.toml
index 28312541ae..bceceea9d2 100644
--- a/third_party/rust/cssparser/Cargo.toml
+++ b/third_party/rust/cssparser/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2018"
rust-version = "1.63"
name = "cssparser"
-version = "0.33.0"
+version = "0.34.0"
authors = ["Simon Sapin <simon.sapin@exyr.org>"]
exclude = [
"src/css-parsing-tests/**",
@@ -30,36 +30,41 @@ keywords = [
license = "MPL-2.0"
repository = "https://github.com/servo/rust-cssparser"
-[dependencies]
-dtoa-short = "0.3"
-itoa = "1.0"
-smallvec = "1.0"
+[profile.profiling]
+debug = 2
+inherits = "release"
[dependencies.cssparser-macros]
version = "0.6.1"
-path = "./macros"
+
+[dependencies.dtoa-short]
+version = "0.3"
+
+[dependencies.itoa]
+version = "1.0"
[dependencies.phf]
-version = ">=0.8,<=0.11"
+version = "0.11.2"
features = ["macros"]
[dependencies.serde]
version = "1.0"
+features = ["derive"]
optional = true
-[dev-dependencies]
-difference = "2.0"
-encoding_rs = "0.8"
-serde_json = "1.0"
+[dependencies.smallvec]
+version = "1.0"
+
+[dev-dependencies.difference]
+version = "2.0"
+
+[dev-dependencies.encoding_rs]
+version = "0.8"
+
+[dev-dependencies.serde_json]
+version = "1.0.25"
[features]
bench = []
dummy_match_byte = []
skip_long_tests = []
-
-[workspace]
-members = [
- ".",
- "./macros",
- "./color",
-]