summaryrefslogtreecommitdiffstats
path: root/third_party/rust/darling/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/darling/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/darling/Cargo.toml')
-rw-r--r--third_party/rust/darling/Cargo.toml58
1 files changed, 58 insertions, 0 deletions
diff --git a/third_party/rust/darling/Cargo.toml b/third_party/rust/darling/Cargo.toml
new file mode 100644
index 0000000000..8306cd46fa
--- /dev/null
+++ b/third_party/rust/darling/Cargo.toml
@@ -0,0 +1,58 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "darling"
+version = "0.20.1"
+authors = ["Ted Driggs <ted.driggs@outlook.com>"]
+exclude = [
+ "/.travis.yml",
+ "/publish.sh",
+ "/.github/**",
+]
+description = """
+A proc-macro library for reading attributes into structs when
+implementing custom derives.
+"""
+documentation = "https://docs.rs/darling/0.20.1"
+readme = "README.md"
+license = "MIT"
+repository = "https://github.com/TedDriggs/darling"
+
+[dependencies.darling_core]
+version = "=0.20.1"
+
+[dependencies.darling_macro]
+version = "=0.20.1"
+
+[dev-dependencies.proc-macro2]
+version = "1.0.37"
+
+[dev-dependencies.quote]
+version = "1.0.18"
+
+[dev-dependencies.syn]
+version = "2.0.15"
+
+[features]
+default = ["suggestions"]
+diagnostics = ["darling_core/diagnostics"]
+suggestions = ["darling_core/suggestions"]
+
+[target."cfg(compiletests)".dev-dependencies.rustversion]
+version = "1.0.9"
+
+[target."cfg(compiletests)".dev-dependencies.trybuild]
+version = "1.0.38"
+
+[badges.maintenance]
+status = "actively-developed"