summaryrefslogtreecommitdiffstats
path: root/third_party/rust/dbus/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/dbus/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/dbus/Cargo.toml')
-rw-r--r--third_party/rust/dbus/Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/third_party/rust/dbus/Cargo.toml b/third_party/rust/dbus/Cargo.toml
new file mode 100644
index 0000000000..e1d7e7c49e
--- /dev/null
+++ b/third_party/rust/dbus/Cargo.toml
@@ -0,0 +1,38 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "dbus"
+version = "0.6.5"
+authors = ["David Henningsson <diwic@ubuntu.com>"]
+description = "Bindings to D-Bus, which is a bus commonly used on Linux for inter-process communication."
+documentation = "http://docs.rs/dbus"
+readme = "../README.md"
+keywords = ["D-Bus", "DBus", "IPC"]
+categories = ["os::unix-apis", "api-bindings"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/diwic/dbus-rs"
+[dependencies.libc]
+version = "0.2.7"
+
+[dependencies.libdbus-sys]
+version = "0.2"
+[dev-dependencies.tempdir]
+version = "0.3"
+
+[features]
+no-string-validation = []
+[badges.is-it-maintained-issue-resolution]
+repository = "diwic/dbus-rs"
+
+[badges.is-it-maintained-open-issues]
+repository = "diwic/dbus-rs"