summaryrefslogtreecommitdiffstats
path: root/third_party/rust/derive_arbitrary
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/derive_arbitrary
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/derive_arbitrary')
-rw-r--r--third_party/rust/derive_arbitrary/.cargo-checksum.json1
-rw-r--r--third_party/rust/derive_arbitrary/Cargo.toml52
-rw-r--r--third_party/rust/derive_arbitrary/LICENSE-APACHE201
-rw-r--r--third_party/rust/derive_arbitrary/LICENSE-MIT27
-rw-r--r--third_party/rust/derive_arbitrary/README.md7
-rw-r--r--third_party/rust/derive_arbitrary/src/container_attributes.rs78
-rw-r--r--third_party/rust/derive_arbitrary/src/field_attributes.rs105
-rw-r--r--third_party/rust/derive_arbitrary/src/lib.rs403
8 files changed, 874 insertions, 0 deletions
diff --git a/third_party/rust/derive_arbitrary/.cargo-checksum.json b/third_party/rust/derive_arbitrary/.cargo-checksum.json
new file mode 100644
index 0000000000..95cc15121a
--- /dev/null
+++ b/third_party/rust/derive_arbitrary/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"f1778460809aaf6ac901ebb08f73bde6776318f85be107ab632d855140fea183","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"15656cc11a8331f28c0986b8ab97220d3e76f98e60ed388b5ffad37dfac4710c","README.md":"7059db284b2016ba7355c63a2b14eb732c7b8952286ff1bc4fdde605018a39c4","src/container_attributes.rs":"9342a89e5e5f412159d1a1a88ae4ee0248180f30adc13e61ebf5f96b5f09877f","src/field_attributes.rs":"15093171d7f1e30c2b2523788e54c69c816029b310133ceb1ac811d1f11a76d5","src/lib.rs":"701a9c66e25c3a2151eab9159f6c2fa64ea910ceb6feb225dc97c2734254c265"},"package":"53e0efad4403bfc52dc201159c4b842a246a14b98c64b55dfd0f2d89729dfeb8"} \ No newline at end of file
diff --git a/third_party/rust/derive_arbitrary/Cargo.toml b/third_party/rust/derive_arbitrary/Cargo.toml
new file mode 100644
index 0000000000..3396129b6d
--- /dev/null
+++ b/third_party/rust/derive_arbitrary/Cargo.toml
@@ -0,0 +1,52 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.63.0"
+name = "derive_arbitrary"
+version = "1.3.1"
+authors = [
+ "The Rust-Fuzz Project Developers",
+ "Nick Fitzgerald <fitzgen@gmail.com>",
+ "Manish Goregaokar <manishsmail@gmail.com>",
+ "Andre Bogus <bogusandre@gmail.com>",
+ "Corey Farwell <coreyf@rwell.org>",
+]
+description = "Derives arbitrary traits"
+documentation = "https://docs.rs/arbitrary/"
+readme = "README.md"
+keywords = [
+ "arbitrary",
+ "testing",
+ "derive",
+ "macro",
+]
+categories = ["development-tools::testing"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-fuzz/arbitrary"
+resolver = "1"
+
+[lib]
+proc_macro = true
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "2"
+features = [
+ "derive",
+ "parsing",
+]
diff --git a/third_party/rust/derive_arbitrary/LICENSE-APACHE b/third_party/rust/derive_arbitrary/LICENSE-APACHE
new file mode 100644
index 0000000000..16fe87b06e
--- /dev/null
+++ b/third_party/rust/derive_arbitrary/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/third_party/rust/derive_arbitrary/LICENSE-MIT b/third_party/rust/derive_arbitrary/LICENSE-MIT
new file mode 100644
index 0000000000..d74f9e93d4
--- /dev/null
+++ b/third_party/rust/derive_arbitrary/LICENSE-MIT
@@ -0,0 +1,27 @@
+MIT License
+
+Copyright (c) 2019 Manish Goregaokar
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/third_party/rust/derive_arbitrary/README.md b/third_party/rust/derive_arbitrary/README.md
new file mode 100644
index 0000000000..7f48c75de1
--- /dev/null
+++ b/third_party/rust/derive_arbitrary/README.md
@@ -0,0 +1,7 @@
+# `#[derive(Arbitrary)]`
+
+This crate implements support for automatically deriving [the `Arbitrary`
+trait](https://docs.rs/arbitrary/*/arbitrary/trait.Arbitrary.html).
+
+Don't depend on this crate directly, though. Instead, enable the `"derive"`
+feature of the `arbitrary` crate.
diff --git a/third_party/rust/derive_arbitrary/src/container_attributes.rs b/third_party/rust/derive_arbitrary/src/container_attributes.rs
new file mode 100644
index 0000000000..269131c884
--- /dev/null
+++ b/third_party/rust/derive_arbitrary/src/container_attributes.rs
@@ -0,0 +1,78 @@
+use crate::ARBITRARY_ATTRIBUTE_NAME;
+use syn::{
+ parse::Error, punctuated::Punctuated, DeriveInput, Expr, ExprLit, Lit, Meta, MetaNameValue,
+ Token, TypeParam,
+};
+
+pub struct ContainerAttributes {
+ /// Specify type bounds to be applied to the derived `Arbitrary` implementation instead of the
+ /// default inferred bounds.
+ ///
+ /// ```ignore
+ /// #[arbitrary(bound = "T: Default, U: Debug")]
+ /// ```
+ ///
+ /// Multiple attributes will be combined as long as they don't conflict, e.g.
+ ///
+ /// ```ignore
+ /// #[arbitrary(bound = "T: Default")]
+ /// #[arbitrary(bound = "U: Default")]
+ /// ```
+ pub bounds: Option<Vec<Punctuated<TypeParam, Token![,]>>>,
+}
+
+impl ContainerAttributes {
+ pub fn from_derive_input(derive_input: &DeriveInput) -> Result<Self, Error> {
+ let mut bounds = None;
+
+ for attr in &derive_input.attrs {
+ if !attr.path().is_ident(ARBITRARY_ATTRIBUTE_NAME) {
+ continue;
+ }
+
+ let meta_list = match attr.meta {
+ Meta::List(ref l) => l,
+ _ => {
+ return Err(Error::new_spanned(
+ attr,
+ format!(
+ "invalid `{}` attribute. expected list",
+ ARBITRARY_ATTRIBUTE_NAME
+ ),
+ ))
+ }
+ };
+
+ for nested_meta in
+ meta_list.parse_args_with(Punctuated::<Meta, Token![,]>::parse_terminated)?
+ {
+ match nested_meta {
+ Meta::NameValue(MetaNameValue {
+ path,
+ value:
+ Expr::Lit(ExprLit {
+ lit: Lit::Str(bound_str_lit),
+ ..
+ }),
+ ..
+ }) if path.is_ident("bound") => {
+ bounds
+ .get_or_insert_with(Vec::new)
+ .push(bound_str_lit.parse_with(Punctuated::parse_terminated)?);
+ }
+ _ => {
+ return Err(Error::new_spanned(
+ attr,
+ format!(
+ "invalid `{}` attribute. expected `bound = \"..\"`",
+ ARBITRARY_ATTRIBUTE_NAME,
+ ),
+ ))
+ }
+ }
+ }
+ }
+
+ Ok(Self { bounds })
+ }
+}
diff --git a/third_party/rust/derive_arbitrary/src/field_attributes.rs b/third_party/rust/derive_arbitrary/src/field_attributes.rs
new file mode 100644
index 0000000000..9e5922e04b
--- /dev/null
+++ b/third_party/rust/derive_arbitrary/src/field_attributes.rs
@@ -0,0 +1,105 @@
+use crate::ARBITRARY_ATTRIBUTE_NAME;
+use proc_macro2::{Span, TokenStream, TokenTree};
+use quote::quote;
+use syn::{spanned::Spanned, *};
+
+/// Determines how a value for a field should be constructed.
+#[cfg_attr(test, derive(Debug))]
+pub enum FieldConstructor {
+ /// Assume that Arbitrary is defined for the type of this field and use it (default)
+ Arbitrary,
+
+ /// Places `Default::default()` as a field value.
+ Default,
+
+ /// Use custom function or closure to generate a value for a field.
+ With(TokenStream),
+
+ /// Set a field always to the given value.
+ Value(TokenStream),
+}
+
+pub fn determine_field_constructor(field: &Field) -> Result<FieldConstructor> {
+ let opt_attr = fetch_attr_from_field(field)?;
+ let ctor = match opt_attr {
+ Some(attr) => parse_attribute(attr)?,
+ None => FieldConstructor::Arbitrary,
+ };
+ Ok(ctor)
+}
+
+fn fetch_attr_from_field(field: &Field) -> Result<Option<&Attribute>> {
+ let found_attributes: Vec<_> = field
+ .attrs
+ .iter()
+ .filter(|a| {
+ let path = a.path();
+ let name = quote!(#path).to_string();
+ name == ARBITRARY_ATTRIBUTE_NAME
+ })
+ .collect();
+ if found_attributes.len() > 1 {
+ let name = field.ident.as_ref().unwrap();
+ let msg = format!(
+ "Multiple conflicting #[{ARBITRARY_ATTRIBUTE_NAME}] attributes found on field `{name}`"
+ );
+ return Err(syn::Error::new(field.span(), msg));
+ }
+ Ok(found_attributes.into_iter().next())
+}
+
+fn parse_attribute(attr: &Attribute) -> Result<FieldConstructor> {
+ if let Meta::List(ref meta_list) = attr.meta {
+ parse_attribute_internals(meta_list)
+ } else {
+ let msg = format!("#[{ARBITRARY_ATTRIBUTE_NAME}] must contain a group");
+ Err(syn::Error::new(attr.span(), msg))
+ }
+}
+
+fn parse_attribute_internals(meta_list: &MetaList) -> Result<FieldConstructor> {
+ let mut tokens_iter = meta_list.tokens.clone().into_iter();
+ let token = tokens_iter.next().ok_or_else(|| {
+ let msg = format!("#[{ARBITRARY_ATTRIBUTE_NAME}] cannot be empty.");
+ syn::Error::new(meta_list.span(), msg)
+ })?;
+ match token.to_string().as_ref() {
+ "default" => Ok(FieldConstructor::Default),
+ "with" => {
+ let func_path = parse_assigned_value("with", tokens_iter, meta_list.span())?;
+ Ok(FieldConstructor::With(func_path))
+ }
+ "value" => {
+ let value = parse_assigned_value("value", tokens_iter, meta_list.span())?;
+ Ok(FieldConstructor::Value(value))
+ }
+ _ => {
+ let msg = format!("Unknown option for #[{ARBITRARY_ATTRIBUTE_NAME}]: `{token}`");
+ Err(syn::Error::new(token.span(), msg))
+ }
+ }
+}
+
+// Input:
+// = 2 + 2
+// Output:
+// 2 + 2
+fn parse_assigned_value(
+ opt_name: &str,
+ mut tokens_iter: impl Iterator<Item = TokenTree>,
+ default_span: Span,
+) -> Result<TokenStream> {
+ let eq_sign = tokens_iter.next().ok_or_else(|| {
+ let msg = format!(
+ "Invalid syntax for #[{ARBITRARY_ATTRIBUTE_NAME}], `{opt_name}` is missing assignment."
+ );
+ syn::Error::new(default_span, msg)
+ })?;
+
+ if eq_sign.to_string() == "=" {
+ Ok(tokens_iter.collect())
+ } else {
+ let msg = format!("Invalid syntax for #[{ARBITRARY_ATTRIBUTE_NAME}], expected `=` after `{opt_name}`, got: `{eq_sign}`");
+ Err(syn::Error::new(eq_sign.span(), msg))
+ }
+}
diff --git a/third_party/rust/derive_arbitrary/src/lib.rs b/third_party/rust/derive_arbitrary/src/lib.rs
new file mode 100644
index 0000000000..886bb4924b
--- /dev/null
+++ b/third_party/rust/derive_arbitrary/src/lib.rs
@@ -0,0 +1,403 @@
+extern crate proc_macro;
+
+use proc_macro2::{Span, TokenStream};
+use quote::quote;
+use syn::*;
+
+mod container_attributes;
+mod field_attributes;
+use container_attributes::ContainerAttributes;
+use field_attributes::{determine_field_constructor, FieldConstructor};
+
+static ARBITRARY_ATTRIBUTE_NAME: &str = "arbitrary";
+static ARBITRARY_LIFETIME_NAME: &str = "'arbitrary";
+
+#[proc_macro_derive(Arbitrary, attributes(arbitrary))]
+pub fn derive_arbitrary(tokens: proc_macro::TokenStream) -> proc_macro::TokenStream {
+ let input = syn::parse_macro_input!(tokens as syn::DeriveInput);
+ expand_derive_arbitrary(input)
+ .unwrap_or_else(syn::Error::into_compile_error)
+ .into()
+}
+
+fn expand_derive_arbitrary(input: syn::DeriveInput) -> Result<TokenStream> {
+ let container_attrs = ContainerAttributes::from_derive_input(&input)?;
+
+ let (lifetime_without_bounds, lifetime_with_bounds) =
+ build_arbitrary_lifetime(input.generics.clone());
+
+ let recursive_count = syn::Ident::new(
+ &format!("RECURSIVE_COUNT_{}", input.ident),
+ Span::call_site(),
+ );
+
+ let arbitrary_method =
+ gen_arbitrary_method(&input, lifetime_without_bounds.clone(), &recursive_count)?;
+ let size_hint_method = gen_size_hint_method(&input)?;
+ let name = input.ident;
+
+ // Apply user-supplied bounds or automatic `T: ArbitraryBounds`.
+ let generics = apply_trait_bounds(
+ input.generics,
+ lifetime_without_bounds.clone(),
+ &container_attrs,
+ )?;
+
+ // Build ImplGeneric with a lifetime (https://github.com/dtolnay/syn/issues/90)
+ let mut generics_with_lifetime = generics.clone();
+ generics_with_lifetime
+ .params
+ .push(GenericParam::Lifetime(lifetime_with_bounds));
+ let (impl_generics, _, _) = generics_with_lifetime.split_for_impl();
+
+ // Build TypeGenerics and WhereClause without a lifetime
+ let (_, ty_generics, where_clause) = generics.split_for_impl();
+
+ Ok(quote! {
+ const _: () = {
+ std::thread_local! {
+ #[allow(non_upper_case_globals)]
+ static #recursive_count: std::cell::Cell<u32> = std::cell::Cell::new(0);
+ }
+
+ #[automatically_derived]
+ impl #impl_generics arbitrary::Arbitrary<#lifetime_without_bounds> for #name #ty_generics #where_clause {
+ #arbitrary_method
+ #size_hint_method
+ }
+ };
+ })
+}
+
+// Returns: (lifetime without bounds, lifetime with bounds)
+// Example: ("'arbitrary", "'arbitrary: 'a + 'b")
+fn build_arbitrary_lifetime(generics: Generics) -> (LifetimeParam, LifetimeParam) {
+ let lifetime_without_bounds =
+ LifetimeParam::new(Lifetime::new(ARBITRARY_LIFETIME_NAME, Span::call_site()));
+ let mut lifetime_with_bounds = lifetime_without_bounds.clone();
+
+ for param in generics.params.iter() {
+ if let GenericParam::Lifetime(lifetime_def) = param {
+ lifetime_with_bounds
+ .bounds
+ .push(lifetime_def.lifetime.clone());
+ }
+ }
+
+ (lifetime_without_bounds, lifetime_with_bounds)
+}
+
+fn apply_trait_bounds(
+ mut generics: Generics,
+ lifetime: LifetimeParam,
+ container_attrs: &ContainerAttributes,
+) -> Result<Generics> {
+ // If user-supplied bounds exist, apply them to their matching type parameters.
+ if let Some(config_bounds) = &container_attrs.bounds {
+ let mut config_bounds_applied = 0;
+ for param in generics.params.iter_mut() {
+ if let GenericParam::Type(type_param) = param {
+ if let Some(replacement) = config_bounds
+ .iter()
+ .flatten()
+ .find(|p| p.ident == type_param.ident)
+ {
+ *type_param = replacement.clone();
+ config_bounds_applied += 1;
+ } else {
+ // If no user-supplied bounds exist for this type, delete the original bounds.
+ // This mimics serde.
+ type_param.bounds = Default::default();
+ type_param.default = None;
+ }
+ }
+ }
+ let config_bounds_supplied = config_bounds
+ .iter()
+ .map(|bounds| bounds.len())
+ .sum::<usize>();
+ if config_bounds_applied != config_bounds_supplied {
+ return Err(Error::new(
+ Span::call_site(),
+ format!(
+ "invalid `{}` attribute. too many bounds, only {} out of {} are applicable",
+ ARBITRARY_ATTRIBUTE_NAME, config_bounds_applied, config_bounds_supplied,
+ ),
+ ));
+ }
+ Ok(generics)
+ } else {
+ // Otherwise, inject a `T: Arbitrary` bound for every parameter.
+ Ok(add_trait_bounds(generics, lifetime))
+ }
+}
+
+// Add a bound `T: Arbitrary` to every type parameter T.
+fn add_trait_bounds(mut generics: Generics, lifetime: LifetimeParam) -> Generics {
+ for param in generics.params.iter_mut() {
+ if let GenericParam::Type(type_param) = param {
+ type_param
+ .bounds
+ .push(parse_quote!(arbitrary::Arbitrary<#lifetime>));
+ }
+ }
+ generics
+}
+
+fn with_recursive_count_guard(
+ recursive_count: &syn::Ident,
+ expr: impl quote::ToTokens,
+) -> impl quote::ToTokens {
+ quote! {
+ let guard_against_recursion = u.is_empty();
+ if guard_against_recursion {
+ #recursive_count.with(|count| {
+ if count.get() > 0 {
+ return Err(arbitrary::Error::NotEnoughData);
+ }
+ count.set(count.get() + 1);
+ Ok(())
+ })?;
+ }
+
+ let result = (|| { #expr })();
+
+ if guard_against_recursion {
+ #recursive_count.with(|count| {
+ count.set(count.get() - 1);
+ });
+ }
+
+ result
+ }
+}
+
+fn gen_arbitrary_method(
+ input: &DeriveInput,
+ lifetime: LifetimeParam,
+ recursive_count: &syn::Ident,
+) -> Result<TokenStream> {
+ fn arbitrary_structlike(
+ fields: &Fields,
+ ident: &syn::Ident,
+ lifetime: LifetimeParam,
+ recursive_count: &syn::Ident,
+ ) -> Result<TokenStream> {
+ let arbitrary = construct(fields, |_idx, field| gen_constructor_for_field(field))?;
+ let body = with_recursive_count_guard(recursive_count, quote! { Ok(#ident #arbitrary) });
+
+ let arbitrary_take_rest = construct_take_rest(fields)?;
+ let take_rest_body =
+ with_recursive_count_guard(recursive_count, quote! { Ok(#ident #arbitrary_take_rest) });
+
+ Ok(quote! {
+ fn arbitrary(u: &mut arbitrary::Unstructured<#lifetime>) -> arbitrary::Result<Self> {
+ #body
+ }
+
+ fn arbitrary_take_rest(mut u: arbitrary::Unstructured<#lifetime>) -> arbitrary::Result<Self> {
+ #take_rest_body
+ }
+ })
+ }
+
+ let ident = &input.ident;
+ let output = match &input.data {
+ Data::Struct(data) => arbitrary_structlike(&data.fields, ident, lifetime, recursive_count)?,
+ Data::Union(data) => arbitrary_structlike(
+ &Fields::Named(data.fields.clone()),
+ ident,
+ lifetime,
+ recursive_count,
+ )?,
+ Data::Enum(data) => {
+ let variants: Vec<TokenStream> = data
+ .variants
+ .iter()
+ .enumerate()
+ .map(|(i, variant)| {
+ let idx = i as u64;
+ let variant_name = &variant.ident;
+ construct(&variant.fields, |_, field| gen_constructor_for_field(field))
+ .map(|ctor| quote! { #idx => #ident::#variant_name #ctor })
+ })
+ .collect::<Result<_>>()?;
+
+ let variants_take_rest: Vec<TokenStream> = data
+ .variants
+ .iter()
+ .enumerate()
+ .map(|(i, variant)| {
+ let idx = i as u64;
+ let variant_name = &variant.ident;
+ construct_take_rest(&variant.fields)
+ .map(|ctor| quote! { #idx => #ident::#variant_name #ctor })
+ })
+ .collect::<Result<_>>()?;
+
+ let count = data.variants.len() as u64;
+
+ let arbitrary = with_recursive_count_guard(
+ recursive_count,
+ quote! {
+ // Use a multiply + shift to generate a ranged random number
+ // with slight bias. For details, see:
+ // https://lemire.me/blog/2016/06/30/fast-random-shuffling
+ Ok(match (u64::from(<u32 as arbitrary::Arbitrary>::arbitrary(u)?) * #count) >> 32 {
+ #(#variants,)*
+ _ => unreachable!()
+ })
+ },
+ );
+
+ let arbitrary_take_rest = with_recursive_count_guard(
+ recursive_count,
+ quote! {
+ // Use a multiply + shift to generate a ranged random number
+ // with slight bias. For details, see:
+ // https://lemire.me/blog/2016/06/30/fast-random-shuffling
+ Ok(match (u64::from(<u32 as arbitrary::Arbitrary>::arbitrary(&mut u)?) * #count) >> 32 {
+ #(#variants_take_rest,)*
+ _ => unreachable!()
+ })
+ },
+ );
+
+ quote! {
+ fn arbitrary(u: &mut arbitrary::Unstructured<#lifetime>) -> arbitrary::Result<Self> {
+ #arbitrary
+ }
+
+ fn arbitrary_take_rest(mut u: arbitrary::Unstructured<#lifetime>) -> arbitrary::Result<Self> {
+ #arbitrary_take_rest
+ }
+ }
+ }
+ };
+ Ok(output)
+}
+
+fn construct(
+ fields: &Fields,
+ ctor: impl Fn(usize, &Field) -> Result<TokenStream>,
+) -> Result<TokenStream> {
+ let output = match fields {
+ Fields::Named(names) => {
+ let names: Vec<TokenStream> = names
+ .named
+ .iter()
+ .enumerate()
+ .map(|(i, f)| {
+ let name = f.ident.as_ref().unwrap();
+ ctor(i, f).map(|ctor| quote! { #name: #ctor })
+ })
+ .collect::<Result<_>>()?;
+ quote! { { #(#names,)* } }
+ }
+ Fields::Unnamed(names) => {
+ let names: Vec<TokenStream> = names
+ .unnamed
+ .iter()
+ .enumerate()
+ .map(|(i, f)| ctor(i, f).map(|ctor| quote! { #ctor }))
+ .collect::<Result<_>>()?;
+ quote! { ( #(#names),* ) }
+ }
+ Fields::Unit => quote!(),
+ };
+ Ok(output)
+}
+
+fn construct_take_rest(fields: &Fields) -> Result<TokenStream> {
+ construct(fields, |idx, field| {
+ determine_field_constructor(field).map(|field_constructor| match field_constructor {
+ FieldConstructor::Default => quote!(Default::default()),
+ FieldConstructor::Arbitrary => {
+ if idx + 1 == fields.len() {
+ quote! { arbitrary::Arbitrary::arbitrary_take_rest(u)? }
+ } else {
+ quote! { arbitrary::Arbitrary::arbitrary(&mut u)? }
+ }
+ }
+ FieldConstructor::With(function_or_closure) => quote!((#function_or_closure)(&mut u)?),
+ FieldConstructor::Value(value) => quote!(#value),
+ })
+ })
+}
+
+fn gen_size_hint_method(input: &DeriveInput) -> Result<TokenStream> {
+ let size_hint_fields = |fields: &Fields| {
+ fields
+ .iter()
+ .map(|f| {
+ let ty = &f.ty;
+ determine_field_constructor(f).map(|field_constructor| {
+ match field_constructor {
+ FieldConstructor::Default | FieldConstructor::Value(_) => {
+ quote!((0, Some(0)))
+ }
+ FieldConstructor::Arbitrary => {
+ quote! { <#ty as arbitrary::Arbitrary>::size_hint(depth) }
+ }
+
+ // Note that in this case it's hard to determine what size_hint must be, so size_of::<T>() is
+ // just an educated guess, although it's gonna be inaccurate for dynamically
+ // allocated types (Vec, HashMap, etc.).
+ FieldConstructor::With(_) => {
+ quote! { (::core::mem::size_of::<#ty>(), None) }
+ }
+ }
+ })
+ })
+ .collect::<Result<Vec<TokenStream>>>()
+ .map(|hints| {
+ quote! {
+ arbitrary::size_hint::and_all(&[
+ #( #hints ),*
+ ])
+ }
+ })
+ };
+ let size_hint_structlike = |fields: &Fields| {
+ size_hint_fields(fields).map(|hint| {
+ quote! {
+ #[inline]
+ fn size_hint(depth: usize) -> (usize, Option<usize>) {
+ arbitrary::size_hint::recursion_guard(depth, |depth| #hint)
+ }
+ }
+ })
+ };
+ match &input.data {
+ Data::Struct(data) => size_hint_structlike(&data.fields),
+ Data::Union(data) => size_hint_structlike(&Fields::Named(data.fields.clone())),
+ Data::Enum(data) => data
+ .variants
+ .iter()
+ .map(|v| size_hint_fields(&v.fields))
+ .collect::<Result<Vec<TokenStream>>>()
+ .map(|variants| {
+ quote! {
+ #[inline]
+ fn size_hint(depth: usize) -> (usize, Option<usize>) {
+ arbitrary::size_hint::and(
+ <u32 as arbitrary::Arbitrary>::size_hint(depth),
+ arbitrary::size_hint::recursion_guard(depth, |depth| {
+ arbitrary::size_hint::or_all(&[ #( #variants ),* ])
+ }),
+ )
+ }
+ }
+ }),
+ }
+}
+
+fn gen_constructor_for_field(field: &Field) -> Result<TokenStream> {
+ let ctor = match determine_field_constructor(field)? {
+ FieldConstructor::Default => quote!(Default::default()),
+ FieldConstructor::Arbitrary => quote!(arbitrary::Arbitrary::arbitrary(u)?),
+ FieldConstructor::With(function_or_closure) => quote!((#function_or_closure)(u)?),
+ FieldConstructor::Value(value) => quote!(#value),
+ };
+ Ok(ctor)
+}