summaryrefslogtreecommitdiffstats
path: root/third_party/rust/diplomat-runtime
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/diplomat-runtime
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/diplomat-runtime')
-rw-r--r--third_party/rust/diplomat-runtime/.cargo-checksum.json1
-rw-r--r--third_party/rust/diplomat-runtime/Cargo.toml36
-rw-r--r--third_party/rust/diplomat-runtime/LICENSE-APACHE201
-rw-r--r--third_party/rust/diplomat-runtime/LICENSE-MIT27
-rw-r--r--third_party/rust/diplomat-runtime/src/lib.rs32
-rw-r--r--third_party/rust/diplomat-runtime/src/result.rs60
-rw-r--r--third_party/rust/diplomat-runtime/src/wasm_glue.rs94
-rw-r--r--third_party/rust/diplomat-runtime/src/writeable.rs189
8 files changed, 640 insertions, 0 deletions
diff --git a/third_party/rust/diplomat-runtime/.cargo-checksum.json b/third_party/rust/diplomat-runtime/.cargo-checksum.json
new file mode 100644
index 0000000000..fa0aae0776
--- /dev/null
+++ b/third_party/rust/diplomat-runtime/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"ea77755aae387e62c45564000302e3c7a5ceda3be2f9ef8664e26ee871627b88","LICENSE-APACHE":"639c20c7f14fb122750d5ad1a6cfb116d9bf8d103e709ee40949e5a12a731666","LICENSE-MIT":"3337fe6e4a3830ad87c23cb9d6d750f9a1e5c45efc08de9c76c1a207fc6966c4","src/lib.rs":"1f42457d57ec23fd89f05af631eb73728f37a9790cd604ce1ce94ef153869fb0","src/result.rs":"2b07ce3cbb02a141abc35742f307cc4ef2b097ce610e04d92a50c469f354401d","src/wasm_glue.rs":"3712ccddfeacb98a37be9354a315cc013d9b6ba0bf2f351e0a806112d1f87c15","src/writeable.rs":"80d8a93feba545fcb3150b8daf546f3e060b0c8c11f13917409dd455abe0c3bd"},"package":"f7b0f23d549a46540e26e5490cd44c64ced0d762959f1ffdec6ab0399634cf3c"} \ No newline at end of file
diff --git a/third_party/rust/diplomat-runtime/Cargo.toml b/third_party/rust/diplomat-runtime/Cargo.toml
new file mode 100644
index 0000000000..99c0e4c6ed
--- /dev/null
+++ b/third_party/rust/diplomat-runtime/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "diplomat-runtime"
+version = "0.7.0"
+authors = [
+ "Shadaj Laddad <shadaj@users.noreply.github.com>",
+ "Manish Goregaokar <manishsmail@gmail.com>",
+ "Quinn Okabayashi <QnnOkabayashi@users.noreply.github.com>",
+]
+description = "Common runtime utilities used by diplomat codegen"
+documentation = "https://docs.rs/diplomat_core/"
+keywords = [
+ "ffi",
+ "codegen",
+]
+categories = ["development-tools"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-diplomat/diplomat"
+
+[lib]
+path = "src/lib.rs"
+
+[dependencies.log]
+version = "0.4"
+optional = true
diff --git a/third_party/rust/diplomat-runtime/LICENSE-APACHE b/third_party/rust/diplomat-runtime/LICENSE-APACHE
new file mode 100644
index 0000000000..05fcffa855
--- /dev/null
+++ b/third_party/rust/diplomat-runtime/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright 2022 The Diplomat Developers
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/third_party/rust/diplomat-runtime/LICENSE-MIT b/third_party/rust/diplomat-runtime/LICENSE-MIT
new file mode 100644
index 0000000000..cf62c31bc7
--- /dev/null
+++ b/third_party/rust/diplomat-runtime/LICENSE-MIT
@@ -0,0 +1,27 @@
+MIT License
+
+Copyright (c) 2022 The Diplomat Developers
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/third_party/rust/diplomat-runtime/src/lib.rs b/third_party/rust/diplomat-runtime/src/lib.rs
new file mode 100644
index 0000000000..fa1c5d7dda
--- /dev/null
+++ b/third_party/rust/diplomat-runtime/src/lib.rs
@@ -0,0 +1,32 @@
+#![cfg_attr(not(any(target_arch = "wasm32")), no_std)]
+
+extern crate alloc;
+
+use alloc::alloc::Layout;
+
+#[cfg(target_arch = "wasm32")]
+// defines `extern "C" diplomat_init()`
+mod wasm_glue;
+
+mod writeable;
+pub use writeable::DiplomatWriteable;
+
+mod result;
+pub use result::DiplomatResult;
+
+/// Allocates a buffer of a given size in Rust's memory.
+///
+/// # Safety
+/// - The allocated buffer must be freed with [`diplomat_free()`].
+#[no_mangle]
+pub unsafe extern "C" fn diplomat_alloc(size: usize, align: usize) -> *mut u8 {
+ alloc::alloc::alloc(Layout::from_size_align(size, align).unwrap())
+}
+
+/// Frees a buffer that was allocated in Rust's memory.
+/// # Safety
+/// - `ptr` must be a pointer to a valid buffer allocated by [`diplomat_alloc()`].
+#[no_mangle]
+pub unsafe extern "C" fn diplomat_free(ptr: *mut u8, size: usize, align: usize) {
+ alloc::alloc::dealloc(ptr, Layout::from_size_align(size, align).unwrap())
+}
diff --git a/third_party/rust/diplomat-runtime/src/result.rs b/third_party/rust/diplomat-runtime/src/result.rs
new file mode 100644
index 0000000000..003281fd43
--- /dev/null
+++ b/third_party/rust/diplomat-runtime/src/result.rs
@@ -0,0 +1,60 @@
+use core::mem::ManuallyDrop;
+
+#[repr(C)]
+union DiplomatResultValue<T, E> {
+ ok: ManuallyDrop<T>,
+ err: ManuallyDrop<E>,
+}
+
+/// A `Result`-like type that can be passed across the FFI boundary
+/// as a value. Use this type when returning a result from an FFI
+/// function instead of `Result`.
+#[repr(C)]
+pub struct DiplomatResult<T, E> {
+ value: DiplomatResultValue<T, E>,
+ pub is_ok: bool,
+}
+
+impl<T, E> Drop for DiplomatResult<T, E> {
+ fn drop(&mut self) {
+ unsafe {
+ if self.is_ok {
+ let _ = ManuallyDrop::take(&mut self.value.ok);
+ } else {
+ let _ = ManuallyDrop::take(&mut self.value.err);
+ }
+ }
+ }
+}
+
+impl<T, E> From<Result<T, E>> for DiplomatResult<T, E> {
+ fn from(result: Result<T, E>) -> Self {
+ match result {
+ Result::Ok(ok) => DiplomatResult {
+ value: DiplomatResultValue {
+ ok: ManuallyDrop::new(ok),
+ },
+ is_ok: true,
+ },
+
+ Result::Err(err) => DiplomatResult {
+ value: DiplomatResultValue {
+ err: ManuallyDrop::new(err),
+ },
+ is_ok: false,
+ },
+ }
+ }
+}
+
+impl<T, E> From<DiplomatResult<T, E>> for Result<T, E> {
+ fn from(mut result: DiplomatResult<T, E>) -> Result<T, E> {
+ unsafe {
+ if result.is_ok {
+ Ok(ManuallyDrop::take(&mut result.value.ok))
+ } else {
+ Err(ManuallyDrop::take(&mut result.value.err))
+ }
+ }
+ }
+}
diff --git a/third_party/rust/diplomat-runtime/src/wasm_glue.rs b/third_party/rust/diplomat-runtime/src/wasm_glue.rs
new file mode 100644
index 0000000000..98a46139a3
--- /dev/null
+++ b/third_party/rust/diplomat-runtime/src/wasm_glue.rs
@@ -0,0 +1,94 @@
+use alloc::format;
+use core::panic::PanicInfo;
+
+#[no_mangle]
+unsafe extern "C" fn diplomat_init() {
+ #[cfg(debug_assertions)]
+ std::panic::set_hook(Box::new(panic_handler));
+ #[cfg(feature = "log")]
+ log::set_logger(&ConsoleLogger)
+ .map(|()| log::set_max_level(log::LevelFilter::Debug))
+ .unwrap();
+}
+
+fn panic_handler(info: &PanicInfo) {
+ let msg = match info.payload().downcast_ref::<&'static str>() {
+ Some(&s) => s,
+ None => match info.payload().downcast_ref::<String>() {
+ Some(s) => s.as_str(),
+ None => "Box<Any>",
+ },
+ };
+
+ let msg = match info.location() {
+ Some(l) => format!(
+ "wasm panicked at {}:{}:{}:\n{msg}",
+ l.file(),
+ l.line(),
+ l.column(),
+ ),
+ None => format!("wasm panicked at <unknown location>:\n{msg}"),
+ };
+
+ extern "C" {
+ fn diplomat_throw_error_js(ptr: *const u8, len: usize);
+ }
+
+ unsafe { diplomat_throw_error_js(msg.as_ptr(), msg.len()) }
+}
+
+#[cfg(feature = "log")]
+struct ConsoleLogger;
+
+#[cfg(feature = "log")]
+impl log::Log for ConsoleLogger {
+ #[inline]
+ fn enabled(&self, metadata: &log::Metadata) -> bool {
+ metadata.level() <= log::max_level()
+ }
+
+ fn log(&self, record: &log::Record) {
+ if !self.enabled(record.metadata()) {
+ return;
+ }
+
+ let out = match record.level() {
+ log::Level::Error => {
+ extern "C" {
+ fn diplomat_console_error_js(ptr: *const u8, len: usize);
+ }
+ diplomat_console_error_js
+ }
+ log::Level::Warn => {
+ extern "C" {
+ fn diplomat_console_warn_js(ptr: *const u8, len: usize);
+ }
+ diplomat_console_warn_js
+ }
+ log::Level::Info => {
+ extern "C" {
+ fn diplomat_console_info_js(ptr: *const u8, len: usize);
+ }
+ diplomat_console_info_js
+ }
+ log::Level::Debug => {
+ extern "C" {
+ fn diplomat_console_log_js(ptr: *const u8, len: usize);
+ }
+ diplomat_console_log_js
+ }
+ log::Level::Trace => {
+ extern "C" {
+ fn diplomat_console_debug_js(ptr: *const u8, len: usize);
+ }
+ diplomat_console_debug_js
+ }
+ };
+
+ let msg = alloc::format!("{}", record.args());
+
+ unsafe { out(msg.as_ptr(), msg.len()) };
+ }
+
+ fn flush(&self) {}
+}
diff --git a/third_party/rust/diplomat-runtime/src/writeable.rs b/third_party/rust/diplomat-runtime/src/writeable.rs
new file mode 100644
index 0000000000..d37f4197b5
--- /dev/null
+++ b/third_party/rust/diplomat-runtime/src/writeable.rs
@@ -0,0 +1,189 @@
+use alloc::boxed::Box;
+use alloc::vec::Vec;
+use core::ffi::c_void;
+use core::{fmt, ptr};
+
+/// An object that can one can write UTF-8 strings to
+///
+/// This allows the C API to write to arbitrary kinds of objects, for example a
+/// C++ std::string or a char buffer.
+///
+/// The way to use this object is to fill out the `buf`, `len`, `cap` fields with
+/// appropriate values for the buffer, its current length, and its current capacity,
+/// and `flush` and `grow` with appropriate callbacks (using `context` to reference any
+/// state they need). This object will be passed by mutable reference to the Rust side,
+/// and Rust will write to it, calling `grow()` as necessary. Once done, it will call `flush()`
+/// to update any state on `context` (e.g. adding a null terminator, updating the length).
+/// The object on the foreign side will be directly usable after this, the foreign side
+/// need not perform additional state updates after passing an [`DiplomatWriteable`] to
+/// a function.
+///
+/// [`diplomat_simple_writeable()`] can be used to write to a fixed-size char buffer.
+///
+/// May be extended in the future to support further invariants
+///
+/// DiplomatWriteable will not perform any cleanup on `context` or `buf`, these are logically
+/// "borrows" from the FFI side.
+///
+/// # Safety invariants:
+/// - `flush()` and `grow()` will be passed `self` including `context` and it should always be safe to do so.
+/// `context` may be null, however `flush()` and `grow()` must then be ready to receive it as such.
+/// - `buf` must be `cap` bytes long
+/// - `grow()` must either return false or update `buf` and `cap` for a valid buffer
+/// of at least the requested buffer size
+/// - `DiplomatWriteable::flush()` will be automatically called by Diplomat. `flush()` might also be called
+/// (erroneously) on the Rust side (it's a public method), so it must be idempotent.
+#[repr(C)]
+pub struct DiplomatWriteable {
+ /// Context pointer for additional data needed by `grow()` and `flush()`. May be `null`.
+ ///
+ /// The pointer may reference structured data on the foreign side,
+ /// such as C++ std::string, used to reallocate buf.
+ context: *mut c_void,
+ /// The raw string buffer, which will be mutated on the Rust side.
+ buf: *mut u8,
+ /// The current filled size of the buffer
+ len: usize,
+ /// The current capacity of the buffer
+ cap: usize,
+ /// Called by Rust to indicate that there is no more data to write.
+ ///
+ /// May be called multiple times.
+ ///
+ /// Arguments:
+ /// - `self` (`*mut DiplomatWriteable`): This `DiplomatWriteable`
+ flush: extern "C" fn(*mut DiplomatWriteable),
+ /// Called by Rust to request more capacity in the buffer. The implementation should allocate a new
+ /// buffer and copy the contents of the old buffer into the new buffer, updating `self.buf` and `self.cap`
+ ///
+ /// Arguments:
+ /// - `self` (`*mut DiplomatWriteable`): This `DiplomatWriteable`
+ /// - `capacity` (`usize`): The requested capacity.
+ ///
+ /// Returns: `true` if the allocation succeeded. Should not update any state if it failed.
+ grow: extern "C" fn(*mut DiplomatWriteable, usize) -> bool,
+}
+
+impl DiplomatWriteable {
+ /// Call this function before releasing the buffer to C
+ pub fn flush(&mut self) {
+ (self.flush)(self);
+ }
+}
+impl fmt::Write for DiplomatWriteable {
+ fn write_str(&mut self, s: &str) -> Result<(), fmt::Error> {
+ let needed_len = self.len + s.len();
+ if needed_len > self.cap {
+ let success = (self.grow)(self, needed_len);
+ if !success {
+ return Err(fmt::Error);
+ }
+ }
+ debug_assert!(needed_len <= self.cap);
+ unsafe {
+ ptr::copy_nonoverlapping(s.as_bytes().as_ptr(), self.buf.add(self.len), s.len());
+ }
+ self.len = needed_len;
+ Ok(())
+ }
+}
+
+/// Create an `DiplomatWriteable` that can write to a fixed-length stack allocated `u8` buffer.
+///
+/// Once done, this will append a null terminator to the written string.
+///
+/// # Safety
+///
+/// - `buf` must be a valid pointer to a region of memory that can hold at `buf_size` bytes
+#[no_mangle]
+pub unsafe extern "C" fn diplomat_simple_writeable(
+ buf: *mut u8,
+ buf_size: usize,
+) -> DiplomatWriteable {
+ extern "C" fn grow(_this: *mut DiplomatWriteable, _cap: usize) -> bool {
+ false
+ }
+ extern "C" fn flush(this: *mut DiplomatWriteable) {
+ unsafe {
+ debug_assert!((*this).len <= (*this).cap);
+ let buf = (*this).buf;
+ ptr::write(buf.add((*this).len), 0)
+ }
+ }
+ DiplomatWriteable {
+ context: ptr::null_mut(),
+ buf,
+ len: 0,
+ // keep an extra byte in our pocket for the null terminator
+ cap: buf_size - 1,
+ flush,
+ grow,
+ }
+}
+
+/// Create an [`DiplomatWriteable`] that can write to a dynamically allocated buffer managed by Rust.
+///
+/// Use [`diplomat_buffer_writeable_destroy()`] to free the writable and its underlying buffer.
+#[no_mangle]
+pub extern "C" fn diplomat_buffer_writeable_create(cap: usize) -> *mut DiplomatWriteable {
+ extern "C" fn grow(this: *mut DiplomatWriteable, new_cap: usize) -> bool {
+ unsafe {
+ let this = this.as_mut().unwrap();
+ let mut vec = Vec::from_raw_parts(this.buf, 0, this.cap);
+ vec.reserve(new_cap);
+ this.cap = vec.capacity();
+ this.buf = vec.as_mut_ptr();
+ core::mem::forget(vec);
+ }
+ true
+ }
+
+ extern "C" fn flush(_: *mut DiplomatWriteable) {}
+
+ let mut vec = Vec::<u8>::with_capacity(cap);
+ let ret = DiplomatWriteable {
+ context: ptr::null_mut(),
+ buf: vec.as_mut_ptr(),
+ len: 0,
+ cap,
+ flush,
+ grow,
+ };
+
+ core::mem::forget(vec);
+ Box::into_raw(Box::new(ret))
+}
+
+/// Grabs a pointer to the underlying buffer of a writable.
+///
+/// # Safety
+/// - The returned pointer is valid until the passed writable is destroyed.
+/// - `this` must be a pointer to a valid [`DiplomatWriteable`] constructed by
+/// [`diplomat_buffer_writeable_create()`].
+#[no_mangle]
+pub extern "C" fn diplomat_buffer_writeable_get_bytes(this: &DiplomatWriteable) -> *mut u8 {
+ this.buf
+}
+
+/// Gets the length in bytes of the content written to the writable.
+///
+/// # Safety
+/// - `this` must be a pointer to a valid [`DiplomatWriteable`] constructed by
+/// [`diplomat_buffer_writeable_create()`].
+#[no_mangle]
+pub extern "C" fn diplomat_buffer_writeable_len(this: &DiplomatWriteable) -> usize {
+ this.len
+}
+
+/// Destructor for Rust-memory backed writables.
+///
+/// # Safety
+/// - `this` must be a pointer to a valid [`DiplomatWriteable`] constructed by
+/// [`diplomat_buffer_writeable_create()`].
+#[no_mangle]
+pub unsafe extern "C" fn diplomat_buffer_writeable_destroy(this: *mut DiplomatWriteable) {
+ let this = Box::from_raw(this);
+ let vec = Vec::from_raw_parts(this.buf, 0, this.cap);
+ drop(vec);
+ drop(this);
+}