summaryrefslogtreecommitdiffstats
path: root/third_party/rust/diplomat/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/diplomat/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/diplomat/Cargo.toml')
-rw-r--r--third_party/rust/diplomat/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/diplomat/Cargo.toml b/third_party/rust/diplomat/Cargo.toml
new file mode 100644
index 0000000000..af5ef28fa6
--- /dev/null
+++ b/third_party/rust/diplomat/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "diplomat"
+version = "0.7.0"
+authors = [
+ "Shadaj Laddad <shadaj@users.noreply.github.com>",
+ "Manish Goregaokar <manishsmail@gmail.com>",
+ "Quinn Okabayashi <QnnOkabayashi@users.noreply.github.com>",
+]
+description = "The diplomat FFI generation macro"
+documentation = "https://docs.rs/diplomat_core/"
+keywords = [
+ "ffi",
+ "codegen",
+]
+categories = ["development-tools"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-diplomat/diplomat"
+
+[lib]
+path = "src/lib.rs"
+proc-macro = true
+
+[dependencies.diplomat_core]
+version = "0.7.0"
+
+[dependencies.proc-macro2]
+version = "1.0.27"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "2.0"
+features = [
+ "full",
+ "extra-traits",
+]
+
+[dev-dependencies.insta]
+version = "1.7.1"
+
+[dev-dependencies.tempfile]
+version = "3.2.0"