summaryrefslogtreecommitdiffstats
path: root/third_party/rust/dwrote/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/dwrote/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/dwrote/Cargo.toml')
-rw-r--r--third_party/rust/dwrote/Cargo.toml47
1 files changed, 47 insertions, 0 deletions
diff --git a/third_party/rust/dwrote/Cargo.toml b/third_party/rust/dwrote/Cargo.toml
new file mode 100644
index 0000000000..6fac8fcff0
--- /dev/null
+++ b/third_party/rust/dwrote/Cargo.toml
@@ -0,0 +1,47 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "dwrote"
+version = "0.11.0"
+authors = ["The Servo Project Developers", "Vladimir Vukicevic <vladimir@pobox.com>"]
+description = "Lightweight binding to DirectWrite."
+license = "MPL-2.0"
+repository = "https://github.com/servo/dwrote-rs"
+
+[lib]
+name = "dwrote"
+[dependencies.lazy_static]
+version = "1"
+
+[dependencies.libc]
+version = "0.2"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dependencies.serde_derive]
+version = "1.0"
+optional = true
+
+[dependencies.winapi]
+version = "0.3.6"
+features = ["dwrite", "dwrite_1", "dwrite_3", "winnt", "unknwnbase", "libloaderapi", "winnls"]
+
+[dependencies.wio]
+version = "0.2"
+
+[features]
+default = ["serde_serialization"]
+serde_serialization = ["serde", "serde_derive"]