summaryrefslogtreecommitdiffstats
path: root/third_party/rust/enum-map-derive
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/enum-map-derive
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/enum-map-derive')
-rw-r--r--third_party/rust/enum-map-derive/.cargo-checksum.json1
-rw-r--r--third_party/rust/enum-map-derive/Cargo.toml54
-rw-r--r--third_party/rust/enum-map-derive/LICENSES/Apache-2.0.txt73
-rw-r--r--third_party/rust/enum-map-derive/LICENSES/CC0-1.0.txt121
-rw-r--r--third_party/rust/enum-map-derive/LICENSES/MIT.txt9
-rw-r--r--third_party/rust/enum-map-derive/README.md10
-rw-r--r--third_party/rust/enum-map-derive/src/derive_enum.rs216
-rw-r--r--third_party/rust/enum-map-derive/src/derive_struct.rs129
-rw-r--r--third_party/rust/enum-map-derive/src/lib.rs178
9 files changed, 791 insertions, 0 deletions
diff --git a/third_party/rust/enum-map-derive/.cargo-checksum.json b/third_party/rust/enum-map-derive/.cargo-checksum.json
new file mode 100644
index 0000000000..2650ba111c
--- /dev/null
+++ b/third_party/rust/enum-map-derive/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"ebe51a5658f0e34f3f31cd0f4af2a90affbc5e562b6d4695fab1ae31348c2590","LICENSES/Apache-2.0.txt":"074e6e32c86a4c0ef8b3ed25b721ca23aca83df277cd88106ef7177c354615ff","LICENSES/CC0-1.0.txt":"a2010f343487d3f7618affe54f789f5487602331c0a8d03f49e9a7c547cf0499","LICENSES/MIT.txt":"b85dcd3e453d05982552c52b5fc9e0bdd6d23c6f8e844b984a88af32570b0cc0","README.md":"9ba5f04156a8fb4aeec6af6db17b6716c18dc73e1db59300340591f246f4558e","src/derive_enum.rs":"fc478b32e580dabfa31f71db2958faf05125e58b17bf420a881930d96e76ce11","src/derive_struct.rs":"ec7e4d1f44925713098713c8c77af87142f499999a812687d52306cc9255224f","src/lib.rs":"531dd501eced4ebf2733d525417adc9ef724e1c117ffb20be7453a79200c2988"},"package":"f282cfdfe92516eb26c2af8589c274c7c17681f5ecc03c18255fe741c6aa64eb"} \ No newline at end of file
diff --git a/third_party/rust/enum-map-derive/Cargo.toml b/third_party/rust/enum-map-derive/Cargo.toml
new file mode 100644
index 0000000000..2e17e5d8ee
--- /dev/null
+++ b/third_party/rust/enum-map-derive/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.61"
+name = "enum-map-derive"
+version = "0.17.0"
+authors = ["Kamila Borowska <kamila@borowska.pw>"]
+description = "Macros 1.1 implementation of #[derive(Enum)]"
+readme = "README.md"
+keywords = [
+ "data-structure",
+ "no_std",
+ "enum",
+]
+categories = [
+ "data-structures",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://codeberg.org/xfix/enum-map"
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0.60"
+
+[dependencies.quote]
+version = "1.0.7"
+
+[dependencies.syn]
+version = "2.0.0"
+features = [
+ "derive",
+ "parsing",
+ "printing",
+ "proc-macro",
+]
+default-features = false
+
+[dev-dependencies]
+
+[badges.maintenance]
+status = "passively-maintained"
diff --git a/third_party/rust/enum-map-derive/LICENSES/Apache-2.0.txt b/third_party/rust/enum-map-derive/LICENSES/Apache-2.0.txt
new file mode 100644
index 0000000000..137069b823
--- /dev/null
+++ b/third_party/rust/enum-map-derive/LICENSES/Apache-2.0.txt
@@ -0,0 +1,73 @@
+Apache License
+Version 2.0, January 2004
+http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by Sections 1 through 9 of this document.
+
+"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is granting the License.
+
+"Legal Entity" shall mean the union of the acting entity and all other entities that control, are controlled by, or are under common control with that entity. For the purposes of this definition, "control" means (i) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the outstanding shares, or (iii) beneficial ownership of such entity.
+
+"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License.
+
+"Source" form shall mean the preferred form for making modifications, including but not limited to software source code, documentation source, and configuration files.
+
+"Object" form shall mean any form resulting from mechanical transformation or translation of a Source form, including but not limited to compiled object code, generated documentation, and conversions to other media types.
+
+"Work" shall mean the work of authorship, whether in Source or Object form, made available under the License, as indicated by a copyright notice that is included in or attached to the work (an example is provided in the Appendix below).
+
+"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from) the Work and for which the editorial revisions, annotations, elaborations, or other modifications represent, as a whole, an original work of authorship. For the purposes of this License, Derivative Works shall not include works that remain separable from, or merely link (or bind by name) to the interfaces of, the Work and Derivative Works thereof.
+
+"Contribution" shall mean any work of authorship, including the original version of the Work and any modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this definition, "submitted" means any form of electronic, verbal, or written communication sent to the Licensor or its representatives, including but not limited to communication on electronic mailing lists, source code control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding communication that is conspicuously marked or otherwise designated in writing by the copyright owner as "Not a Contribution."
+
+"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution has been received by Licensor and subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this section) patent license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work, where such license applies only to those patent claims licensable by such Contributor that are necessarily infringed by their Contribution(s) alone or by combination of their Contribution(s) with the Work to which such Contribution(s) was submitted. If You institute patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the Work constitutes direct or contributory patent infringement, then any patent licenses granted to You under this License for that Work shall terminate as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions:
+
+ (a) You must give any other recipients of the Work or Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE file are for informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of this License, without any additional terms or conditions. Notwithstanding the above, nothing herein shall supersede or modify the terms of any separate license agreement you may have executed with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade names, trademarks, service marks, or product names of the Licensor, except as required for reasonable and customary use in describing the origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or redistributing the Work and assume any risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory, whether in tort (including negligence), contract, or otherwise, unless required by applicable law (such as deliberate and grossly negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, including any direct, indirect, special, incidental, or consequential damages of any character arising as a result of this License or out of the use or inability to use the Work (including but not limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any and all other commercial damages or losses), even if such Contributor has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works thereof, You may choose to offer, and charge a fee for, acceptance of support, warranty, indemnity, or other liability obligations and/or rights consistent with this License. However, in accepting such obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+To apply the Apache License to your work, attach the following boilerplate notice, with the fields enclosed by brackets "[]" replaced with your own identifying information. (Don't include the brackets!) The text should be enclosed in the appropriate comment syntax for the file format. We also recommend that a file or class name and description of purpose be included on the same "printed page" as the copyright notice for easier identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/third_party/rust/enum-map-derive/LICENSES/CC0-1.0.txt b/third_party/rust/enum-map-derive/LICENSES/CC0-1.0.txt
new file mode 100644
index 0000000000..0e259d42c9
--- /dev/null
+++ b/third_party/rust/enum-map-derive/LICENSES/CC0-1.0.txt
@@ -0,0 +1,121 @@
+Creative Commons Legal Code
+
+CC0 1.0 Universal
+
+ CREATIVE COMMONS CORPORATION IS NOT A LAW FIRM AND DOES NOT PROVIDE
+ LEGAL SERVICES. DISTRIBUTION OF THIS DOCUMENT DOES NOT CREATE AN
+ ATTORNEY-CLIENT RELATIONSHIP. CREATIVE COMMONS PROVIDES THIS
+ INFORMATION ON AN "AS-IS" BASIS. CREATIVE COMMONS MAKES NO WARRANTIES
+ REGARDING THE USE OF THIS DOCUMENT OR THE INFORMATION OR WORKS
+ PROVIDED HEREUNDER, AND DISCLAIMS LIABILITY FOR DAMAGES RESULTING FROM
+ THE USE OF THIS DOCUMENT OR THE INFORMATION OR WORKS PROVIDED
+ HEREUNDER.
+
+Statement of Purpose
+
+The laws of most jurisdictions throughout the world automatically confer
+exclusive Copyright and Related Rights (defined below) upon the creator
+and subsequent owner(s) (each and all, an "owner") of an original work of
+authorship and/or a database (each, a "Work").
+
+Certain owners wish to permanently relinquish those rights to a Work for
+the purpose of contributing to a commons of creative, cultural and
+scientific works ("Commons") that the public can reliably and without fear
+of later claims of infringement build upon, modify, incorporate in other
+works, reuse and redistribute as freely as possible in any form whatsoever
+and for any purposes, including without limitation commercial purposes.
+These owners may contribute to the Commons to promote the ideal of a free
+culture and the further production of creative, cultural and scientific
+works, or to gain reputation or greater distribution for their Work in
+part through the use and efforts of others.
+
+For these and/or other purposes and motivations, and without any
+expectation of additional consideration or compensation, the person
+associating CC0 with a Work (the "Affirmer"), to the extent that he or she
+is an owner of Copyright and Related Rights in the Work, voluntarily
+elects to apply CC0 to the Work and publicly distribute the Work under its
+terms, with knowledge of his or her Copyright and Related Rights in the
+Work and the meaning and intended legal effect of CC0 on those rights.
+
+1. Copyright and Related Rights. A Work made available under CC0 may be
+protected by copyright and related or neighboring rights ("Copyright and
+Related Rights"). Copyright and Related Rights include, but are not
+limited to, the following:
+
+ i. the right to reproduce, adapt, distribute, perform, display,
+ communicate, and translate a Work;
+ ii. moral rights retained by the original author(s) and/or performer(s);
+iii. publicity and privacy rights pertaining to a person's image or
+ likeness depicted in a Work;
+ iv. rights protecting against unfair competition in regards to a Work,
+ subject to the limitations in paragraph 4(a), below;
+ v. rights protecting the extraction, dissemination, use and reuse of data
+ in a Work;
+ vi. database rights (such as those arising under Directive 96/9/EC of the
+ European Parliament and of the Council of 11 March 1996 on the legal
+ protection of databases, and under any national implementation
+ thereof, including any amended or successor version of such
+ directive); and
+vii. other similar, equivalent or corresponding rights throughout the
+ world based on applicable law or treaty, and any national
+ implementations thereof.
+
+2. Waiver. To the greatest extent permitted by, but not in contravention
+of, applicable law, Affirmer hereby overtly, fully, permanently,
+irrevocably and unconditionally waives, abandons, and surrenders all of
+Affirmer's Copyright and Related Rights and associated claims and causes
+of action, whether now known or unknown (including existing as well as
+future claims and causes of action), in the Work (i) in all territories
+worldwide, (ii) for the maximum duration provided by applicable law or
+treaty (including future time extensions), (iii) in any current or future
+medium and for any number of copies, and (iv) for any purpose whatsoever,
+including without limitation commercial, advertising or promotional
+purposes (the "Waiver"). Affirmer makes the Waiver for the benefit of each
+member of the public at large and to the detriment of Affirmer's heirs and
+successors, fully intending that such Waiver shall not be subject to
+revocation, rescission, cancellation, termination, or any other legal or
+equitable action to disrupt the quiet enjoyment of the Work by the public
+as contemplated by Affirmer's express Statement of Purpose.
+
+3. Public License Fallback. Should any part of the Waiver for any reason
+be judged legally invalid or ineffective under applicable law, then the
+Waiver shall be preserved to the maximum extent permitted taking into
+account Affirmer's express Statement of Purpose. In addition, to the
+extent the Waiver is so judged Affirmer hereby grants to each affected
+person a royalty-free, non transferable, non sublicensable, non exclusive,
+irrevocable and unconditional license to exercise Affirmer's Copyright and
+Related Rights in the Work (i) in all territories worldwide, (ii) for the
+maximum duration provided by applicable law or treaty (including future
+time extensions), (iii) in any current or future medium and for any number
+of copies, and (iv) for any purpose whatsoever, including without
+limitation commercial, advertising or promotional purposes (the
+"License"). The License shall be deemed effective as of the date CC0 was
+applied by Affirmer to the Work. Should any part of the License for any
+reason be judged legally invalid or ineffective under applicable law, such
+partial invalidity or ineffectiveness shall not invalidate the remainder
+of the License, and in such case Affirmer hereby affirms that he or she
+will not (i) exercise any of his or her remaining Copyright and Related
+Rights in the Work or (ii) assert any associated claims and causes of
+action with respect to the Work, in either case contrary to Affirmer's
+express Statement of Purpose.
+
+4. Limitations and Disclaimers.
+
+ a. No trademark or patent rights held by Affirmer are waived, abandoned,
+ surrendered, licensed or otherwise affected by this document.
+ b. Affirmer offers the Work as-is and makes no representations or
+ warranties of any kind concerning the Work, express, implied,
+ statutory or otherwise, including without limitation warranties of
+ title, merchantability, fitness for a particular purpose, non
+ infringement, or the absence of latent or other defects, accuracy, or
+ the present or absence of errors, whether or not discoverable, all to
+ the greatest extent permissible under applicable law.
+ c. Affirmer disclaims responsibility for clearing rights of other persons
+ that may apply to the Work or any use thereof, including without
+ limitation any person's Copyright and Related Rights in the Work.
+ Further, Affirmer disclaims responsibility for obtaining any necessary
+ consents, permissions or other rights required for any use of the
+ Work.
+ d. Affirmer understands and acknowledges that Creative Commons is not a
+ party to this document and has no duty or obligation with respect to
+ this CC0 or use of the Work.
diff --git a/third_party/rust/enum-map-derive/LICENSES/MIT.txt b/third_party/rust/enum-map-derive/LICENSES/MIT.txt
new file mode 100644
index 0000000000..2071b23b0e
--- /dev/null
+++ b/third_party/rust/enum-map-derive/LICENSES/MIT.txt
@@ -0,0 +1,9 @@
+MIT License
+
+Copyright (c) <year> <copyright holders>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/third_party/rust/enum-map-derive/README.md b/third_party/rust/enum-map-derive/README.md
new file mode 100644
index 0000000000..a5b8481d7d
--- /dev/null
+++ b/third_party/rust/enum-map-derive/README.md
@@ -0,0 +1,10 @@
+<!--
+SPDX-FileCopyrightText: 2022 Kamila Borowska <kamila@borowska.pw>
+
+SPDX-License-Identifier: MIT OR Apache-2.0
+-->
+
+# enum-map-derive
+
+This is a derive macro for `enum-map`. You don't need to specify it
+in dependencies as `enum-map` crate re-exports it.
diff --git a/third_party/rust/enum-map-derive/src/derive_enum.rs b/third_party/rust/enum-map-derive/src/derive_enum.rs
new file mode 100644
index 0000000000..8dce3de984
--- /dev/null
+++ b/third_party/rust/enum-map-derive/src/derive_enum.rs
@@ -0,0 +1,216 @@
+// SPDX-FileCopyrightText: 2021 - 2023 Kamila Borowska <kamila@borowska.pw>
+// SPDX-FileCopyrightText: 2021 Bruno Corrêa Zimmermann <brunoczim@gmail.com>
+//
+// SPDX-License-Identifier: MIT OR Apache-2.0
+
+use crate::type_length;
+use proc_macro2::TokenStream;
+use quote::{format_ident, quote, ToTokens};
+use syn::{DataEnum, Fields, FieldsNamed, FieldsUnnamed, Ident, Variant};
+
+pub fn generate(name: Ident, data_enum: DataEnum) -> TokenStream {
+ let mut generator = EnumGenerator::empty();
+ for variant in &data_enum.variants {
+ generator.handle_variant(variant);
+ }
+ generator.finish(&name)
+}
+
+#[derive(Debug)]
+struct Length {
+ units: usize,
+ opaque: TokenStream,
+}
+
+impl ToTokens for Length {
+ fn to_tokens(&self, tokens: &mut TokenStream) {
+ let Self { units, opaque } = self;
+ tokens.extend(quote! { (#units + #opaque) });
+ }
+}
+
+/// Total length is the sum of each variant's length. To represent a variant, its number is added to
+/// the sum of previous variant lengths.
+#[derive(Debug)]
+struct EnumGenerator {
+ length: Length,
+ from_usize_arms: TokenStream,
+ into_usize_arms: TokenStream,
+}
+
+impl EnumGenerator {
+ fn empty() -> Self {
+ Self {
+ length: Length {
+ units: 0,
+ opaque: quote! { 0 },
+ },
+ from_usize_arms: quote! {},
+ into_usize_arms: quote! {},
+ }
+ }
+
+ fn finish(&self, name: &Ident) -> TokenStream {
+ let Self {
+ length,
+ from_usize_arms,
+ into_usize_arms,
+ } = self;
+
+ quote! {
+ #[automatically_derived]
+ impl ::enum_map::Enum for #name {
+ const LENGTH: ::enum_map::usize = #length;
+
+ #[inline]
+ fn from_usize(value: ::enum_map::usize) -> Self {
+ #from_usize_arms {
+ ::enum_map::out_of_bounds()
+ }
+ }
+
+ #[inline]
+ fn into_usize(self) -> ::enum_map::usize {
+ match self {
+ #into_usize_arms
+ }
+ }
+ }
+
+ #[automatically_derived]
+ impl<V> ::enum_map::EnumArray<V> for #name {
+ type Array = [V; #length];
+ }
+ }
+ }
+
+ fn handle_variant(&mut self, variant: &Variant) {
+ match &variant.fields {
+ Fields::Unit => self.handle_unit_variant(&variant.ident),
+ Fields::Unnamed(fields) => self.handle_unnamed_variant(&variant.ident, fields),
+ Fields::Named(fields) => self.handle_named_variant(&variant.ident, fields),
+ }
+ }
+
+ /// Becomes simply `1` in counting, since this is the size of the unit.
+ fn handle_unit_variant(&mut self, variant: &Ident) {
+ let Self {
+ length,
+ from_usize_arms,
+ into_usize_arms,
+ } = self;
+ *into_usize_arms = quote! { #into_usize_arms Self::#variant => #length, };
+ *from_usize_arms = quote! {
+ #from_usize_arms if value == #length {
+ Self::#variant
+ } else
+ };
+ self.length.units += 1;
+ }
+
+ /// Its size is the product of the sizes of its members. To represent this variant, one can
+ /// think of this as representing a little-endian number. First member is simply added, but
+ /// next members are multiplied before being added.
+ fn handle_unnamed_variant(&mut self, variant: &Ident, fields: &FieldsUnnamed) {
+ let Self {
+ length,
+ from_usize_arms,
+ into_usize_arms,
+ } = self;
+ let mut expr_into = quote! { #length };
+ let mut fields_length = quote! { 1usize };
+ let mut params_from = quote! {};
+ for (i, field) in fields.unnamed.iter().enumerate() {
+ let ident = format_ident!("p{}", i);
+ let ty = &field.ty;
+ let field_length = type_length(ty);
+
+ expr_into = quote! {
+ (#expr_into + #fields_length * ::enum_map::Enum::into_usize(#ident))
+ };
+
+ params_from = quote! {
+ #params_from <#ty as ::enum_map::Enum>::from_usize(
+ (value - #length) / #fields_length % #field_length
+ ),
+ };
+
+ fields_length = quote! { (#fields_length * #field_length) };
+ }
+
+ *length = Length {
+ units: 0,
+ opaque: quote! { (#length + #fields_length) },
+ };
+
+ let from_arms = &from_usize_arms;
+ *from_usize_arms = quote! {
+ #from_arms if value < #length {
+ Self::#variant(#params_from)
+ } else
+ };
+
+ let mut params_into = quote! {};
+ for i in 0..fields.unnamed.len() {
+ let ident = format_ident!("p{}", i);
+ params_into = quote! { #params_into #ident, };
+ }
+
+ *into_usize_arms = quote! {
+ #into_usize_arms Self::#variant(#params_into) => #expr_into,
+ };
+ }
+
+ /// Its size is the product of the sizes of its members. To represent this variant, one can
+ /// think of this as representing a little-endian number. First member is simply added, but
+ /// next members are multiplied before being added.
+ fn handle_named_variant(&mut self, variant: &Ident, fields: &FieldsNamed) {
+ let Self {
+ length,
+ from_usize_arms,
+ into_usize_arms,
+ } = self;
+ let mut expr_into = quote! { #length };
+ let mut fields_length = quote! { 1usize };
+ let mut params_from = quote! {};
+
+ for field in fields.named.iter() {
+ let ident = field.ident.as_ref().unwrap();
+ let ty = &field.ty;
+ let field_length = type_length(ty);
+
+ expr_into = quote! {
+ (#expr_into + #fields_length * ::enum_map::Enum::into_usize(#ident))
+ };
+
+ params_from = quote! {
+ #params_from #ident: <#ty as ::enum_map::Enum>::from_usize(
+ (value - #length) / #fields_length % #field_length
+ ),
+ };
+
+ fields_length = quote! { (#fields_length * #field_length) };
+ }
+
+ *length = Length {
+ units: 0,
+ opaque: quote! { (#length + #fields_length) },
+ };
+
+ *from_usize_arms = quote! {
+ #from_usize_arms if value < #length {
+ Self::#variant { #params_from }
+ } else
+ };
+
+ let mut params_into = quote! {};
+ for field in fields.named.iter() {
+ let ident = field.ident.as_ref().unwrap();
+ params_into = quote! { #params_into #ident, };
+ }
+
+ *into_usize_arms = quote! {
+ #into_usize_arms Self::#variant { #params_into } => #expr_into,
+ };
+ }
+}
diff --git a/third_party/rust/enum-map-derive/src/derive_struct.rs b/third_party/rust/enum-map-derive/src/derive_struct.rs
new file mode 100644
index 0000000000..94f3f97250
--- /dev/null
+++ b/third_party/rust/enum-map-derive/src/derive_struct.rs
@@ -0,0 +1,129 @@
+// SPDX-FileCopyrightText: 2021 - 2022 Kamila Borowska <kamila@borowska.pw>
+// SPDX-FileCopyrightText: 2021 Bruno Corrêa Zimmermann <brunoczim@gmail.com>
+//
+// SPDX-License-Identifier: MIT OR Apache-2.0
+
+use crate::type_length;
+use proc_macro2::TokenStream;
+use quote::quote;
+use syn::{DataStruct, Fields, FieldsNamed, FieldsUnnamed, Ident, Index};
+
+pub fn generate(name: Ident, data_struct: DataStruct) -> TokenStream {
+ StructGenerator::from_fields(&data_struct.fields).finish(&name)
+}
+
+/// Total length is the product of each member's length. To represent a struct, one can
+/// think of this as representing a little-endian number. First member is simply added, but
+/// next members are multiplied before being added.
+#[derive(Debug)]
+struct StructGenerator {
+ length: TokenStream,
+ from_usize: TokenStream,
+ into_usize: TokenStream,
+}
+
+impl StructGenerator {
+ fn from_fields(fields: &Fields) -> Self {
+ match fields {
+ Fields::Unit => Self::from_unit_fields(),
+ Fields::Unnamed(fields_data) => Self::from_unnamed_fields(fields_data),
+ Fields::Named(fields_data) => Self::from_named_fields(fields_data),
+ }
+ }
+
+ fn from_unit_fields() -> Self {
+ Self {
+ length: quote! { 1usize },
+ from_usize: quote! { Self },
+ into_usize: quote! { 0usize },
+ }
+ }
+
+ fn from_unnamed_fields(fields: &FieldsUnnamed) -> Self {
+ let mut params_from = quote! {};
+ let mut into_usize = quote! { 0usize };
+ let mut length = quote! { 1usize };
+ for (i, field) in fields.unnamed.iter().enumerate() {
+ let ty = &field.ty;
+ let index_ident = Index::from(i);
+ let field_length = type_length(ty);
+
+ into_usize = quote! {
+ (#into_usize + #length * ::enum_map::Enum::into_usize(self.#index_ident))
+ };
+
+ params_from = quote! {
+ #params_from <#ty as ::enum_map::Enum>::from_usize(
+ value / #length % #field_length
+ ),
+ };
+
+ length = quote! { (#length * #field_length) };
+ }
+
+ let from_usize = quote! { Self(#params_from) };
+ Self {
+ length,
+ from_usize,
+ into_usize,
+ }
+ }
+
+ fn from_named_fields(fields: &FieldsNamed) -> Self {
+ let mut params_from = quote! {};
+ let mut into_usize = quote! { 0usize };
+ let mut length = quote! { 1usize };
+ for field in fields.named.iter() {
+ let ty = &field.ty;
+ let ident = field.ident.as_ref().unwrap();
+ let field_length = type_length(ty);
+
+ into_usize = quote! {
+ (#into_usize + #length * ::enum_map::Enum::into_usize(self.#ident))
+ };
+
+ params_from = quote! {
+ #params_from #ident: <#ty as ::enum_map::Enum>::from_usize(
+ value / #length % #field_length
+ ),
+ };
+
+ length = quote! { (#field_length * #length) };
+ }
+
+ let from_usize = quote! { Self { #params_from } };
+ Self {
+ length,
+ from_usize,
+ into_usize,
+ }
+ }
+
+ fn finish(&self, name: &Ident) -> TokenStream {
+ let length = &self.length;
+ let from_usize = &self.from_usize;
+ let into_usize = &self.into_usize;
+
+ quote! {
+ #[automatically_derived]
+ impl ::enum_map::Enum for #name {
+ const LENGTH: ::enum_map::usize = #length;
+
+ #[inline]
+ fn from_usize(value: ::enum_map::usize) -> Self {
+ #from_usize
+ }
+
+ #[inline]
+ fn into_usize(self) -> ::enum_map::usize {
+ #into_usize
+ }
+ }
+
+ #[automatically_derived]
+ impl<V> ::enum_map::EnumArray<V> for #name {
+ type Array = [V; #length];
+ }
+ }
+ }
+}
diff --git a/third_party/rust/enum-map-derive/src/lib.rs b/third_party/rust/enum-map-derive/src/lib.rs
new file mode 100644
index 0000000000..0776559b28
--- /dev/null
+++ b/third_party/rust/enum-map-derive/src/lib.rs
@@ -0,0 +1,178 @@
+// SPDX-FileCopyrightText: 2017 - 2022 Kamila Borowska <kamila@borowska.pw>
+// SPDX-FileCopyrightText: 2018 hcpl <hcpl.prog@gmail.com>
+// SPDX-FileCopyrightText: 2019 mara <vmedea@protonmail.com>
+// SPDX-FileCopyrightText: 2021 Bruno Corrêa Zimmermann <brunoczim@gmail.com>
+// SPDX-FileCopyrightText: 2021 Dietrich <dietrich@teilgedanken.de>
+//
+// SPDX-License-Identifier: MIT OR Apache-2.0
+
+//! Procedural macro implementing `#[derive(Enum)]`
+//!
+//! This is supposed to used with `enum-map` crate, which provides the
+//! actual usage documentation.
+
+mod derive_enum;
+mod derive_struct;
+
+use proc_macro2::TokenStream;
+use quote::quote;
+use syn::{Data, DeriveInput, Type};
+
+/// Derive macro generating an implementation of trait `Enum`.
+///
+/// When using a derive, enum maps are maintained in the order in which
+/// enum variants are declared. This is reflected in the value returned
+/// by `Enum::into_usize`, iterators of enum map as well as
+/// `EnumMap::as_slice` method.
+///
+/// # Examples
+///
+/// ## Enums Without Payload
+/// ```
+/// use enum_map::Enum;
+///
+/// #[derive(Enum, Debug, PartialEq, Eq)]
+/// enum A {
+/// B,
+/// C,
+/// D,
+/// }
+///
+/// assert_eq!(A::B.into_usize(), 0);
+/// assert_eq!(A::C.into_usize(), 1);
+/// assert_eq!(A::D.into_usize(), 2);
+///
+/// assert_eq!(A::from_usize(0), A::B);
+/// assert_eq!(A::from_usize(1), A::C);
+/// assert_eq!(A::from_usize(2), A::D);
+/// ```
+///
+/// ## Enums With Payload
+///
+/// ```
+/// use enum_map::Enum;
+///
+/// #[derive(Enum, Debug, PartialEq, Eq)]
+/// enum A {
+/// B,
+/// C,
+/// D,
+/// }
+///
+/// #[derive(Enum, Debug, PartialEq, Eq)]
+/// enum X {
+/// Y,
+/// Z,
+/// }
+///
+/// #[derive(Enum, Debug, PartialEq, Eq)]
+/// enum Foo {
+/// Bar(bool, A),
+/// Empty,
+/// Baz { fa: A, fx: X },
+/// }
+///
+/// assert_eq!(Foo::Bar(false, A::B).into_usize(), 0);
+/// assert_eq!(Foo::Bar(false, A::D).into_usize(), 4);
+/// assert_eq!(Foo::Bar(true, A::B).into_usize(), 1);
+/// assert_eq!(Foo::Bar(true, A::C).into_usize(), 3);
+/// assert_eq!(Foo::Empty.into_usize(), 6);
+/// assert_eq!(Foo::Baz { fa: A::B, fx: X::Y }.into_usize(), 7);
+/// assert_eq!(Foo::Baz { fa: A::B, fx: X::Z }.into_usize(), 10);
+/// assert_eq!(Foo::Baz { fa: A::D, fx: X::Y }.into_usize(), 9);
+///
+/// assert_eq!(Foo::from_usize(0), Foo::Bar(false, A::B));
+/// assert_eq!(Foo::from_usize(4), Foo::Bar(false, A::D));
+/// assert_eq!(Foo::from_usize(1), Foo::Bar(true, A::B));
+/// assert_eq!(Foo::from_usize(3), Foo::Bar(true, A::C));
+/// assert_eq!(Foo::from_usize(6), Foo::Empty);
+/// assert_eq!(Foo::from_usize(7), Foo::Baz { fa: A::B, fx: X::Y });
+/// assert_eq!(Foo::from_usize(10), Foo::Baz { fa: A::B, fx: X::Z });
+/// assert_eq!(Foo::from_usize(9), Foo::Baz { fa: A::D, fx: X::Y });
+///
+/// ```
+///
+/// ## Structs
+///
+/// ```
+/// use enum_map::Enum;
+///
+/// #[derive(Enum, Debug, PartialEq, Eq)]
+/// enum A {
+/// B,
+/// C,
+/// D,
+/// }
+///
+/// #[derive(Enum, Debug, PartialEq, Eq)]
+/// enum X {
+/// Y,
+/// Z,
+/// }
+///
+/// #[derive(Enum, Debug, PartialEq, Eq)]
+/// struct Foo {
+/// bar: bool,
+/// baz: A,
+/// end: X,
+/// }
+///
+/// assert_eq!(Foo { bar: false, baz: A::B, end: X::Y }.into_usize(), 0);
+/// assert_eq!(Foo { bar: true, baz: A::B, end: X::Y }.into_usize(), 1);
+/// assert_eq!(Foo { bar: false, baz: A::D, end: X::Y }.into_usize(), 4);
+/// assert_eq!(Foo { bar: true, baz: A::C, end: X::Z }.into_usize(), 9);
+///
+/// assert_eq!(Foo::from_usize(0), Foo { bar: false, baz: A::B, end: X::Y });
+/// assert_eq!(Foo::from_usize(1), Foo { bar: true, baz: A::B, end: X::Y });
+/// assert_eq!(Foo::from_usize(4), Foo { bar: false, baz: A::D, end: X::Y });
+/// assert_eq!(Foo::from_usize(9), Foo { bar: true, baz: A::C, end: X::Z });
+/// ```
+///
+/// ## Tuple Structs
+///
+/// ```
+/// use enum_map::Enum;
+///
+/// #[derive(Enum, Debug, PartialEq, Eq)]
+/// enum A {
+/// B,
+/// C,
+/// D,
+/// }
+///
+/// #[derive(Enum, Debug, PartialEq, Eq)]
+/// enum X {
+/// Y,
+/// Z,
+/// }
+///
+/// #[derive(Enum, Debug, PartialEq, Eq)]
+/// struct Foo(bool, A, X);
+///
+/// assert_eq!(Foo(false, A::B, X::Y ).into_usize(), 0);
+/// assert_eq!(Foo(true, A::B, X::Y ).into_usize(), 1);
+/// assert_eq!(Foo(false, A::D, X::Y ).into_usize(), 4);
+/// assert_eq!(Foo(true, A::C, X::Z ).into_usize(), 9);
+///
+/// assert_eq!(Foo::from_usize(0), Foo(false, A::B, X::Y));
+/// assert_eq!(Foo::from_usize(1), Foo(true, A::B, X::Y));
+/// assert_eq!(Foo::from_usize(4), Foo(false, A::D, X::Y));
+/// assert_eq!(Foo::from_usize(9), Foo(true, A::C, X::Z));
+#[proc_macro_derive(Enum)]
+pub fn derive_enum_map(input: proc_macro::TokenStream) -> proc_macro::TokenStream {
+ let input: DeriveInput = syn::parse(input).unwrap();
+
+ let result = match input.data {
+ Data::Enum(data_enum) => derive_enum::generate(input.ident, data_enum),
+ Data::Struct(data_struct) => derive_struct::generate(input.ident, data_struct),
+ _ => quote! { compile_error! {"#[derive(Enum)] is only defined for enums and structs"} },
+ };
+
+ result.into()
+}
+
+fn type_length(ty: &Type) -> TokenStream {
+ quote! {
+ <#ty as ::enum_map::Enum>::LENGTH
+ }
+}