summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ffi-support/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/ffi-support/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/ffi-support/Cargo.toml')
-rw-r--r--third_party/rust/ffi-support/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/rust/ffi-support/Cargo.toml b/third_party/rust/ffi-support/Cargo.toml
new file mode 100644
index 0000000000..84a2c633e3
--- /dev/null
+++ b/third_party/rust/ffi-support/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "ffi-support"
+version = "0.4.4"
+authors = ["Thom Chiovoloni <tchiovoloni@mozilla.com>"]
+description = "A crate to help expose Rust functions over the FFI."
+readme = "README.md"
+keywords = ["ffi", "bindings"]
+categories = ["development-tools::ffi"]
+license = "Apache-2.0 / MIT"
+repository = "https://github.com/mozilla/ffi-support"
+[dependencies.backtrace]
+version = "0.3"
+optional = true
+
+[dependencies.lazy_static]
+version = "1.4"
+
+[dependencies.log]
+version = "0.4"
+[dev-dependencies.env_logger]
+version = "0.7"
+default-features = false
+
+[dev-dependencies.log]
+version = "0.4"
+
+[dev-dependencies.rand]
+version = "0.7"
+
+[dev-dependencies.rayon]
+version = "1.3"
+
+[features]
+default = []
+log_backtraces = ["log_panics", "backtrace"]
+log_panics = []