summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ffi-support/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/ffi-support/README.md
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/ffi-support/README.md')
-rw-r--r--third_party/rust/ffi-support/README.md32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/ffi-support/README.md b/third_party/rust/ffi-support/README.md
new file mode 100644
index 0000000000..1295023f1e
--- /dev/null
+++ b/third_party/rust/ffi-support/README.md
@@ -0,0 +1,32 @@
+# FFI Support
+
+[![Docs](https://docs.rs/ffi-support/badge.svg)](https://docs.rs/ffi-support)
+
+This crate implements a support library to simplify implementing the patterns that the [mozilla/application-services](https://github.com/mozilla/application-services) repository uses for it's "Rust Component" FFI libraries, which are used to share Rust code
+
+In particular, it can assist with the following areas:
+
+1. Avoiding throwing panics over the FFI (which is undefined behavior)
+2. Translating rust errors (and panics) into errors that the caller on the other side of the FFI is able to handle.
+3. Converting strings to/from rust str.
+4. Passing non-string data (in a few ways, including exposing an opaque pointeer, marshalling data to JSON strings with serde, as well as arbitrary custom handling) back and forth between Rust and whatever the caller on the other side of the FFI is.
+
+Additionally, it's documentation describes a number of the problems we've hit doing this to expose libraries to consumers on mobile platforms.
+
+## Usage
+
+Add the following to your Cargo.toml
+
+```toml
+ffi-support = "0.4.4"
+```
+
+For further examples, the examples in the docs is the best starting point, followed by the usage code in the [mozilla/application-services](https://github.com/mozilla/application-services) repo (for example [here](https://github.com/mozilla/application-services/blob/main/components/places/ffi/src/lib.rs) or [here](https://github.com/mozilla/application-services/blob/main/components/places/src/ffi.rs)).
+
+## License
+
+Dual licensed under the Apache License, Version 2.0 <LICENSE-APACHE> or
+<http://www.apache.org/licenses/LICENSE-2.0> or the MIT license <LICENSE-MIT> or
+<http://opensource.org/licenses/MIT>, at your option. All files in the project
+carrying such notice may not be copied, modified, or distributed except
+according to those terms.