summaryrefslogtreecommitdiffstats
path: root/third_party/rust/foreign-types-macros
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/foreign-types-macros
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/foreign-types-macros')
-rw-r--r--third_party/rust/foreign-types-macros/.cargo-checksum.json1
-rw-r--r--third_party/rust/foreign-types-macros/Cargo.toml35
-rw-r--r--third_party/rust/foreign-types-macros/LICENSE-APACHE202
-rw-r--r--third_party/rust/foreign-types-macros/LICENSE-MIT19
-rw-r--r--third_party/rust/foreign-types-macros/src/build.rs261
-rw-r--r--third_party/rust/foreign-types-macros/src/lib.rs15
-rw-r--r--third_party/rust/foreign-types-macros/src/parse.rs140
7 files changed, 673 insertions, 0 deletions
diff --git a/third_party/rust/foreign-types-macros/.cargo-checksum.json b/third_party/rust/foreign-types-macros/.cargo-checksum.json
new file mode 100644
index 0000000000..576d885de8
--- /dev/null
+++ b/third_party/rust/foreign-types-macros/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"829c9da0910b673669e0401c6affd6564c94c49cf9629740104ffabf46f54d08","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"333ea3aaa3cadb819f4acd9f9153f9feee060a995ca8710f32bc5bd9a4b91734","src/build.rs":"bee8027592dff9052e1235a6b1bfd0ae715389265247131c3e1ed865e561ba40","src/lib.rs":"7bb43075bede4947ee8f07a05e4d1b00e0daedadbde15f1b386f97514853ad1c","src/parse.rs":"d8cc189b7108602dee81ff5436a9480dd45397101f7faad875027441e1477ef1"},"package":"1a5c6c585bc94aaf2c7b51dd4c2ba22680844aba4c687be581871a6f518c5742"} \ No newline at end of file
diff --git a/third_party/rust/foreign-types-macros/Cargo.toml b/third_party/rust/foreign-types-macros/Cargo.toml
new file mode 100644
index 0000000000..584d1844c5
--- /dev/null
+++ b/third_party/rust/foreign-types-macros/Cargo.toml
@@ -0,0 +1,35 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "foreign-types-macros"
+version = "0.2.3"
+authors = ["Steven Fackler <sfackler@gmail.com>"]
+description = "An internal crate used by foreign-types"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/sfackler/foreign-types"
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "2.0"
+features = ["full"]
+
+[features]
+std = []
diff --git a/third_party/rust/foreign-types-macros/LICENSE-APACHE b/third_party/rust/foreign-types-macros/LICENSE-APACHE
new file mode 100644
index 0000000000..8f71f43fee
--- /dev/null
+++ b/third_party/rust/foreign-types-macros/LICENSE-APACHE
@@ -0,0 +1,202 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
+ APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "{}"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+ Copyright {yyyy} {name of copyright owner}
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+
diff --git a/third_party/rust/foreign-types-macros/LICENSE-MIT b/third_party/rust/foreign-types-macros/LICENSE-MIT
new file mode 100644
index 0000000000..bb76d01469
--- /dev/null
+++ b/third_party/rust/foreign-types-macros/LICENSE-MIT
@@ -0,0 +1,19 @@
+Copyright (c) 2017 The foreign-types Developers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/third_party/rust/foreign-types-macros/src/build.rs b/third_party/rust/foreign-types-macros/src/build.rs
new file mode 100644
index 0000000000..b50610f0f3
--- /dev/null
+++ b/third_party/rust/foreign-types-macros/src/build.rs
@@ -0,0 +1,261 @@
+use proc_macro2::TokenStream;
+use quote::quote;
+use syn::{Ident, Path};
+
+use crate::parse::{ForeignType, Input};
+
+fn ref_name(input: &ForeignType) -> Ident {
+ Ident::new(&format!("{}Ref", input.name), input.name.span())
+}
+
+pub fn build(input: Input) -> TokenStream {
+ let types = input
+ .types
+ .iter()
+ .map(|t| build_foreign_type(&input.crate_, t));
+ quote! {
+ #(#types)*
+ }
+}
+
+fn build_foreign_type(crate_: &Path, input: &ForeignType) -> TokenStream {
+ let decls = build_decls(crate_, input);
+ let oibits = build_oibits(crate_, input);
+ let foreign_impls = build_foreign_impls(crate_, input);
+ let drop_impl = build_drop_impl(crate_, input);
+ let deref_impls = build_deref_impls(crate_, input);
+ let borrow_impls = build_borrow_impls(crate_, input);
+ let as_ref_impls = build_as_ref_impls(crate_, input);
+ let clone_impl = build_clone_impl(crate_, input);
+ let to_owned_impl = build_to_owned_impl(crate_, input);
+
+ quote! {
+ #decls
+ #oibits
+ #foreign_impls
+ #drop_impl
+ #deref_impls
+ #borrow_impls
+ #as_ref_impls
+ #clone_impl
+ #to_owned_impl
+ }
+}
+
+fn build_decls(crate_: &Path, input: &ForeignType) -> TokenStream {
+ let attrs = &input.attrs;
+ let vis = &input.visibility;
+ let name = &input.name;
+ let generics = &input.generics;
+ let ctype = &input.ctype;
+ let phantom_data = input
+ .phantom_data
+ .as_ref()
+ .map(|d| quote!(, #crate_::export::PhantomData<#d>));
+ let ref_name = ref_name(input);
+ let ref_docs = format!(
+ "A borrowed reference to a [`{name}`](struct.{name}.html).",
+ name = name
+ );
+
+ quote! {
+ #(#attrs)*
+ #[repr(transparent)]
+ #vis struct #name #generics(#crate_::export::NonNull<#ctype> #phantom_data);
+
+ #[doc = #ref_docs]
+ #vis struct #ref_name #generics(#crate_::Opaque #phantom_data);
+ }
+}
+
+fn build_oibits(crate_: &Path, input: &ForeignType) -> TokenStream {
+ let oibits = input.oibits.iter().map(|t| build_oibit(crate_, input, t));
+
+ quote! {
+ #(#oibits)*
+ }
+}
+
+fn build_oibit(crate_: &Path, input: &ForeignType, oibit: &Ident) -> TokenStream {
+ let name = &input.name;
+ let ref_name = ref_name(input);
+ let (impl_generics, ty_generics, _) = input.generics.split_for_impl();
+
+ quote! {
+ unsafe impl #impl_generics #crate_::export::#oibit for #name #ty_generics {}
+ unsafe impl #impl_generics #crate_::export::#oibit for #ref_name #ty_generics {}
+ }
+}
+
+fn build_foreign_impls(crate_: &Path, input: &ForeignType) -> TokenStream {
+ let name = &input.name;
+ let ctype = &input.ctype;
+ let ref_name = ref_name(input);
+ let (impl_generics, ty_generics, _) = input.generics.split_for_impl();
+ let phantom_data = input
+ .phantom_data
+ .as_ref()
+ .map(|_| quote!(, #crate_::export::PhantomData));
+
+ quote! {
+ unsafe impl #impl_generics #crate_::ForeignType for #name #ty_generics {
+ type CType = #ctype;
+ type Ref = #ref_name #ty_generics;
+
+ #[inline]
+ unsafe fn from_ptr(ptr: *mut #ctype) -> #name #ty_generics {
+ debug_assert!(!ptr.is_null());
+ #name(<#crate_::export::NonNull<_>>::new_unchecked(ptr) #phantom_data)
+ }
+
+ #[inline]
+ fn as_ptr(&self) -> *mut #ctype {
+ <#crate_::export::NonNull<_>>::as_ptr(self.0)
+ }
+ }
+
+ unsafe impl #impl_generics #crate_::ForeignTypeRef for #ref_name #ty_generics {
+ type CType = #ctype;
+ }
+ }
+}
+
+fn build_drop_impl(crate_: &Path, input: &ForeignType) -> TokenStream {
+ let name = &input.name;
+ let drop = &input.drop;
+ let (impl_generics, ty_generics, _) = input.generics.split_for_impl();
+
+ quote! {
+ impl #impl_generics #crate_::export::Drop for #name #ty_generics {
+ #[inline]
+ fn drop(&mut self) {
+ unsafe {
+ (#drop)(#crate_::ForeignType::as_ptr(self));
+ }
+ }
+ }
+ }
+}
+
+fn build_deref_impls(crate_: &Path, input: &ForeignType) -> TokenStream {
+ let name = &input.name;
+ let ref_name = ref_name(input);
+ let (impl_generics, ty_generics, _) = input.generics.split_for_impl();
+
+ quote! {
+ impl #impl_generics #crate_::export::Deref for #name #ty_generics {
+ type Target = #ref_name #ty_generics;
+
+ #[inline]
+ fn deref(&self) -> &#ref_name #ty_generics {
+ unsafe {
+ #crate_::ForeignTypeRef::from_ptr(#crate_::ForeignType::as_ptr(self))
+ }
+ }
+ }
+
+ impl #impl_generics #crate_::export::DerefMut for #name #ty_generics {
+ #[inline]
+ fn deref_mut(&mut self) -> &mut #ref_name #ty_generics {
+ unsafe {
+ #crate_::ForeignTypeRef::from_ptr_mut(#crate_::ForeignType::as_ptr(self))
+ }
+ }
+ }
+ }
+}
+
+fn build_borrow_impls(crate_: &Path, input: &ForeignType) -> TokenStream {
+ let name = &input.name;
+ let ref_name = ref_name(input);
+ let (impl_generics, ty_generics, _) = input.generics.split_for_impl();
+
+ quote! {
+ impl #impl_generics #crate_::export::Borrow<#ref_name #ty_generics> for #name #ty_generics {
+ #[inline]
+ fn borrow(&self) -> &#ref_name #ty_generics {
+ &**self
+ }
+ }
+
+ impl #impl_generics #crate_::export::BorrowMut<#ref_name #ty_generics> for #name #ty_generics {
+ #[inline]
+ fn borrow_mut(&mut self) -> &mut #ref_name #ty_generics {
+ &mut **self
+ }
+ }
+ }
+}
+
+fn build_as_ref_impls(crate_: &Path, input: &ForeignType) -> TokenStream {
+ let name = &input.name;
+ let ref_name = ref_name(input);
+ let (impl_generics, ty_generics, _) = input.generics.split_for_impl();
+
+ quote! {
+ impl #impl_generics #crate_::export::AsRef<#ref_name #ty_generics> for #name #ty_generics {
+ #[inline]
+ fn as_ref(&self) -> &#ref_name #ty_generics {
+ &**self
+ }
+ }
+
+ impl #impl_generics #crate_::export::AsMut<#ref_name #ty_generics> for #name #ty_generics {
+ #[inline]
+ fn as_mut(&mut self) -> &mut #ref_name #ty_generics {
+ &mut **self
+ }
+ }
+ }
+}
+
+fn build_clone_impl(crate_: &Path, input: &ForeignType) -> TokenStream {
+ let clone = match &input.clone {
+ Some(clone) => clone,
+ None => return quote!(),
+ };
+ let name = &input.name;
+ let (impl_generics, ty_generics, _) = input.generics.split_for_impl();
+
+ quote! {
+ impl #impl_generics #crate_::export::Clone for #name #ty_generics {
+ #[inline]
+ fn clone(&self) -> #name #ty_generics {
+ unsafe {
+ let ptr = (#clone)(#crate_::ForeignType::as_ptr(self));
+ #crate_::ForeignType::from_ptr(ptr)
+ }
+ }
+ }
+ }
+}
+
+#[cfg(feature = "std")]
+fn build_to_owned_impl(crate_: &Path, input: &ForeignType) -> TokenStream {
+ let clone = match &input.clone {
+ Some(clone) => clone,
+ None => return quote!(),
+ };
+ let name = &input.name;
+ let ref_name = ref_name(input);
+ let (impl_generics, ty_generics, _) = input.generics.split_for_impl();
+
+ quote! {
+ impl #impl_generics #crate_::export::ToOwned for #ref_name #ty_generics {
+ type Owned = #name #ty_generics;
+
+ #[inline]
+ fn to_owned(&self) -> #name #ty_generics {
+ unsafe {
+ let ptr = (#clone)(#crate_::ForeignTypeRef::as_ptr(self));
+ #crate_::ForeignType::from_ptr(ptr)
+ }
+ }
+ }
+ }
+}
+
+#[cfg(not(feature = "std"))]
+fn build_to_owned_impl(_: &Path, _: &ForeignType) -> TokenStream {
+ quote!()
+}
diff --git a/third_party/rust/foreign-types-macros/src/lib.rs b/third_party/rust/foreign-types-macros/src/lib.rs
new file mode 100644
index 0000000000..77c1e99fbc
--- /dev/null
+++ b/third_party/rust/foreign-types-macros/src/lib.rs
@@ -0,0 +1,15 @@
+extern crate proc_macro;
+
+use proc_macro::TokenStream;
+use syn::parse_macro_input;
+
+use crate::parse::Input;
+
+mod build;
+mod parse;
+
+#[proc_macro]
+pub fn foreign_type_impl(input: TokenStream) -> TokenStream {
+ let input = parse_macro_input!(input as Input);
+ build::build(input).into()
+}
diff --git a/third_party/rust/foreign-types-macros/src/parse.rs b/third_party/rust/foreign-types-macros/src/parse.rs
new file mode 100644
index 0000000000..ba11dc976c
--- /dev/null
+++ b/third_party/rust/foreign-types-macros/src/parse.rs
@@ -0,0 +1,140 @@
+use syn::parse::{self, Parse, ParseStream};
+use syn::punctuated::Punctuated;
+use syn::token;
+use syn::{braced, Attribute, Expr, Generics, Ident, Path, Token, Type, Visibility};
+
+mod kw {
+ syn::custom_keyword!(Sync);
+ syn::custom_keyword!(Send);
+ syn::custom_keyword!(PhantomData);
+ syn::custom_keyword!(CType);
+ syn::custom_keyword!(drop);
+ syn::custom_keyword!(clone);
+}
+
+pub struct Input {
+ pub crate_: Path,
+ pub types: Vec<ForeignType>,
+}
+
+impl Parse for Input {
+ fn parse(input: ParseStream) -> parse::Result<Input> {
+ let crate_ = input.parse()?;
+ let mut types = vec![];
+ while !input.is_empty() {
+ types.push(input.parse()?);
+ }
+
+ Ok(Input { crate_, types })
+ }
+}
+
+pub struct ForeignType {
+ pub attrs: Vec<Attribute>,
+ pub visibility: Visibility,
+ pub name: Ident,
+ pub generics: Generics,
+ pub oibits: Punctuated<Ident, Token![+]>,
+ pub phantom_data: Option<Type>,
+ pub ctype: Type,
+ pub drop: Expr,
+ pub clone: Option<Expr>,
+}
+
+impl Parse for ForeignType {
+ fn parse(input: ParseStream) -> parse::Result<ForeignType> {
+ let attrs = input.call(Attribute::parse_outer)?;
+ let visibility = input.parse()?;
+ input.parse::<Token![unsafe]>()?;
+ input.parse::<Token![type]>()?;
+ let name = input.parse()?;
+ let generics = input.parse()?;
+ let oibits = input.call(parse_oibits)?;
+ let inner;
+ braced!(inner in input);
+ let ctype = inner.call(parse_type::<kw::CType>)?;
+ let phantom_data = inner.call(parse_phantom_data)?;
+ let drop = inner.call(parse_fn::<kw::drop>)?;
+ let clone = inner.call(parse_clone)?;
+
+ Ok(ForeignType {
+ attrs,
+ visibility,
+ name,
+ generics,
+ oibits,
+ ctype,
+ phantom_data,
+ drop,
+ clone,
+ })
+ }
+}
+
+fn parse_oibit(input: ParseStream) -> parse::Result<Ident> {
+ let lookahead = input.lookahead1();
+ if lookahead.peek(kw::Sync) || lookahead.peek(kw::Send) {
+ input.parse()
+ } else {
+ Err(lookahead.error())
+ }
+}
+
+fn parse_oibits(input: ParseStream) -> parse::Result<Punctuated<Ident, Token![+]>> {
+ let mut out = Punctuated::new();
+
+ if input.parse::<Option<Token![:]>>()?.is_some() {
+ loop {
+ out.push_value(input.call(parse_oibit)?);
+ if input.peek(token::Brace) {
+ break;
+ }
+ out.push_punct(input.parse()?);
+ if input.peek(token::Brace) {
+ break;
+ }
+ }
+ }
+
+ Ok(out)
+}
+
+fn parse_type<T>(input: ParseStream) -> parse::Result<Type>
+where
+ T: Parse,
+{
+ input.parse::<Token![type]>()?;
+ input.parse::<T>()?;
+ input.parse::<Token![=]>()?;
+ let type_ = input.parse()?;
+ input.parse::<Token![;]>()?;
+ Ok(type_)
+}
+
+fn parse_phantom_data(input: ParseStream) -> parse::Result<Option<Type>> {
+ if input.peek(Token![type]) && input.peek2(kw::PhantomData) {
+ input.call(parse_type::<kw::PhantomData>).map(Some)
+ } else {
+ Ok(None)
+ }
+}
+
+fn parse_fn<T>(input: ParseStream) -> parse::Result<Expr>
+where
+ T: Parse,
+{
+ input.parse::<Token![fn]>()?;
+ input.parse::<T>()?;
+ input.parse::<Token![=]>()?;
+ let path = input.parse()?;
+ input.parse::<Token![;]>()?;
+ Ok(path)
+}
+
+fn parse_clone(input: ParseStream) -> parse::Result<Option<Expr>> {
+ if input.peek(Token![fn]) && input.peek2(kw::clone) {
+ input.call(parse_fn::<kw::clone>).map(Some)
+ } else {
+ Ok(None)
+ }
+}