summaryrefslogtreecommitdiffstats
path: root/third_party/rust/foreign-types
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/foreign-types
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/foreign-types')
-rw-r--r--third_party/rust/foreign-types/.cargo-checksum.json1
-rw-r--r--third_party/rust/foreign-types/Cargo.toml30
-rw-r--r--third_party/rust/foreign-types/LICENSE-APACHE202
-rw-r--r--third_party/rust/foreign-types/LICENSE-MIT19
-rw-r--r--third_party/rust/foreign-types/README.md23
-rw-r--r--third_party/rust/foreign-types/src/lib.rs250
-rw-r--r--third_party/rust/foreign-types/tests/test.rs22
7 files changed, 547 insertions, 0 deletions
diff --git a/third_party/rust/foreign-types/.cargo-checksum.json b/third_party/rust/foreign-types/.cargo-checksum.json
new file mode 100644
index 0000000000..978653cf7c
--- /dev/null
+++ b/third_party/rust/foreign-types/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"2e1b7838114ee31147555eb858dd837f1f8ac80d53f00c62b2c81c5a0121224d","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"333ea3aaa3cadb819f4acd9f9153f9feee060a995ca8710f32bc5bd9a4b91734","README.md":"6f3f1429f2724a481df811842f318d0d3b83160ada953fd869d4b685f7fd72e4","src/lib.rs":"a0039cfb11b235119b81ba8d31987c19d8fd6e1d23abbde57e67747fdd8f0ad0","tests/test.rs":"7913e5e040b75e5b63bf813d25a0491cb8e9b51857a039cf3b56d7f10fc787d3"},"package":"d737d9aa519fb7b749cbc3b962edcf310a8dd1f4b67c91c4f83975dbdd17d965"} \ No newline at end of file
diff --git a/third_party/rust/foreign-types/Cargo.toml b/third_party/rust/foreign-types/Cargo.toml
new file mode 100644
index 0000000000..b3639ede10
--- /dev/null
+++ b/third_party/rust/foreign-types/Cargo.toml
@@ -0,0 +1,30 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "foreign-types"
+version = "0.5.0"
+authors = ["Steven Fackler <sfackler@gmail.com>"]
+description = "A framework for Rust wrappers over C APIs"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/sfackler/foreign-types"
+[dependencies.foreign-types-macros]
+version = "0.2"
+
+[dependencies.foreign-types-shared]
+version = "0.3"
+
+[features]
+default = ["std"]
+std = ["foreign-types-macros/std"]
diff --git a/third_party/rust/foreign-types/LICENSE-APACHE b/third_party/rust/foreign-types/LICENSE-APACHE
new file mode 100644
index 0000000000..8f71f43fee
--- /dev/null
+++ b/third_party/rust/foreign-types/LICENSE-APACHE
@@ -0,0 +1,202 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
+ APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "{}"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+ Copyright {yyyy} {name of copyright owner}
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+
diff --git a/third_party/rust/foreign-types/LICENSE-MIT b/third_party/rust/foreign-types/LICENSE-MIT
new file mode 100644
index 0000000000..bb76d01469
--- /dev/null
+++ b/third_party/rust/foreign-types/LICENSE-MIT
@@ -0,0 +1,19 @@
+Copyright (c) 2017 The foreign-types Developers
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/third_party/rust/foreign-types/README.md b/third_party/rust/foreign-types/README.md
new file mode 100644
index 0000000000..cd15965fad
--- /dev/null
+++ b/third_party/rust/foreign-types/README.md
@@ -0,0 +1,23 @@
+# foreign-types
+
+[![CircleCI](https://circleci.com/gh/sfackler/foreign-types.svg?style=shield)](https://circleci.com/gh/sfackler/foreign-types)
+
+[Documentation](https://docs.rs/foreign-types)
+
+A framework for Rust wrappers over C APIs.
+
+## License
+
+Licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally
+submitted for inclusion in the work by you, as defined in the Apache-2.0
+license, shall be dual licensed as above, without any additional terms or
+conditions.
diff --git a/third_party/rust/foreign-types/src/lib.rs b/third_party/rust/foreign-types/src/lib.rs
new file mode 100644
index 0000000000..00b3db950b
--- /dev/null
+++ b/third_party/rust/foreign-types/src/lib.rs
@@ -0,0 +1,250 @@
+//! A framework for Rust wrappers over C APIs.
+//!
+//! Ownership is as important in C as it is in Rust, but the semantics are often implicit. In
+//! particular, pointer-to-value is commonly used to pass C values both when transferring ownership
+//! or a borrow.
+//!
+//! This crate provides a framework to define a Rust wrapper over these kinds of raw C APIs in a way
+//! that allows ownership semantics to be expressed in an ergonomic manner. The framework takes a
+//! dual-type approach similar to APIs in the standard library such as `PathBuf`/`Path` or `String`/
+//! `str`. One type represents an owned value and references to the other represent borrowed
+//! values.
+//!
+//! # Examples
+//!
+//! ```
+//! use foreign_types::{ForeignType, ForeignTypeRef, Opaque};
+//! use std::ops::{Deref, DerefMut};
+//! use std::ptr::NonNull;
+//!
+//! mod foo_sys {
+//! pub enum FOO {}
+//!
+//! extern {
+//! pub fn FOO_free(foo: *mut FOO);
+//! }
+//! }
+//!
+//! // The borrowed type is a newtype wrapper around an `Opaque` value.
+//! //
+//! // `FooRef` values never exist; we instead create references to `FooRef`s
+//! // from raw C pointers.
+//! pub struct FooRef(Opaque);
+//!
+//! unsafe impl ForeignTypeRef for FooRef {
+//! type CType = foo_sys::FOO;
+//! }
+//!
+//! // The owned type is simply a newtype wrapper around the raw C type.
+//! //
+//! // It dereferences to `FooRef`, so methods that do not require ownership
+//! // should be defined there.
+//! pub struct Foo(NonNull<foo_sys::FOO>);
+//!
+//! unsafe impl Sync for FooRef {}
+//! unsafe impl Send for FooRef {}
+//!
+//! unsafe impl Sync for Foo {}
+//! unsafe impl Send for Foo {}
+//!
+//! impl Drop for Foo {
+//! fn drop(&mut self) {
+//! unsafe { foo_sys::FOO_free(self.as_ptr()) }
+//! }
+//! }
+//!
+//! unsafe impl ForeignType for Foo {
+//! type CType = foo_sys::FOO;
+//! type Ref = FooRef;
+//!
+//! unsafe fn from_ptr(ptr: *mut foo_sys::FOO) -> Foo {
+//! Foo(NonNull::new_unchecked(ptr))
+//! }
+//!
+//! fn as_ptr(&self) -> *mut foo_sys::FOO {
+//! self.0.as_ptr()
+//! }
+//!
+//! fn into_ptr(self) -> *mut foo_sys::FOO {
+//! let inner = self.as_ptr();
+//! ::core::mem::forget(self);
+//! inner
+//! }
+//! }
+//!
+//! impl Deref for Foo {
+//! type Target = FooRef;
+//!
+//! fn deref(&self) -> &FooRef {
+//! unsafe { FooRef::from_ptr(self.as_ptr()) }
+//! }
+//! }
+//!
+//! impl DerefMut for Foo {
+//! fn deref_mut(&mut self) -> &mut FooRef {
+//! unsafe { FooRef::from_ptr_mut(self.as_ptr()) }
+//! }
+//! }
+//!
+//! // add in Borrow, BorrowMut, AsRef, AsRefMut, Clone, ToOwned...
+//! ```
+//!
+//! The `foreign_type!` macro can generate this boilerplate for you:
+//!
+//! ```
+//! use foreign_types::foreign_type;
+//!
+//! mod foo_sys {
+//! pub enum FOO {}
+//!
+//! extern {
+//! pub fn FOO_free(foo: *mut FOO);
+//! pub fn FOO_duplicate(foo: *mut FOO) -> *mut FOO; // optional
+//! }
+//! }
+//!
+//! foreign_type! {
+//! /// A Foo.
+//! pub unsafe type Foo
+//! : Sync + Send // optional
+//! {
+//! type CType = foo_sys::FOO;
+//! fn drop = foo_sys::FOO_free;
+//! fn clone = foo_sys::FOO_duplicate; // optional
+//! }
+//!
+//! /// A Foo with generic parameters.
+//! pub unsafe type GenericFoo<T> {
+//! type CType = foo_sys::FOO;
+//! // This type is added as a `PhantomData` field to handle variance
+//! // of the parameters. However, it has no impact on trait impls:
+//! // `GenericFoo<T>` is always `Clone`, even if `T` is not.
+//! type PhantomData = T;
+//! fn drop = foo_sys::FOO_free;
+//! fn clone = foo_sys::FOO_duplicate;
+//! }
+//! }
+//!
+//! # fn main() {}
+//! ```
+//!
+//! If `fn clone` is specified, then it must take `CType` as an argument and return a copy of it as `CType`.
+//! It will be used to implement `Clone`, and if the `std` Cargo feature is enabled, `ToOwned`.
+//!
+//! Say we then have a separate type in our C API that contains a `FOO`:
+//!
+//! ```
+//! mod foo_sys {
+//! pub enum FOO {}
+//! pub enum BAR {}
+//!
+//! extern {
+//! pub fn FOO_free(foo: *mut FOO);
+//! pub fn BAR_free(bar: *mut BAR);
+//! pub fn BAR_get_foo(bar: *mut BAR) -> *mut FOO;
+//! }
+//! }
+//! ```
+//!
+//! The documentation for the C library states that `BAR_get_foo` returns a reference into the `BAR`
+//! passed to it, which translates into a reference in Rust. It also says that we're allowed to
+//! modify the `FOO`, so we'll define a pair of accessor methods, one immutable and one mutable:
+//!
+//! ```
+//! use foreign_types::{ForeignTypeRef, foreign_type};
+//!
+//! mod foo_sys {
+//! pub enum FOO {}
+//! pub enum BAR {}
+//!
+//! extern {
+//! pub fn FOO_free(foo: *mut FOO);
+//! pub fn BAR_free(bar: *mut BAR);
+//! pub fn BAR_get_foo(bar: *mut BAR) -> *mut FOO;
+//! }
+//! }
+//!
+//! foreign_type! {
+//! /// A Foo.
+//! pub unsafe type Foo: Sync + Send {
+//! type CType = foo_sys::FOO;
+//! fn drop = foo_sys::FOO_free;
+//! }
+//!
+//! /// A Bar.
+//! pub unsafe type Bar: Sync + Send {
+//! type CType = foo_sys::BAR;
+//! fn drop = foo_sys::BAR_free;
+//! }
+//! }
+//!
+//! impl BarRef {
+//! fn foo(&self) -> &FooRef {
+//! unsafe { FooRef::from_ptr(foo_sys::BAR_get_foo(self.as_ptr())) }
+//! }
+//!
+//! fn foo_mut(&mut self) -> &mut FooRef {
+//! unsafe { FooRef::from_ptr_mut(foo_sys::BAR_get_foo(self.as_ptr())) }
+//! }
+//! }
+//!
+//! # fn main() {}
+//! ```
+#![no_std]
+#![warn(missing_docs)]
+#![doc(html_root_url = "https://docs.rs/foreign-types/0.5")]
+
+#[cfg(feature = "std")]
+extern crate std;
+
+#[doc(hidden)]
+pub use foreign_types_macros::foreign_type_impl;
+#[doc(inline)]
+pub use foreign_types_shared::{ForeignType, ForeignTypeRef, Opaque};
+
+#[doc(hidden)]
+pub mod export {
+ pub use core::borrow::{Borrow, BorrowMut};
+ pub use core::clone::Clone;
+ pub use core::convert::{AsMut, AsRef};
+ pub use core::marker::{PhantomData, Send, Sync};
+ pub use core::ops::{Deref, DerefMut, Drop};
+ pub use core::ptr::NonNull;
+
+ #[cfg(feature = "std")]
+ pub use std::borrow::ToOwned;
+}
+
+/// A macro to easily define wrappers for foreign types.
+///
+/// # Examples
+///
+/// ```
+/// use foreign_types::foreign_type;
+///
+/// # mod openssl_sys { pub type SSL = (); pub unsafe fn SSL_free(_: *mut SSL) {} pub unsafe fn SSL_dup(x: *mut SSL) -> *mut SSL {x} }
+/// # mod foo_sys { pub type THING = (); pub unsafe fn THING_free(_: *mut THING) {} }
+/// foreign_type! {
+/// /// Documentation for the owned type.
+/// pub unsafe type Ssl: Sync + Send {
+/// type CType = openssl_sys::SSL;
+/// fn drop = openssl_sys::SSL_free;
+/// fn clone = openssl_sys::SSL_dup;
+/// }
+///
+/// /// This type immutably borrows other data and has a limited lifetime!
+/// pub unsafe type Thing<'a>: Send {
+/// type CType = foo_sys::THING;
+/// type PhantomData = &'a ();
+/// fn drop = foo_sys::THING_free;
+/// }
+/// }
+///
+/// # fn main() {}
+/// ```
+#[macro_export(local_inner_macros)]
+macro_rules! foreign_type {
+ ($($t:tt)*) => {
+ $crate::foreign_type_impl!($crate $($t)*);
+ };
+}
diff --git a/third_party/rust/foreign-types/tests/test.rs b/third_party/rust/foreign-types/tests/test.rs
new file mode 100644
index 0000000000..a1df67e7a1
--- /dev/null
+++ b/third_party/rust/foreign-types/tests/test.rs
@@ -0,0 +1,22 @@
+use foreign_types::foreign_type;
+
+mod foo_sys {
+ pub enum FOO {}
+
+ pub unsafe extern "C" fn foo_drop(_: *mut FOO) {}
+ pub unsafe extern "C" fn foo_clone(ptr: *mut FOO) -> *mut FOO { ptr }
+}
+
+foreign_type! {
+ pub unsafe type Foo<'a, T>: Sync + Send {
+ type CType = foo_sys::FOO;
+ type PhantomData = &'a T;
+ fn drop = foo_sys::foo_drop;
+ fn clone = foo_sys::foo_clone;
+ }
+
+ pub unsafe type Foo2 {
+ type CType = foo_sys::FOO;
+ fn drop = foo_sys::foo_drop;
+ }
+}