summaryrefslogtreecommitdiffstats
path: root/third_party/rust/gpu-descriptor/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/gpu-descriptor/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/gpu-descriptor/Cargo.toml')
-rw-r--r--third_party/rust/gpu-descriptor/Cargo.toml52
1 files changed, 52 insertions, 0 deletions
diff --git a/third_party/rust/gpu-descriptor/Cargo.toml b/third_party/rust/gpu-descriptor/Cargo.toml
new file mode 100644
index 0000000000..1f8ff2851c
--- /dev/null
+++ b/third_party/rust/gpu-descriptor/Cargo.toml
@@ -0,0 +1,52 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "gpu-descriptor"
+version = "0.2.3"
+authors = ["Zakarum <zakarumych@ya.ru>"]
+description = "Implementation agnostic descriptor allocator for Vulkan like APIs"
+homepage = "https://github.com/zakarumych/gpu-descriptor"
+documentation = "https://docs.rs/gpu-descriptor"
+readme = "../README.md"
+keywords = [
+ "gpu",
+ "vulkan",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/zakarumych/gpu-descriptor"
+
+[dependencies.bitflags]
+version = "1.2"
+default-features = false
+
+[dependencies.gpu-descriptor-types]
+version = "0.1"
+
+[dependencies.hashbrown]
+version = "0.12"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.tracing]
+version = "0.1"
+optional = true
+default-features = false
+
+[features]
+default = ["std"]
+std = []