summaryrefslogtreecommitdiffstats
path: root/third_party/rust/gpu-descriptor/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
commit8dd16259287f58f9273002717ec4d27e97127719 (patch)
tree3863e62a53829a84037444beab3abd4ed9dfc7d0 /third_party/rust/gpu-descriptor/Cargo.toml
parentReleasing progress-linux version 126.0.1-1~progress7.99u1. (diff)
downloadfirefox-8dd16259287f58f9273002717ec4d27e97127719.tar.xz
firefox-8dd16259287f58f9273002717ec4d27e97127719.zip
Merging upstream version 127.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/gpu-descriptor/Cargo.toml')
-rw-r--r--third_party/rust/gpu-descriptor/Cargo.toml14
1 files changed, 10 insertions, 4 deletions
diff --git a/third_party/rust/gpu-descriptor/Cargo.toml b/third_party/rust/gpu-descriptor/Cargo.toml
index 1f8ff2851c..7524894008 100644
--- a/third_party/rust/gpu-descriptor/Cargo.toml
+++ b/third_party/rust/gpu-descriptor/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "gpu-descriptor"
-version = "0.2.3"
+version = "0.3.0"
authors = ["Zakarum <zakarumych@ya.ru>"]
description = "Implementation agnostic descriptor allocator for Vulkan like APIs"
homepage = "https://github.com/zakarumych/gpu-descriptor"
@@ -27,14 +27,20 @@ license = "MIT OR Apache-2.0"
repository = "https://github.com/zakarumych/gpu-descriptor"
[dependencies.bitflags]
-version = "1.2"
+version = "2.4"
default-features = false
[dependencies.gpu-descriptor-types]
-version = "0.1"
+version = "0.2"
+path = "../types"
[dependencies.hashbrown]
-version = "0.12"
+version = "0.14"
+features = [
+ "ahash",
+ "raw",
+]
+default-features = false
[dependencies.serde]
version = "1.0"