summaryrefslogtreecommitdiffstats
path: root/third_party/rust/hashlink/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/hashlink/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/hashlink/Cargo.toml')
-rw-r--r--third_party/rust/hashlink/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/third_party/rust/hashlink/Cargo.toml b/third_party/rust/hashlink/Cargo.toml
new file mode 100644
index 0000000000..308f9f77c3
--- /dev/null
+++ b/third_party/rust/hashlink/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "hashlink"
+version = "0.8.1"
+authors = ["kyren <kerriganw@gmail.com>"]
+description = "HashMap-like containers that hold their key-value pairs in a user controllable order"
+documentation = "https://docs.rs/hashlink"
+readme = "README.md"
+keywords = ["data-structures"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/kyren/hashlink"
+
+[dependencies.hashbrown]
+version = "0.12.0"
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dev-dependencies.fxhash]
+version = "0.2.1"
+
+[dev-dependencies.serde_test]
+version = "1.0"
+
+[features]
+serde_impl = ["serde"]
+
+[badges.circle-ci]
+branch = "master"
+repository = "kyren/hashlink"