summaryrefslogtreecommitdiffstats
path: root/third_party/rust/icu_collections/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/icu_collections/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/icu_collections/Cargo.toml')
-rw-r--r--third_party/rust/icu_collections/Cargo.toml128
1 files changed, 128 insertions, 0 deletions
diff --git a/third_party/rust/icu_collections/Cargo.toml b/third_party/rust/icu_collections/Cargo.toml
new file mode 100644
index 0000000000..7ecc93c7d8
--- /dev/null
+++ b/third_party/rust/icu_collections/Cargo.toml
@@ -0,0 +1,128 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.67"
+name = "icu_collections"
+version = "1.4.0"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "data/**/*",
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "tests/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "Collection of API for use in ICU libraries."
+homepage = "https://icu4x.unicode.org"
+readme = "README.md"
+categories = ["internationalization"]
+license-file = "LICENSE"
+repository = "https://github.com/unicode-org/icu4x"
+
+[package.metadata.cargo-all-features]
+denylist = ["bench"]
+
+[package.metadata.docs.rs]
+all-features = true
+
+[lib]
+bench = false
+
+[[bench]]
+name = "codepointtrie"
+path = "src/codepointtrie/benches/codepointtrie.rs"
+harness = false
+
+[[bench]]
+name = "iai_cpt"
+path = "src/codepointtrie/benches/iai_cpt.rs"
+harness = false
+required-features = ["bench"]
+
+[[bench]]
+name = "inv_list"
+path = "src/codepointinvlist/benches/inv_list.rs"
+harness = false
+
+[dependencies.databake]
+version = "0.1.7"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.displaydoc]
+version = "0.2.3"
+default-features = false
+
+[dependencies.serde]
+version = "1.0"
+features = [
+ "derive",
+ "alloc",
+]
+optional = true
+default-features = false
+
+[dependencies.yoke]
+version = "0.7.3"
+features = ["derive"]
+default-features = false
+
+[dependencies.zerofrom]
+version = "0.1.2"
+features = ["derive"]
+default-features = false
+
+[dependencies.zerovec]
+version = "0.10.1"
+features = [
+ "derive",
+ "yoke",
+]
+default-features = false
+
+[dev-dependencies.iai]
+version = "0.1.1"
+
+[dev-dependencies.postcard]
+version = "1.0.0"
+features = ["alloc"]
+default-features = false
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.toml]
+version = "0.5"
+
+[features]
+bench = []
+databake = [
+ "dep:databake",
+ "zerovec/databake",
+]
+serde = [
+ "dep:serde",
+ "zerovec/serde",
+]
+std = []
+
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.criterion]
+version = "0.4"