summaryrefslogtreecommitdiffstats
path: root/third_party/rust/icu_provider/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/icu_provider/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/icu_provider/Cargo.toml')
-rw-r--r--third_party/rust/icu_provider/Cargo.toml161
1 files changed, 161 insertions, 0 deletions
diff --git a/third_party/rust/icu_provider/Cargo.toml b/third_party/rust/icu_provider/Cargo.toml
new file mode 100644
index 0000000000..5fbb63a341
--- /dev/null
+++ b/third_party/rust/icu_provider/Cargo.toml
@@ -0,0 +1,161 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.67"
+name = "icu_provider"
+version = "1.4.0"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "data/**/*",
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "tests/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "Trait and struct definitions for the ICU data provider"
+homepage = "https://icu4x.unicode.org"
+readme = "README.md"
+categories = ["internationalization"]
+license-file = "LICENSE"
+repository = "https://github.com/unicode-org/icu4x"
+
+[package.metadata.cargo-all-features]
+denylist = ["macros"]
+max_combination_size = 3
+
+[package.metadata.docs.rs]
+all-features = true
+
+[dependencies.bincode]
+version = "1.3"
+optional = true
+
+[dependencies.databake]
+version = "0.1.7"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.displaydoc]
+version = "0.2.3"
+default-features = false
+
+[dependencies.erased-serde]
+version = "0.3"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dependencies.icu_locid]
+version = "~1.4.0"
+default-features = false
+
+[dependencies.icu_provider_macros]
+version = "~1.4.0"
+optional = true
+default-features = false
+
+[dependencies.log]
+version = "0.4"
+optional = true
+
+[dependencies.postcard]
+version = "1.0.0"
+optional = true
+default-features = false
+
+[dependencies.serde]
+version = "1.0"
+features = [
+ "derive",
+ "alloc",
+]
+optional = true
+default-features = false
+
+[dependencies.serde_json]
+version = "1.0"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dependencies.stable_deref_trait]
+version = "1.2.0"
+default-features = false
+
+[dependencies.tinystr]
+version = "0.7.4"
+default-features = false
+
+[dependencies.writeable]
+version = "0.5.4"
+default-features = false
+
+[dependencies.yoke]
+version = "0.7.3"
+features = [
+ "alloc",
+ "derive",
+]
+default-features = false
+
+[dependencies.zerofrom]
+version = "0.1.2"
+features = [
+ "alloc",
+ "derive",
+]
+default-features = false
+
+[dependencies.zerovec]
+version = "0.10.1"
+features = ["derive"]
+default-features = false
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+datagen = [
+ "serde",
+ "dep:erased-serde",
+ "dep:databake",
+ "std",
+ "sync",
+]
+deserialize_bincode_1 = [
+ "serde",
+ "dep:bincode",
+ "std",
+]
+deserialize_json = [
+ "serde",
+ "dep:serde_json",
+]
+deserialize_postcard_1 = [
+ "serde",
+ "dep:postcard",
+]
+experimental = []
+log_error_context = ["logging"]
+logging = ["dep:log"]
+macros = ["dep:icu_provider_macros"]
+serde = [
+ "dep:serde",
+ "yoke/serde",
+]
+std = ["icu_locid/std"]
+sync = []