summaryrefslogtreecommitdiffstats
path: root/third_party/rust/icu_segmenter/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/icu_segmenter/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/icu_segmenter/Cargo.toml')
-rw-r--r--third_party/rust/icu_segmenter/Cargo.toml148
1 files changed, 148 insertions, 0 deletions
diff --git a/third_party/rust/icu_segmenter/Cargo.toml b/third_party/rust/icu_segmenter/Cargo.toml
new file mode 100644
index 0000000000..28a5945d49
--- /dev/null
+++ b/third_party/rust/icu_segmenter/Cargo.toml
@@ -0,0 +1,148 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.67"
+name = "icu_segmenter"
+version = "1.4.0"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "data/**/*",
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "tests/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "Unicode line breaking and text segmentation algorithms for text boundaries analysis"
+homepage = "https://icu4x.unicode.org"
+readme = "README.md"
+categories = ["internationalization"]
+license-file = "LICENSE"
+repository = "https://github.com/unicode-org/icu4x"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[lib]
+bench = false
+
+[[test]]
+name = "complex_word"
+required-features = ["auto"]
+
+[[bench]]
+name = "bench"
+harness = false
+
+[dependencies.core_maths]
+version = "0.1"
+optional = true
+
+[dependencies.databake]
+version = "0.1.7"
+features = ["derive"]
+optional = true
+default-features = false
+
+[dependencies.displaydoc]
+version = "0.2.3"
+default-features = false
+
+[dependencies.icu_collections]
+version = "~1.4.0"
+default-features = false
+
+[dependencies.icu_locid]
+version = "~1.4.0"
+default-features = false
+
+[dependencies.icu_locid_transform]
+version = "~1.4.0"
+features = ["compiled_data"]
+optional = true
+default-features = false
+
+[dependencies.icu_provider]
+version = "~1.4.0"
+features = ["macros"]
+default-features = false
+
+[dependencies.icu_segmenter_data]
+version = "~1.4.0"
+optional = true
+default-features = false
+
+[dependencies.serde]
+version = "1.0"
+features = [
+ "derive",
+ "alloc",
+]
+optional = true
+default-features = false
+
+[dependencies.utf8_iter]
+version = "1.0.3"
+
+[dependencies.zerovec]
+version = "0.10.1"
+features = ["yoke"]
+default-features = false
+
+[dev-dependencies.icu_properties]
+version = "~1.4.0"
+features = ["compiled_data"]
+default-features = false
+
+[dev-dependencies.itertools]
+version = "0.10"
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+default-features = false
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+auto = ["lstm"]
+bench = []
+compiled_data = ["dep:icu_segmenter_data"]
+datagen = [
+ "serde",
+ "dep:databake",
+ "zerovec/databake",
+ "icu_collections/databake",
+]
+default = [
+ "compiled_data",
+ "auto",
+]
+lstm = ["dep:core_maths"]
+serde = [
+ "dep:serde",
+ "zerovec/serde",
+ "icu_collections/serde",
+ "icu_provider/serde",
+]
+std = [
+ "icu_collections/std",
+ "icu_locid/std",
+ "icu_provider/std",
+]
+
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.criterion]
+version = "0.4"