summaryrefslogtreecommitdiffstats
path: root/third_party/rust/iovec/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/iovec/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/iovec/Cargo.toml')
-rw-r--r--third_party/rust/iovec/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/third_party/rust/iovec/Cargo.toml b/third_party/rust/iovec/Cargo.toml
new file mode 100644
index 0000000000..e950318358
--- /dev/null
+++ b/third_party/rust/iovec/Cargo.toml
@@ -0,0 +1,26 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "iovec"
+version = "0.1.4"
+authors = ["Carl Lerche <me@carllerche.com>"]
+description = "Portable buffer type for scatter/gather I/O operations\n"
+homepage = "https://github.com/carllerche/iovec"
+documentation = "https://docs.rs/iovec"
+readme = "README.md"
+keywords = ["scatter", "gather", "vectored", "io", "networking"]
+categories = ["network-programming", "api-bindings"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/carllerche/iovec"
+[target."cfg(unix)".dependencies.libc]
+version = "0.2"