summaryrefslogtreecommitdiffstats
path: root/third_party/rust/keccak/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/keccak/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/keccak/Cargo.toml')
-rw-r--r--third_party/rust/keccak/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/rust/keccak/Cargo.toml b/third_party/rust/keccak/Cargo.toml
new file mode 100644
index 0000000000..a5c08ba810
--- /dev/null
+++ b/third_party/rust/keccak/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "keccak"
+version = "0.1.4"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of the Keccak sponge function including the keccak-f
+and keccak-p variants
+"""
+documentation = "https://docs.rs/keccak"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "sponge",
+ "keccak",
+ "keccak-f",
+ "keccak-p",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/sponges/tree/master/keccak"
+
+[features]
+asm = []
+no_unroll = []
+simd = []
+
+[target."cfg(target_arch = \"aarch64\")".dependencies.cpufeatures]
+version = "0.2"