summaryrefslogtreecommitdiffstats
path: root/third_party/rust/lock_api/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/lock_api/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/lock_api/Cargo.toml')
-rw-r--r--third_party/rust/lock_api/Cargo.toml49
1 files changed, 49 insertions, 0 deletions
diff --git a/third_party/rust/lock_api/Cargo.toml b/third_party/rust/lock_api/Cargo.toml
new file mode 100644
index 0000000000..b1ff8c4db2
--- /dev/null
+++ b/third_party/rust/lock_api/Cargo.toml
@@ -0,0 +1,49 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "lock_api"
+version = "0.4.9"
+authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
+description = "Wrappers to create fully-featured Mutex and RwLock types. Compatible with no_std."
+keywords = [
+ "mutex",
+ "rwlock",
+ "lock",
+ "no_std",
+]
+categories = [
+ "concurrency",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/Amanieu/parking_lot"
+
+[dependencies.owning_ref]
+version = "0.4.1"
+optional = true
+
+[dependencies.scopeguard]
+version = "1.1.0"
+default-features = false
+
+[dependencies.serde]
+version = "1.0.126"
+optional = true
+default-features = false
+
+[build-dependencies.autocfg]
+version = "1.1.0"
+
+[features]
+arc_lock = []
+nightly = []