summaryrefslogtreecommitdiffstats
path: root/third_party/rust/metal/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/metal/Makefile
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/metal/Makefile')
-rw-r--r--third_party/rust/metal/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/third_party/rust/metal/Makefile b/third_party/rust/metal/Makefile
new file mode 100644
index 0000000000..ee7870c4e3
--- /dev/null
+++ b/third_party/rust/metal/Makefile
@@ -0,0 +1,16 @@
+
+compute:
+ xcrun -sdk macosx metal -c examples/compute/shaders.metal -o examples/compute/shaders.air
+ xcrun -sdk macosx metallib examples/compute/shaders.air -o examples/compute/shaders.metallib
+
+window:
+ xcrun -sdk macosx metal -c examples/window/shaders.metal -o examples/window/shaders.air
+ xcrun -sdk macosx metallib examples/window/shaders.air -o examples/window/shaders.metallib
+
+circle:
+ xcrun -sdk macosx metal -c examples/circle/shaders.metal -o examples/circle/shaders.air
+ xcrun -sdk macosx metallib examples/circle/shaders.air -o examples/circle/shaders.metallib
+
+raytracing:
+ xcrun -sdk macosx metal -c -g examples/raytracing/shaders.metal -o examples/raytracing/shaders.air
+ xcrun -sdk macosx metallib examples/raytracing/shaders.air -o examples/raytracing/shaders.metallib