summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mime_guess/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/mime_guess/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/mime_guess/Cargo.toml')
-rw-r--r--third_party/rust/mime_guess/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/third_party/rust/mime_guess/Cargo.toml b/third_party/rust/mime_guess/Cargo.toml
new file mode 100644
index 0000000000..fc6f68d2a7
--- /dev/null
+++ b/third_party/rust/mime_guess/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "mime_guess"
+version = "2.0.4"
+authors = ["Austin Bonander <austin.bonander@gmail.com>"]
+description = "A simple crate for detection of a file's MIME type by its extension."
+documentation = "https://docs.rs/mime_guess/"
+readme = "README.md"
+keywords = ["mime", "filesystem", "extension"]
+license = "MIT"
+repository = "https://github.com/abonander/mime_guess"
+
+[[example]]
+name = "rev_map"
+required-features = ["rev-mappings"]
+
+[[bench]]
+name = "benchmark"
+harness = false
+[dependencies.mime]
+version = "0.3"
+
+[dependencies.unicase]
+version = "2.4.0"
+[dev-dependencies.criterion]
+version = "0.3"
+[build-dependencies.unicase]
+version = "2.4.0"
+
+[features]
+default = ["rev-mappings"]
+rev-mappings = []