summaryrefslogtreecommitdiffstats
path: root/third_party/rust/mp4parse/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/mp4parse/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/mp4parse/Cargo.toml')
-rw-r--r--third_party/rust/mp4parse/Cargo.toml68
1 files changed, 68 insertions, 0 deletions
diff --git a/third_party/rust/mp4parse/Cargo.toml b/third_party/rust/mp4parse/Cargo.toml
new file mode 100644
index 0000000000..de277ab39f
--- /dev/null
+++ b/third_party/rust/mp4parse/Cargo.toml
@@ -0,0 +1,68 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "mp4parse"
+version = "0.17.0"
+authors = [
+ "Ralph Giles <giles@mozilla.com>",
+ "Matthew Gregan <kinetik@flim.org>",
+ "Alfredo Yang <ayang@mozilla.com>",
+ "Jon Bauman <jbauman@mozilla.com>",
+ "Bryce Seager van Dyk <bvandyk@mozilla.com>",
+]
+exclude = [
+ "*.mp4",
+ "*.avif",
+ "av1-avif/*",
+]
+description = "Parser for ISO base media file format (mp4)"
+documentation = "https://docs.rs/mp4parse/"
+readme = "README.md"
+categories = ["multimedia::video"]
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/mp4parse-rust"
+
+[lib]
+bench = false
+
+[[bench]]
+name = "avif_benchmark"
+harness = false
+
+[dependencies]
+byteorder = "1.2.1"
+log = "0.4"
+num-traits = "0.2.14"
+static_assertions = "1.1.0"
+
+[dependencies.bitreader]
+version = "0.3.2"
+
+[dependencies.fallible_collections]
+version = "0.4"
+features = ["std_io"]
+
+[dev-dependencies]
+criterion = "0.4"
+test-assembler = "0.1.2"
+walkdir = "2.3.1"
+
+[features]
+3gpp = []
+meta-xml = []
+missing-pixi-permitted = []
+mp4v = []
+unstable-api = []
+
+[badges.travis-ci]
+repository = "https://github.com/mozilla/mp4parse-rust"