summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-transport/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:35:29 +0000
commit59203c63bb777a3bacec32fb8830fba33540e809 (patch)
tree58298e711c0ff0575818c30485b44a2f21bf28a0 /third_party/rust/neqo-transport/Cargo.toml
parentAdding upstream version 126.0.1. (diff)
downloadfirefox-59203c63bb777a3bacec32fb8830fba33540e809.tar.xz
firefox-59203c63bb777a3bacec32fb8830fba33540e809.zip
Adding upstream version 127.0.upstream/127.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/neqo-transport/Cargo.toml')
-rw-r--r--third_party/rust/neqo-transport/Cargo.toml22
1 files changed, 14 insertions, 8 deletions
diff --git a/third_party/rust/neqo-transport/Cargo.toml b/third_party/rust/neqo-transport/Cargo.toml
index 9abdf9b984..78e551072e 100644
--- a/third_party/rust/neqo-transport/Cargo.toml
+++ b/third_party/rust/neqo-transport/Cargo.toml
@@ -11,9 +11,9 @@
[package]
edition = "2021"
-rust-version = "1.74.0"
+rust-version = "1.76.0"
name = "neqo-transport"
-version = "0.7.5"
+version = "0.7.7"
authors = ["The Neqo Authors <necko@mozilla.com>"]
homepage = "https://github.com/mozilla/neqo/"
license = "MIT OR Apache-2.0"
@@ -37,8 +37,12 @@ name = "range_tracker"
harness = false
required-features = ["bench"]
+[dependencies.enum-map]
+version = "2.7"
+default-features = false
+
[dependencies.indexmap]
-version = "1.9"
+version = "2.2"
default-features = false
[dependencies.log]
@@ -52,7 +56,7 @@ path = "../neqo-common"
path = "../neqo-crypto"
[dependencies.qlog]
-version = "0.12"
+version = "0.13"
default-features = false
[dependencies.smallvec]
@@ -64,15 +68,17 @@ version = "0.5"
features = ["html_reports"]
default-features = false
-[dev-dependencies.enum-map]
-version = "2.7"
-default-features = false
-
[dev-dependencies.test-fixture]
path = "../test-fixture"
[features]
bench = []
+build-fuzzing-corpus = [
+ "neqo-common/build-fuzzing-corpus",
+ "neqo-crypto/disable-encryption",
+ "neqo-crypto/disable-random",
+ "test-fixture/disable-random",
+]
disable-encryption = ["neqo-crypto/disable-encryption"]
[lints.clippy.pedantic]