summaryrefslogtreecommitdiffstats
path: root/third_party/rust/new_debug_unreachable/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/new_debug_unreachable/README.md
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/new_debug_unreachable/README.md')
-rw-r--r--third_party/rust/new_debug_unreachable/README.md42
1 files changed, 42 insertions, 0 deletions
diff --git a/third_party/rust/new_debug_unreachable/README.md b/third_party/rust/new_debug_unreachable/README.md
new file mode 100644
index 0000000000..b9c8b1e2c4
--- /dev/null
+++ b/third_party/rust/new_debug_unreachable/README.md
@@ -0,0 +1,42 @@
+# new_debug_unreachable
+
+> unreachable!() in debug, std::intrinsics::unreachable() in release.
+
+This is a fork of [`debug_unreachable`](https://crates.io/crates/debug_unreachable).
+
+## [Documentation](https://docs.rs/new_debug_unreachable)
+
+## Usage
+
+Use the crates.io repository; add this to your `Cargo.toml` along
+with the rest of your dependencies:
+
+```toml
+[dependencies]
+new_debug_unreachable = "1.0"
+```
+
+In your Rust code, the library name is still `debug_unreachable`:
+
+```rust
+use debug_unreachable::debug_unreachable;
+
+fn main() {
+ if 0 > 100 {
+ // Can't happen!
+ unsafe { debug_unreachable!() }
+ } else {
+ println!("Good, 0 <= 100.");
+ }
+}
+```
+
+## Author
+
+[Jonathan Reem](https://medium.com/@jreem) is the original author of debug-unreachable.
+
+[Matt Brubeck](https://limpet.net/mbrubeck/) is the maintainer of this fork.
+
+## License
+
+MIT