summaryrefslogtreecommitdiffstats
path: root/third_party/rust/nix/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/nix/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/nix/Cargo.toml')
-rw-r--r--third_party/rust/nix/Cargo.toml147
1 files changed, 147 insertions, 0 deletions
diff --git a/third_party/rust/nix/Cargo.toml b/third_party/rust/nix/Cargo.toml
new file mode 100644
index 0000000000..bb04ab2702
--- /dev/null
+++ b/third_party/rust/nix/Cargo.toml
@@ -0,0 +1,147 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.65"
+name = "nix"
+version = "0.27.1"
+authors = ["The nix-rust Project Developers"]
+include = [
+ "src/**/*",
+ "test/**/*",
+ "LICENSE",
+ "README.md",
+ "CHANGELOG.md",
+]
+description = "Rust friendly bindings to *nix APIs"
+readme = "README.md"
+categories = ["os::unix-apis"]
+license = "MIT"
+repository = "https://github.com/nix-rust/nix"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+targets = [
+ "x86_64-unknown-linux-gnu",
+ "aarch64-linux-android",
+ "x86_64-apple-darwin",
+ "aarch64-apple-ios",
+ "x86_64-unknown-freebsd",
+ "x86_64-unknown-openbsd",
+ "x86_64-unknown-netbsd",
+ "x86_64-unknown-dragonfly",
+ "x86_64-fuchsia",
+ "x86_64-unknown-redox",
+ "x86_64-unknown-illumos",
+]
+
+[[test]]
+name = "test"
+path = "test/test.rs"
+
+[[test]]
+name = "test-aio-drop"
+path = "test/sys/test_aio_drop.rs"
+
+[[test]]
+name = "test-clearenv"
+path = "test/test_clearenv.rs"
+
+[[test]]
+name = "test-mount"
+path = "test/test_mount.rs"
+harness = false
+
+[[test]]
+name = "test-prctl"
+path = "test/sys/test_prctl.rs"
+
+[dependencies.bitflags]
+version = "2.3.1"
+
+[dependencies.cfg-if]
+version = "1.0"
+
+[dependencies.libc]
+version = "0.2.147"
+features = ["extra_traits"]
+
+[dependencies.memoffset]
+version = "0.9"
+optional = true
+
+[dependencies.pin-utils]
+version = "0.1.0"
+optional = true
+
+[dev-dependencies.assert-impl]
+version = "0.1"
+
+[dev-dependencies.parking_lot]
+version = "0.12"
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[dev-dependencies.semver]
+version = "1.0.7"
+
+[dev-dependencies.tempfile]
+version = "3.7.1"
+
+[features]
+acct = []
+aio = ["pin-utils"]
+default = []
+dir = ["fs"]
+env = []
+event = []
+feature = []
+fs = []
+hostname = []
+inotify = []
+ioctl = []
+kmod = []
+mman = []
+mount = ["uio"]
+mqueue = ["fs"]
+net = ["socket"]
+personality = []
+poll = []
+process = []
+pthread = []
+ptrace = ["process"]
+quota = []
+reboot = []
+resource = []
+sched = ["process"]
+signal = ["process"]
+socket = ["memoffset"]
+term = []
+time = []
+ucontext = ["signal"]
+uio = []
+user = ["feature"]
+zerocopy = [
+ "fs",
+ "uio",
+]
+
+[target."cfg(any(target_os = \"android\", target_os = \"linux\"))".dev-dependencies.caps]
+version = "0.5.3"
+
+[target."cfg(target_os = \"freebsd\")".dev-dependencies.sysctl]
+version = "0.4"