summaryrefslogtreecommitdiffstats
path: root/third_party/rust/origin-trial-token/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/origin-trial-token/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/origin-trial-token/Cargo.toml')
-rw-r--r--third_party/rust/origin-trial-token/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/third_party/rust/origin-trial-token/Cargo.toml b/third_party/rust/origin-trial-token/Cargo.toml
new file mode 100644
index 0000000000..c78becce9f
--- /dev/null
+++ b/third_party/rust/origin-trial-token/Cargo.toml
@@ -0,0 +1,33 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "origin-trial-token"
+version = "0.1.1"
+authors = ["Emilio Cobos Álvarez <emilio@crisal.io>"]
+description = "An implementation of the Chrome Origin Trial token format"
+license = "MPL-2.0"
+repository = "https://github.com/mozilla/origin-trial-token"
+resolver = "2"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.base64]
+version = "0.13"