summaryrefslogtreecommitdiffstats
path: root/third_party/rust/plist/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/plist/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/plist/Cargo.toml')
-rw-r--r--third_party/rust/plist/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/third_party/rust/plist/Cargo.toml b/third_party/rust/plist/Cargo.toml
new file mode 100644
index 0000000000..4829298f4f
--- /dev/null
+++ b/third_party/rust/plist/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "plist"
+version = "1.3.1"
+authors = ["Ed Barnard <eabarnard@gmail.com>"]
+description = "A rusty plist parser. Supports Serde serialization."
+documentation = "https://docs.rs/plist/1.3.1/plist/"
+keywords = ["plist", "parser"]
+categories = ["config", "encoding", "parser-implementations"]
+license = "MIT"
+repository = "https://github.com/ebarnard/rust-plist/"
+[dependencies.base64]
+version = "0.13.0"
+
+[dependencies.indexmap]
+version = "1.0.2"
+
+[dependencies.line-wrap]
+version = "0.1.1"
+
+[dependencies.serde]
+version = "1.0.2"
+optional = true
+
+[dependencies.time]
+version = "0.3.3"
+features = ["parsing", "formatting"]
+
+[dependencies.xml_rs]
+version = "0.8.2"
+package = "xml-rs"
+[dev-dependencies.serde_derive]
+version = "1.0.2"
+
+[dev-dependencies.serde_yaml]
+version = "0.8.21"
+
+[features]
+default = ["serde"]
+enable_unstable_features_that_may_break_with_minor_version_bumps = []