summaryrefslogtreecommitdiffstats
path: root/third_party/rust/profiling/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/profiling/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/profiling/Cargo.toml')
-rw-r--r--third_party/rust/profiling/Cargo.toml129
1 files changed, 129 insertions, 0 deletions
diff --git a/third_party/rust/profiling/Cargo.toml b/third_party/rust/profiling/Cargo.toml
new file mode 100644
index 0000000000..e5ac884890
--- /dev/null
+++ b/third_party/rust/profiling/Cargo.toml
@@ -0,0 +1,129 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "profiling"
+version = "1.0.7"
+authors = ["Philip Degarmo <aclysma@gmail.com>"]
+exclude = [
+ "/examples",
+ "/screenshots",
+]
+description = "This crate provides a very thin abstraction over other profiler crates."
+homepage = "https://github.com/aclysma/profiling"
+readme = "README.md"
+keywords = [
+ "performance",
+ "profiling",
+]
+categories = ["development-tools::profiling"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/aclysma/profiling"
+
+[[example]]
+name = "puffin"
+path = "examples/puffin/puffin.rs"
+required-features = ["profile-with-puffin"]
+
+[[example]]
+name = "simple"
+path = "examples/simple.rs"
+required-features = []
+
+[dependencies.optick]
+version = "1.3"
+optional = true
+
+[dependencies.profiling-procmacros]
+version = "1.0.7"
+optional = true
+
+[dependencies.puffin]
+version = "0.12.1"
+optional = true
+
+[dependencies.superluminal-perf]
+version = "0.1"
+optional = true
+
+[dependencies.tracing]
+version = "0.1"
+optional = true
+
+[dependencies.tracy-client]
+version = "0.14.1"
+optional = true
+
+[dev-dependencies.bincode]
+version = "1.3.1"
+
+[dev-dependencies.env_logger]
+version = "0.6"
+
+[dev-dependencies.glam]
+version = "0.8.6"
+
+[dev-dependencies.imgui]
+version = "0.8"
+
+[dev-dependencies.imgui-winit-support]
+version = "0.8"
+
+[dev-dependencies.lazy_static]
+version = "1"
+
+[dev-dependencies.log]
+version = "0.4"
+
+[dev-dependencies.puffin-imgui]
+version = "0.15.0"
+
+[dev-dependencies.rafx]
+version = "=0.0.14"
+features = [
+ "rafx-vulkan",
+ "framework",
+]
+
+[dev-dependencies.tracing-subscriber]
+version = "0.2"
+
+[dev-dependencies.tracing-tracy]
+version = "0.4.0"
+
+[dev-dependencies.winit]
+version = "0.25"
+
+[features]
+default = ["procmacros"]
+procmacros = ["profiling-procmacros"]
+profile-with-optick = [
+ "optick",
+ "profiling-procmacros/profile-with-optick",
+]
+profile-with-puffin = [
+ "puffin",
+ "profiling-procmacros/profile-with-puffin",
+]
+profile-with-superluminal = [
+ "superluminal-perf",
+ "profiling-procmacros/profile-with-superluminal",
+]
+profile-with-tracing = [
+ "tracing",
+ "profiling-procmacros/profile-with-tracing",
+]
+profile-with-tracy = [
+ "tracy-client",
+ "profiling-procmacros/profile-with-tracy",
+]
+type-check = []