summaryrefslogtreecommitdiffstats
path: root/third_party/rust/regex-syntax/test
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/regex-syntax/test
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/regex-syntax/test')
-rwxr-xr-xthird_party/rust/regex-syntax/test30
1 files changed, 30 insertions, 0 deletions
diff --git a/third_party/rust/regex-syntax/test b/third_party/rust/regex-syntax/test
new file mode 100755
index 0000000000..8626c3bfcc
--- /dev/null
+++ b/third_party/rust/regex-syntax/test
@@ -0,0 +1,30 @@
+#!/bin/bash
+
+set -e
+
+# cd to the directory containing this crate's Cargo.toml so that we don't need
+# to pass --manifest-path to every `cargo` command.
+cd "$(dirname "$0")"
+
+# This is a convenience script for running a broad swath of the syntax tests.
+echo "===== DEFAULT FEATURES ==="
+cargo test
+
+features=(
+ std
+ unicode
+ unicode-age
+ unicode-bool
+ unicode-case
+ unicode-gencat
+ unicode-perl
+ unicode-script
+ unicode-segment
+)
+for f in "${features[@]}"; do
+ echo "=== FEATURE: $f ==="
+ # We only run library tests because I couldn't figure out how to easily
+ # make doc tests run in 'no_std' mode. In particular, without the Error
+ # trait, using '?' in doc tests seems tricky.
+ cargo test --no-default-features --lib --features "$f"
+done