summaryrefslogtreecommitdiffstats
path: root/third_party/rust/safemem
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/safemem
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/safemem')
-rw-r--r--third_party/rust/safemem/.cargo-checksum.json1
-rw-r--r--third_party/rust/safemem/Cargo.toml28
-rw-r--r--third_party/rust/safemem/LICENSE-APACHE201
-rw-r--r--third_party/rust/safemem/LICENSE-MIT25
-rw-r--r--third_party/rust/safemem/README.md27
-rw-r--r--third_party/rust/safemem/run_miri.sh11
-rw-r--r--third_party/rust/safemem/src/lib.rs143
7 files changed, 436 insertions, 0 deletions
diff --git a/third_party/rust/safemem/.cargo-checksum.json b/third_party/rust/safemem/.cargo-checksum.json
new file mode 100644
index 0000000000..11e964e5c2
--- /dev/null
+++ b/third_party/rust/safemem/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"1a812b03bbe60da68e444ffc2b54b1c8696d3d9694a08784b80d6f3911762534","LICENSE-APACHE":"7cfd738c53d61c79f07e348f622bf7707c9084237054d37fbe07788a75f5881c","LICENSE-MIT":"64e1c5f067ee2d8c0ee8abd751e57275d4e97e4f7c05699bc23f5005a9c53043","README.md":"fcdfcdc818bac5fbccc5dfc25f8e2916226916c9f3bbd37b6646013bb34c5145","run_miri.sh":"3e9f2a577a268a97b93680a9ec3c218fc231c8fed3e155925c6d58ca89435d63","src/lib.rs":"cec30b7c5f141f490f30b5d08b4925904af47f518b049d69c2f8c48199d24a27"},"package":"ef703b7cb59335eae2eb93ceb664c0eb7ea6bf567079d843e09420219668e072"} \ No newline at end of file
diff --git a/third_party/rust/safemem/Cargo.toml b/third_party/rust/safemem/Cargo.toml
new file mode 100644
index 0000000000..bfdc63f289
--- /dev/null
+++ b/third_party/rust/safemem/Cargo.toml
@@ -0,0 +1,28 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "safemem"
+version = "0.3.3"
+authors = ["Austin Bonander <austin.bonander@gmail.com>"]
+description = "Safe wrappers for memory-accessing functions, like `std::ptr::copy()`."
+documentation = "https://docs.rs/safemem"
+keywords = ["memset", "memmove", "copy"]
+categories = ["no-std"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/abonander/safemem"
+
+[dependencies]
+
+[features]
+default = ["std"]
+std = []
diff --git a/third_party/rust/safemem/LICENSE-APACHE b/third_party/rust/safemem/LICENSE-APACHE
new file mode 100644
index 0000000000..f47c941141
--- /dev/null
+++ b/third_party/rust/safemem/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/third_party/rust/safemem/LICENSE-MIT b/third_party/rust/safemem/LICENSE-MIT
new file mode 100644
index 0000000000..69bdcf51ce
--- /dev/null
+++ b/third_party/rust/safemem/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2016 The `multipart` Crate Developers
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/third_party/rust/safemem/README.md b/third_party/rust/safemem/README.md
new file mode 100644
index 0000000000..1ded7a626c
--- /dev/null
+++ b/third_party/rust/safemem/README.md
@@ -0,0 +1,27 @@
+# safemem ![Travis (.org)](https://img.shields.io/travis/abonander/safemem)
+Safe wrappers for `memmove`, `memset`, etc. in Rust
+
+##### Minimum Supported Rust Version: 1.19.0
+
+`no_std` Support
+----------------
+
+This crate has support for `no_std` which is controlled via default feature `std`. To use the crate
+in a `no_std` environment simply turn off default features.
+
+
+License
+-------
+
+Licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in the work by you, as defined in the Apache-2.0 license, shall be dual licensed as above, without any
+additional terms or conditions.
diff --git a/third_party/rust/safemem/run_miri.sh b/third_party/rust/safemem/run_miri.sh
new file mode 100644
index 0000000000..20b96c37fb
--- /dev/null
+++ b/third_party/rust/safemem/run_miri.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+MIRI_NIGHTLY=nightly-$(curl -s https://rust-lang.github.io/rustup-components-history/x86_64-unknown-linux-gnu/miri)
+echo "Installing latest nightly with Miri: $MIRI_NIGHTLY"
+rustup set profile minimal
+rustup default "$MIRI_NIGHTLY"
+
+rustup component add miri
+cargo miri setup
+
+cargo miri test -- -- -Zunstable-options --exclude-should-panic
diff --git a/third_party/rust/safemem/src/lib.rs b/third_party/rust/safemem/src/lib.rs
new file mode 100644
index 0000000000..a30c933906
--- /dev/null
+++ b/third_party/rust/safemem/src/lib.rs
@@ -0,0 +1,143 @@
+//! Safe wrappers for memory-accessing functions like `std::ptr::copy()`.
+
+#![cfg_attr(not(feature = "std"), no_std)]
+
+#[cfg(not(feature = "std"))]
+extern crate core as std;
+use std::ptr;
+
+macro_rules! idx_check (
+ ($slice:expr, $idx:expr) => {
+ assert!($idx < $slice.len(),
+ concat!("`", stringify!($idx), "` ({}) out of bounds. Length: {}"),
+ $idx, $slice.len());
+ }
+);
+
+macro_rules! len_check (
+ ($slice:expr, $start:ident, $len:ident) => {
+ assert!(
+ $start.checked_add($len)
+ .expect(concat!("Overflow evaluating ", stringify!($start + $len)))
+ <= $slice.len(),
+ "Length {} starting at {} is out of bounds (slice len {}).", $len, $start, $slice.len()
+ )
+ }
+);
+
+/// Copy `len` elements from `src_idx` to `dest_idx`. Ranges may overlap.
+///
+/// Safe wrapper for `memmove()`/`std::ptr::copy()`.
+///
+/// ###Panics
+/// * If either `src_idx` or `dest_idx` are out of bounds, or if either of these plus `len` is out of
+/// bounds.
+/// * If `src_idx + len` or `dest_idx + len` overflows.
+pub fn copy_over<T: Copy>(slice: &mut [T], src_idx: usize, dest_idx: usize, len: usize) {
+ if slice.len() == 0 { return; }
+
+ idx_check!(slice, src_idx);
+ idx_check!(slice, dest_idx);
+ len_check!(slice, src_idx, len);
+ len_check!(slice, dest_idx, len);
+
+ // At any point a Rust reference exists, the compiler is free to do this.
+ // So we explicitely add it to be caught by miri.
+ #[cfg(miri)]
+ slice.iter().copied().for_each(drop);
+
+ let ptr = slice.as_mut_ptr();
+
+ unsafe {
+ ptr::copy(ptr.offset(src_idx as isize), ptr.offset(dest_idx as isize), len);
+ }
+}
+
+/// Safe wrapper for `std::ptr::write_bytes()`/`memset()`.
+pub fn write_bytes(slice: &mut [u8], byte: u8) {
+ unsafe {
+ ptr::write_bytes(slice.as_mut_ptr(), byte, slice.len());
+ }
+}
+
+/// Prepend `elems` to `vec`, resizing if necessary.
+///
+/// ### Panics
+///
+/// If `vec.len() + elems.len()` overflows.
+#[cfg(feature = "std")]
+pub fn prepend<T: Copy>(elems: &[T], vec: &mut Vec<T>) {
+ let elems_len = elems.len(); // `<= isize::MAX as usize`
+ if elems_len == 0 { return; }
+
+ let old_len = vec.len(); // `<= isize::MAX as usize`
+ if old_len == 0 {
+ // Prepend = append: delegate to Rust's stdlib implementation.
+ vec.extend_from_slice(elems);
+ } else {
+ // Our overflow check occurs here, no need to do it ourselves.
+ vec.reserve(elems_len);
+ let ptr = vec.as_mut_ptr();
+ unsafe {
+ // Move the old elements down to the end.
+ ptr::copy(
+ ptr,
+ ptr.offset(elems_len as isize),
+ old_len,
+ );
+ // Copy the input elements to the start
+ ptr::copy_nonoverlapping(
+ elems.as_ptr(),
+ ptr,
+ elems_len,
+ );
+ // Set the len *after* having initialized the elements.
+ vec.set_len(old_len + elems_len);
+ }
+ }
+}
+
+#[cfg(test)]
+mod tests {
+ use super::*;
+
+ #[test]
+ #[should_panic]
+ fn bounds_check() {
+ let mut arr = [0i32, 1, 2, 3, 4, 5];
+
+ copy_over(&mut arr, 2, 1, 7);
+ }
+
+ #[test]
+ fn copy_empty() {
+ let mut arr: [i32; 0] = [];
+
+ copy_over(&mut arr, 0, 0, 0);
+ }
+
+ #[test]
+ #[cfg(feature = "std")]
+ fn prepend_empty() {
+ let mut vec: Vec<i32> = vec![];
+ prepend(&[1, 2, 3], &mut vec);
+ }
+
+ #[test]
+ #[cfg(feature = "std")]
+ fn prepend_i32() {
+ let mut vec = vec![3, 4, 5];
+ prepend(&[1, 2], &mut vec);
+ assert_eq!(vec, &[1, 2, 3, 4, 5]);
+ }
+
+ /// Detect potential uninit values when running miri
+ #[test]
+ #[cfg(all(
+ feature = "std",
+ miri,
+ ))]
+ fn prepend_bool() {
+ prepend(&[true], &mut vec![false]);
+ }
+}