summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serde_json/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/serde_json/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/serde_json/Cargo.toml')
-rw-r--r--third_party/rust/serde_json/Cargo.toml109
1 files changed, 109 insertions, 0 deletions
diff --git a/third_party/rust/serde_json/Cargo.toml b/third_party/rust/serde_json/Cargo.toml
new file mode 100644
index 0000000000..cff28cd7b2
--- /dev/null
+++ b/third_party/rust/serde_json/Cargo.toml
@@ -0,0 +1,109 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.36"
+name = "serde_json"
+version = "1.0.93"
+authors = [
+ "Erick Tryzelaar <erick.tryzelaar@gmail.com>",
+ "David Tolnay <dtolnay@gmail.com>",
+]
+description = "A JSON serialization file format"
+documentation = "https://docs.rs/serde_json"
+readme = "README.md"
+keywords = [
+ "json",
+ "serde",
+ "serialization",
+]
+categories = [
+ "encoding",
+ "parser-implementations",
+ "no-std",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/serde-rs/json"
+
+[package.metadata.docs.rs]
+features = [
+ "raw_value",
+ "unbounded_depth",
+]
+targets = ["x86_64-unknown-linux-gnu"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[package.metadata.playground]
+features = ["raw_value"]
+
+[lib]
+doc-scrape-examples = false
+
+[dependencies.indexmap]
+version = "1.5.2"
+features = ["std"]
+optional = true
+
+[dependencies.itoa]
+version = "1.0"
+
+[dependencies.ryu]
+version = "1.0"
+
+[dependencies.serde]
+version = "1.0.100"
+default-features = false
+
+[dev-dependencies.automod]
+version = "1.0"
+
+[dev-dependencies.indoc]
+version = "2.0"
+
+[dev-dependencies.ref-cast]
+version = "1.0"
+
+[dev-dependencies.rustversion]
+version = "1.0"
+
+[dev-dependencies.serde]
+version = "1.0.100"
+features = ["derive"]
+
+[dev-dependencies.serde_bytes]
+version = "0.11"
+
+[dev-dependencies.serde_derive]
+version = "1.0"
+
+[dev-dependencies.serde_stacker]
+version = "0.1"
+
+[dev-dependencies.trybuild]
+version = "1.0.49"
+features = ["diff"]
+
+[features]
+alloc = ["serde/alloc"]
+arbitrary_precision = []
+default = ["std"]
+float_roundtrip = []
+preserve_order = [
+ "indexmap",
+ "std",
+]
+raw_value = []
+std = ["serde/std"]
+unbounded_depth = []