summaryrefslogtreecommitdiffstats
path: root/third_party/rust/serde_with_macros/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/serde_with_macros/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/serde_with_macros/Cargo.toml')
-rw-r--r--third_party/rust/serde_with_macros/Cargo.toml105
1 files changed, 105 insertions, 0 deletions
diff --git a/third_party/rust/serde_with_macros/Cargo.toml b/third_party/rust/serde_with_macros/Cargo.toml
new file mode 100644
index 0000000000..e833eb60e0
--- /dev/null
+++ b/third_party/rust/serde_with_macros/Cargo.toml
@@ -0,0 +1,105 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.60"
+name = "serde_with_macros"
+version = "3.0.0"
+authors = ["Jonas Bushart"]
+include = [
+ "src/**/*",
+ "tests/**/*",
+ "!tests/compile-fail/**",
+ "LICENSE-*",
+ "README.md",
+ "CHANGELOG.md",
+]
+description = "proc-macro library for serde_with"
+documentation = "https://docs.rs/serde_with_macros/"
+readme = "README.md"
+keywords = [
+ "serde",
+ "utilities",
+ "serialization",
+ "deserialization",
+]
+categories = ["encoding"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/jonasbb/serde_with/"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[package.metadata.release]
+tag = false
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+replace = """
+[Unreleased]
+
+## [{{version}}] - {{date}}"""
+search = '\[Unreleased\]'
+
+[[package.metadata.release.pre-release-replacements]]
+file = "src/lib.rs"
+replace = "https://docs.rs/serde_with/{{version}}/"
+search = 'https://docs\.rs/serde_with/[\d.]+/'
+
+[[package.metadata.release.pre-release-replacements]]
+file = "src/lib.rs"
+replace = "https://docs.rs/serde_with_macros/{{version}}/"
+search = 'https://docs\.rs/serde_with_macros/[\d.]+/'
+
+[lib]
+proc-macro = true
+
+[dependencies.darling]
+version = "0.20.0"
+
+[dependencies.proc-macro2]
+version = "1.0.1"
+
+[dependencies.quote]
+version = "1.0.0"
+
+[dependencies.syn]
+version = "2.0.0"
+features = [
+ "full",
+ "parsing",
+]
+
+[dev-dependencies.expect-test]
+version = "1.4.0"
+
+[dev-dependencies.pretty_assertions]
+version = "1.0.0"
+
+[dev-dependencies.rustversion]
+version = "1.0.0"
+
+[dev-dependencies.serde]
+version = "1.0.157"
+features = ["derive"]
+
+[dev-dependencies.serde_json]
+version = "1.0.25"
+
+[dev-dependencies.trybuild]
+version = "1.0.80"
+
+[dev-dependencies.version-sync]
+version = "0.9.1"
+
+[badges.maintenance]
+status = "actively-developed"