summaryrefslogtreecommitdiffstats
path: root/third_party/rust/time-0.1.45/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/time-0.1.45/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/time-0.1.45/Cargo.toml')
-rw-r--r--third_party/rust/time-0.1.45/Cargo.toml60
1 files changed, 60 insertions, 0 deletions
diff --git a/third_party/rust/time-0.1.45/Cargo.toml b/third_party/rust/time-0.1.45/Cargo.toml
new file mode 100644
index 0000000000..4f6912ef9d
--- /dev/null
+++ b/third_party/rust/time-0.1.45/Cargo.toml
@@ -0,0 +1,60 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "time"
+version = "0.1.45"
+authors = ["The Rust Project Developers"]
+exclude = [
+ ".github",
+ "benches",
+]
+description = """
+Utilities for working with time-related functions in Rust.
+"""
+homepage = "https://github.com/time-rs/time"
+documentation = "https://docs.rs/time/~0.1"
+readme = "README.md"
+license = "MIT/Apache-2.0"
+repository = "https://github.com/time-rs/time"
+
+[dependencies.libc]
+version = "0.2.69"
+
+[dependencies.rustc-serialize]
+version = "0.3"
+optional = true
+
+[dev-dependencies.log]
+version = "0.4"
+
+[dev-dependencies.winapi]
+version = "0.3.0"
+features = [
+ "std",
+ "processthreadsapi",
+ "winbase",
+]
+
+[target."cfg(target_os = \"wasi\")".dependencies.wasi]
+version = "=0.10.0"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3.0"
+features = [
+ "std",
+ "minwinbase",
+ "minwindef",
+ "ntdef",
+ "profileapi",
+ "sysinfoapi",
+ "timezoneapi",
+]