summaryrefslogtreecommitdiffstats
path: root/third_party/rust/tinystr/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/tinystr/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/tinystr/Cargo.toml')
-rw-r--r--third_party/rust/tinystr/Cargo.toml123
1 files changed, 123 insertions, 0 deletions
diff --git a/third_party/rust/tinystr/Cargo.toml b/third_party/rust/tinystr/Cargo.toml
new file mode 100644
index 0000000000..f82bb66b8c
--- /dev/null
+++ b/third_party/rust/tinystr/Cargo.toml
@@ -0,0 +1,123 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.66"
+name = "tinystr"
+version = "0.7.4"
+authors = ["The ICU4X Project Developers"]
+include = [
+ "data/**/*",
+ "src/**/*",
+ "examples/**/*",
+ "benches/**/*",
+ "tests/**/*",
+ "Cargo.toml",
+ "LICENSE",
+ "README.md",
+]
+description = "A small ASCII-only bounded length string representation."
+readme = "README.md"
+keywords = [
+ "string",
+ "str",
+ "small",
+ "tiny",
+ "no_std",
+]
+categories = ["data-structures"]
+license-file = "LICENSE"
+repository = "https://github.com/unicode-org/icu4x"
+
+[package.metadata.cargo-all-features]
+denylist = ["bench"]
+
+[package.metadata.docs.rs]
+all-features = true
+
+[package.metadata.workspaces]
+independent = true
+
+[lib]
+bench = false
+
+[[test]]
+name = "serde"
+required-features = ["serde"]
+
+[[bench]]
+name = "overview"
+harness = false
+
+[[bench]]
+name = "construct"
+harness = false
+required-features = ["bench"]
+
+[[bench]]
+name = "read"
+harness = false
+required-features = ["bench"]
+
+[[bench]]
+name = "serde"
+harness = false
+required-features = [
+ "bench",
+ "serde",
+]
+
+[dependencies.databake]
+version = "0.1.6"
+optional = true
+default-features = false
+
+[dependencies.displaydoc]
+version = "0.2.3"
+default-features = false
+
+[dependencies.serde]
+version = "1.0.123"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dependencies.zerovec]
+version = "0.10.0"
+optional = true
+default-features = false
+
+[dev-dependencies.bincode]
+version = "1.3"
+
+[dev-dependencies.postcard]
+version = "1.0.0"
+features = ["use-std"]
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8.5"
+features = ["small_rng"]
+
+[dev-dependencies.serde_json]
+version = "1.0"
+features = ["alloc"]
+default-features = false
+
+[features]
+alloc = []
+bench = []
+default = ["alloc"]
+std = []
+
+[target."cfg(not(target_arch = \"wasm32\"))".dev-dependencies.criterion]
+version = "0.4"