summaryrefslogtreecommitdiffstats
path: root/third_party/rust/uluru
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/uluru
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/uluru')
-rw-r--r--third_party/rust/uluru/.cargo-checksum.json1
-rw-r--r--third_party/rust/uluru/Cargo.toml27
-rw-r--r--third_party/rust/uluru/LICENSE373
-rw-r--r--third_party/rust/uluru/README.md12
-rw-r--r--third_party/rust/uluru/src/lib.rs341
-rw-r--r--third_party/rust/uluru/src/tests.rs216
6 files changed, 970 insertions, 0 deletions
diff --git a/third_party/rust/uluru/.cargo-checksum.json b/third_party/rust/uluru/.cargo-checksum.json
new file mode 100644
index 0000000000..d2996c097f
--- /dev/null
+++ b/third_party/rust/uluru/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"ccdd1542eacc6997f531dcf6aaba11659a7caed7935956b59121f2ca24168344","LICENSE":"3db78572e8657cca9e9446ce56a057b8a981eb41af318c49a5fe08e7a10fa52a","README.md":"ba37d1f9ea9f852f81d984b612c9028ccc96d9e1da6d9bf2c7fb51cbf10c9066","src/lib.rs":"f8990d5ff57fc701aff48338cb03e8b10e61a5f453951227823fa1ab591565cd","src/tests.rs":"7b748c3be231655c3fda95da219c6f13b4c3f6b9b383457d42b6dea35fdf6b38"},"package":"794a32261a1f5eb6a4462c81b59cec87b5c27d5deea7dd1ac8fc781c41d226db"} \ No newline at end of file
diff --git a/third_party/rust/uluru/Cargo.toml b/third_party/rust/uluru/Cargo.toml
new file mode 100644
index 0000000000..9399b085af
--- /dev/null
+++ b/third_party/rust/uluru/Cargo.toml
@@ -0,0 +1,27 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "uluru"
+version = "3.0.0"
+authors = ["The Servo Project Developers", "Matt Brubeck <mbrubeck@limpet.net>"]
+include = ["src/**/*", "LICENSE", "README.md"]
+description = "A simple, fast, LRU cache implementation"
+readme = "README.md"
+keywords = ["cache", "linkedlist", "array", "no_std"]
+categories = ["data-structures", "no-std"]
+license = "MPL-2.0"
+repository = "https://github.com/servo/uluru"
+[dependencies.arrayvec]
+version = "0.7"
+default-features = false
diff --git a/third_party/rust/uluru/LICENSE b/third_party/rust/uluru/LICENSE
new file mode 100644
index 0000000000..9ad641286f
--- /dev/null
+++ b/third_party/rust/uluru/LICENSE
@@ -0,0 +1,373 @@
+ Mozilla Public License Version 2.0
+==================================
+
+1. Definitions
+--------------
+
+1.1. "Contributor"
+means each individual or legal entity that creates, contributes to
+the creation of, or owns Covered Software.
+
+1.2. "Contributor Version"
+means the combination of the Contributions of others (if any) used
+by a Contributor and that particular Contributor's Contribution.
+
+1.3. "Contribution"
+means Covered Software of a particular Contributor.
+
+1.4. "Covered Software"
+means Source Code Form to which the initial Contributor has attached
+the notice in Exhibit A, the Executable Form of such Source Code
+Form, and Modifications of such Source Code Form, in each case
+including portions thereof.
+
+1.5. "Incompatible With Secondary Licenses"
+means
+
+(a) that the initial Contributor has attached the notice described
+in Exhibit B to the Covered Software; or
+
+(b) that the Covered Software was made available under the terms of
+version 1.1 or earlier of the License, but not also under the
+terms of a Secondary License.
+
+1.6. "Executable Form"
+means any form of the work other than Source Code Form.
+
+1.7. "Larger Work"
+means a work that combines Covered Software with other material, in
+a separate file or files, that is not Covered Software.
+
+1.8. "License"
+means this document.
+
+1.9. "Licensable"
+means having the right to grant, to the maximum extent possible,
+whether at the time of the initial grant or subsequently, any and
+all of the rights conveyed by this License.
+
+1.10. "Modifications"
+means any of the following:
+
+(a) any file in Source Code Form that results from an addition to,
+deletion from, or modification of the contents of Covered
+Software; or
+
+(b) any new file in Source Code Form that contains any Covered
+Software.
+
+1.11. "Patent Claims" of a Contributor
+means any patent claim(s), including without limitation, method,
+process, and apparatus claims, in any patent Licensable by such
+Contributor that would be infringed, but for the grant of the
+License, by the making, using, selling, offering for sale, having
+made, import, or transfer of either its Contributions or its
+Contributor Version.
+
+1.12. "Secondary License"
+means either the GNU General Public License, Version 2.0, the GNU
+Lesser General Public License, Version 2.1, the GNU Affero General
+Public License, Version 3.0, or any later versions of those
+licenses.
+
+1.13. "Source Code Form"
+means the form of the work preferred for making modifications.
+
+1.14. "You" (or "Your")
+means an individual or a legal entity exercising rights under this
+License. For legal entities, "You" includes any entity that
+controls, is controlled by, or is under common control with You. For
+purposes of this definition, "control" means (a) the power, direct
+or indirect, to cause the direction or management of such entity,
+whether by contract or otherwise, or (b) ownership of more than
+fifty percent (50%) of the outstanding shares or beneficial
+ownership of such entity.
+
+2. License Grants and Conditions
+--------------------------------
+
+2.1. Grants
+
+Each Contributor hereby grants You a world-wide, royalty-free,
+non-exclusive license:
+
+(a) under intellectual property rights (other than patent or trademark)
+Licensable by such Contributor to use, reproduce, make available,
+modify, display, perform, distribute, and otherwise exploit its
+Contributions, either on an unmodified basis, with Modifications, or
+as part of a Larger Work; and
+
+(b) under Patent Claims of such Contributor to make, use, sell, offer
+for sale, have made, import, and otherwise transfer either its
+Contributions or its Contributor Version.
+
+2.2. Effective Date
+
+The licenses granted in Section 2.1 with respect to any Contribution
+become effective for each Contribution on the date the Contributor first
+distributes such Contribution.
+
+2.3. Limitations on Grant Scope
+
+The licenses granted in this Section 2 are the only rights granted under
+this License. No additional rights or licenses will be implied from the
+distribution or licensing of Covered Software under this License.
+Notwithstanding Section 2.1(b) above, no patent license is granted by a
+Contributor:
+
+(a) for any code that a Contributor has removed from Covered Software;
+or
+
+(b) for infringements caused by: (i) Your and any other third party's
+modifications of Covered Software, or (ii) the combination of its
+Contributions with other software (except as part of its Contributor
+Version); or
+
+(c) under Patent Claims infringed by Covered Software in the absence of
+its Contributions.
+
+This License does not grant any rights in the trademarks, service marks,
+or logos of any Contributor (except as may be necessary to comply with
+the notice requirements in Section 3.4).
+
+2.4. Subsequent Licenses
+
+No Contributor makes additional grants as a result of Your choice to
+distribute the Covered Software under a subsequent version of this
+License (see Section 10.2) or under the terms of a Secondary License (if
+permitted under the terms of Section 3.3).
+
+2.5. Representation
+
+Each Contributor represents that the Contributor believes its
+Contributions are its original creation(s) or it has sufficient rights
+to grant the rights to its Contributions conveyed by this License.
+
+2.6. Fair Use
+
+This License is not intended to limit any rights You have under
+applicable copyright doctrines of fair use, fair dealing, or other
+equivalents.
+
+2.7. Conditions
+
+Sections 3.1, 3.2, 3.3, and 3.4 are conditions of the licenses granted
+in Section 2.1.
+
+3. Responsibilities
+-------------------
+
+3.1. Distribution of Source Form
+
+All distribution of Covered Software in Source Code Form, including any
+Modifications that You create or to which You contribute, must be under
+the terms of this License. You must inform recipients that the Source
+Code Form of the Covered Software is governed by the terms of this
+License, and how they can obtain a copy of this License. You may not
+attempt to alter or restrict the recipients' rights in the Source Code
+Form.
+
+3.2. Distribution of Executable Form
+
+If You distribute Covered Software in Executable Form then:
+
+(a) such Covered Software must also be made available in Source Code
+Form, as described in Section 3.1, and You must inform recipients of
+the Executable Form how they can obtain a copy of such Source Code
+Form by reasonable means in a timely manner, at a charge no more
+than the cost of distribution to the recipient; and
+
+(b) You may distribute such Executable Form under the terms of this
+License, or sublicense it under different terms, provided that the
+license for the Executable Form does not attempt to limit or alter
+the recipients' rights in the Source Code Form under this License.
+
+3.3. Distribution of a Larger Work
+
+You may create and distribute a Larger Work under terms of Your choice,
+provided that You also comply with the requirements of this License for
+the Covered Software. If the Larger Work is a combination of Covered
+Software with a work governed by one or more Secondary Licenses, and the
+Covered Software is not Incompatible With Secondary Licenses, this
+License permits You to additionally distribute such Covered Software
+under the terms of such Secondary License(s), so that the recipient of
+the Larger Work may, at their option, further distribute the Covered
+Software under the terms of either this License or such Secondary
+License(s).
+
+3.4. Notices
+
+You may not remove or alter the substance of any license notices
+(including copyright notices, patent notices, disclaimers of warranty,
+or limitations of liability) contained within the Source Code Form of
+the Covered Software, except that You may alter any license notices to
+the extent required to remedy known factual inaccuracies.
+
+3.5. Application of Additional Terms
+
+You may choose to offer, and to charge a fee for, warranty, support,
+indemnity or liability obligations to one or more recipients of Covered
+Software. However, You may do so only on Your own behalf, and not on
+behalf of any Contributor. You must make it absolutely clear that any
+such warranty, support, indemnity, or liability obligation is offered by
+You alone, and You hereby agree to indemnify every Contributor for any
+liability incurred by such Contributor as a result of warranty, support,
+indemnity or liability terms You offer. You may include additional
+disclaimers of warranty and limitations of liability specific to any
+jurisdiction.
+
+4. Inability to Comply Due to Statute or Regulation
+---------------------------------------------------
+
+If it is impossible for You to comply with any of the terms of this
+License with respect to some or all of the Covered Software due to
+statute, judicial order, or regulation then You must: (a) comply with
+the terms of this License to the maximum extent possible; and (b)
+describe the limitations and the code they affect. Such description must
+be placed in a text file included with all distributions of the Covered
+Software under this License. Except to the extent prohibited by statute
+or regulation, such description must be sufficiently detailed for a
+recipient of ordinary skill to be able to understand it.
+
+5. Termination
+--------------
+
+5.1. The rights granted under this License will terminate automatically
+if You fail to comply with any of its terms. However, if You become
+compliant, then the rights granted under this License from a particular
+Contributor are reinstated (a) provisionally, unless and until such
+Contributor explicitly and finally terminates Your grants, and (b) on an
+ongoing basis, if such Contributor fails to notify You of the
+non-compliance by some reasonable means prior to 60 days after You have
+come back into compliance. Moreover, Your grants from a particular
+Contributor are reinstated on an ongoing basis if such Contributor
+notifies You of the non-compliance by some reasonable means, this is the
+first time You have received notice of non-compliance with this License
+from such Contributor, and You become compliant prior to 30 days after
+Your receipt of the notice.
+
+5.2. If You initiate litigation against any entity by asserting a patent
+infringement claim (excluding declaratory judgment actions,
+counter-claims, and cross-claims) alleging that a Contributor Version
+directly or indirectly infringes any patent, then the rights granted to
+You by any and all Contributors for the Covered Software under Section
+2.1 of this License shall terminate.
+
+5.3. In the event of termination under Sections 5.1 or 5.2 above, all
+end user license agreements (excluding distributors and resellers) which
+have been validly granted by You or Your distributors under this License
+prior to termination shall survive termination.
+
+************************************************************************
+* *
+* 6. Disclaimer of Warranty *
+* ------------------------- *
+* *
+* Covered Software is provided under this License on an "as is" *
+* basis, without warranty of any kind, either expressed, implied, or *
+* statutory, including, without limitation, warranties that the *
+* Covered Software is free of defects, merchantable, fit for a *
+* particular purpose or non-infringing. The entire risk as to the *
+* quality and performance of the Covered Software is with You. *
+* Should any Covered Software prove defective in any respect, You *
+* (not any Contributor) assume the cost of any necessary servicing, *
+* repair, or correction. This disclaimer of warranty constitutes an *
+* essential part of this License. No use of any Covered Software is *
+* authorized under this License except under this disclaimer. *
+* *
+************************************************************************
+
+************************************************************************
+* *
+* 7. Limitation of Liability *
+* -------------------------- *
+* *
+* Under no circumstances and under no legal theory, whether tort *
+* (including negligence), contract, or otherwise, shall any *
+* Contributor, or anyone who distributes Covered Software as *
+* permitted above, be liable to You for any direct, indirect, *
+* special, incidental, or consequential damages of any character *
+* including, without limitation, damages for lost profits, loss of *
+* goodwill, work stoppage, computer failure or malfunction, or any *
+* and all other commercial damages or losses, even if such party *
+* shall have been informed of the possibility of such damages. This *
+* limitation of liability shall not apply to liability for death or *
+* personal injury resulting from such party's negligence to the *
+* extent applicable law prohibits such limitation. Some *
+* jurisdictions do not allow the exclusion or limitation of *
+* incidental or consequential damages, so this exclusion and *
+* limitation may not apply to You. *
+* *
+************************************************************************
+
+8. Litigation
+-------------
+
+Any litigation relating to this License may be brought only in the
+courts of a jurisdiction where the defendant maintains its principal
+place of business and such litigation shall be governed by laws of that
+jurisdiction, without reference to its conflict-of-law provisions.
+Nothing in this Section shall prevent a party's ability to bring
+cross-claims or counter-claims.
+
+9. Miscellaneous
+----------------
+
+This License represents the complete agreement concerning the subject
+matter hereof. If any provision of this License is held to be
+unenforceable, such provision shall be reformed only to the extent
+necessary to make it enforceable. Any law or regulation which provides
+that the language of a contract shall be construed against the drafter
+shall not be used to construe this License against a Contributor.
+
+10. Versions of the License
+---------------------------
+
+10.1. New Versions
+
+Mozilla Foundation is the license steward. Except as provided in Section
+10.3, no one other than the license steward has the right to modify or
+publish new versions of this License. Each version will be given a
+distinguishing version number.
+
+10.2. Effect of New Versions
+
+You may distribute the Covered Software under the terms of the version
+of the License under which You originally received the Covered Software,
+or under the terms of any subsequent version published by the license
+steward.
+
+10.3. Modified Versions
+
+If you create software not governed by this License, and you want to
+create a new license for such software, you may create and use a
+modified version of this License if you rename the license and remove
+any references to the name of the license steward (except to note that
+such modified license differs from this License).
+
+10.4. Distributing Source Code Form that is Incompatible With Secondary
+Licenses
+
+If You choose to distribute Source Code Form that is Incompatible With
+Secondary Licenses under the terms of this version of the License, the
+notice described in Exhibit B of this License must be attached.
+
+Exhibit A - Source Code Form License Notice
+-------------------------------------------
+
+This Source Code Form is subject to the terms of the Mozilla Public
+License, v. 2.0. If a copy of the MPL was not distributed with this
+file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+If it is not possible or desirable to put the notice in a particular
+file, then You may include the notice in a location (such as a LICENSE
+file in a relevant directory) where a recipient would be likely to look
+for such a notice.
+
+You may add additional accurate notices of copyright ownership.
+
+Exhibit B - "Incompatible With Secondary Licenses" Notice
+---------------------------------------------------------
+
+This Source Code Form is "Incompatible With Secondary Licenses", as
+defined by the Mozilla Public License, v. 2.0.
diff --git a/third_party/rust/uluru/README.md b/third_party/rust/uluru/README.md
new file mode 100644
index 0000000000..82244786e5
--- /dev/null
+++ b/third_party/rust/uluru/README.md
@@ -0,0 +1,12 @@
+# uluru
+
+A simple, fast, least-recently-used (LRU) cache implementation used for
+Servo's style system.
+
+`LRUCache` uses a fixed-capacity array for storage. It provides `O(1)`
+insertion, and `O(n)` lookup. It does not require an allocator and can be
+used in `no_std` crates. It is implemented in 100% safe Rust.
+
+* [Documentation](https://docs.rs/uluru)
+* [crates.io](https://crates.io/crates/uluru)
+* [Release notes](https://github.com/servo/uluru/releases)
diff --git a/third_party/rust/uluru/src/lib.rs b/third_party/rust/uluru/src/lib.rs
new file mode 100644
index 0000000000..0c410509c1
--- /dev/null
+++ b/third_party/rust/uluru/src/lib.rs
@@ -0,0 +1,341 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#![no_std]
+#![deny(unsafe_code)]
+
+//! A simple, fast, least-recently-used (LRU) cache.
+//!
+//! [`LRUCache`] uses a fixed-capacity array for storage. It provides `O(1)` insertion, and `O(n)`
+//! lookup. It does not require an allocator and can be used in `no_std` crates.
+//!
+//! See the [`LRUCache`](LRUCache) docs for details.
+
+use arrayvec::ArrayVec;
+use core::{fmt, mem::replace};
+
+#[cfg(test)]
+mod tests;
+
+/// A LRU cache using a statically-sized array for storage.
+///
+/// `LRUCache` uses a fixed-capacity array for storage. It provides `O(1)` insertion, and `O(n)`
+/// lookup.
+///
+/// All items are stored inline within the `LRUCache`, so it does not impose any heap allocation or
+/// indirection. A linked list is used to record the cache order, so the items themselves do not
+/// need to be moved when the order changes. (This is important for speed if the items are large.)
+///
+/// # Example
+///
+/// ```
+/// use uluru::LRUCache;
+///
+/// struct MyValue {
+/// id: u32,
+/// name: &'static str,
+/// }
+///
+/// // A cache with a capacity of three.
+/// type MyCache = LRUCache<MyValue, 3>;
+///
+/// // Create an empty cache, then insert some items.
+/// let mut cache = MyCache::default();
+/// cache.insert(MyValue { id: 1, name: "Mercury" });
+/// cache.insert(MyValue { id: 2, name: "Venus" });
+/// cache.insert(MyValue { id: 3, name: "Earth" });
+///
+/// // Use the `find` method to retrieve an item from the cache.
+/// // This also "touches" the item, marking it most-recently-used.
+/// let item = cache.find(|x| x.id == 1);
+/// assert_eq!(item.unwrap().name, "Mercury");
+///
+/// // If the cache is full, inserting a new item evicts the least-recently-used item:
+/// cache.insert(MyValue { id: 4, name: "Mars" });
+/// assert!(cache.find(|x| x.id == 2).is_none());
+/// ```
+pub struct LRUCache<T, const N: usize> {
+ /// The most-recently-used entry is at index `head`. The entries form a linked list, linked to
+ /// each other by indices within the `entries` array. After an entry is added to the array,
+ /// its index never changes, so these links are never invalidated.
+ entries: ArrayVec<Entry<T>, N>,
+ /// Index of the first entry. If the cache is empty, ignore this field.
+ head: u16,
+ /// Index of the last entry. If the cache is empty, ignore this field.
+ tail: u16,
+}
+
+/// An entry in an `LRUCache`.
+#[derive(Debug, Clone)]
+struct Entry<T> {
+ val: T,
+ /// Index of the previous entry. If this entry is the head, ignore this field.
+ prev: u16,
+ /// Index of the next entry. If this entry is the tail, ignore this field.
+ next: u16,
+}
+
+impl<T, const N: usize> Default for LRUCache<T, N> {
+ fn default() -> Self {
+ let cache = LRUCache {
+ entries: ArrayVec::new(),
+ head: 0,
+ tail: 0,
+ };
+ assert!(
+ cache.entries.capacity() < u16::max_value() as usize,
+ "Capacity overflow"
+ );
+ cache
+ }
+}
+
+impl<T, const N: usize> LRUCache<T, N> {
+ /// Insert a given key in the cache.
+ ///
+ /// This item becomes the front (most-recently-used) item in the cache. If the cache is full,
+ /// the back (least-recently-used) item will be removed and returned.
+ pub fn insert(&mut self, val: T) -> Option<T> {
+ let entry = Entry {
+ val,
+ prev: 0,
+ next: 0,
+ };
+
+ // If the cache is full, replace the oldest entry. Otherwise, add an entry.
+ let (new_head, previous_entry) = if self.entries.len() == self.entries.capacity() {
+ let i = self.pop_back();
+ let previous_entry = replace(&mut self.entries[i as usize], entry);
+ (i, Some(previous_entry.val))
+ } else {
+ self.entries.push(entry);
+ (self.entries.len() as u16 - 1, None)
+ };
+
+ self.push_front(new_head);
+ previous_entry
+ }
+
+ /// Returns the first item in the cache that matches the given predicate.
+ /// Touches the result (makes it most-recently-used) on a hit.
+ pub fn find<F>(&mut self, pred: F) -> Option<&mut T>
+ where
+ F: FnMut(&T) -> bool,
+ {
+ if self.touch(pred) {
+ self.front_mut()
+ } else {
+ None
+ }
+ }
+
+ /// Performs a lookup on the cache with the given test routine. Touches
+ /// the result on a hit.
+ pub fn lookup<F, R>(&mut self, mut test_one: F) -> Option<R>
+ where
+ F: FnMut(&mut T) -> Option<R>,
+ {
+ let mut result = None;
+ let mut iter = self.iter_mut();
+ while let Some((i, val)) = iter.next() {
+ if let Some(r) = test_one(val) {
+ result = Some((i, r));
+ break;
+ }
+ }
+
+ match result {
+ None => None,
+ Some((i, r)) => {
+ self.touch_index(i);
+ Some(r)
+ }
+ }
+ }
+
+ /// Returns the number of elements in the cache.
+ #[inline]
+ pub fn len(&self) -> usize {
+ self.entries.len()
+ }
+
+ /// Returns true if the cache is empty.
+ #[inline]
+ pub fn is_empty(&self) -> bool {
+ self.entries.is_empty()
+ }
+
+ /// Evict all elements from the cache.
+ #[inline]
+ pub fn clear(&mut self) {
+ self.entries.clear();
+ }
+
+ /// Returns the front entry in the list (most recently used).
+ pub fn front(&self) -> Option<&T> {
+ self.entries.get(self.head as usize).map(|e| &e.val)
+ }
+
+ /// Returns a mutable reference to the front entry in the list (most recently used).
+ pub fn front_mut(&mut self) -> Option<&mut T> {
+ self.entries.get_mut(self.head as usize).map(|e| &mut e.val)
+ }
+
+ /// Returns the n-th entry in the list (most recently used).
+ pub fn get(&self, index: usize) -> Option<&T> {
+ self.iter().nth(index)
+ }
+
+ /// Touches the first item in the cache that matches the given predicate (marks it as
+ /// most-recently-used).
+ /// Returns `true` on a hit, `false` if no matches.
+ pub fn touch<F>(&mut self, mut pred: F) -> bool
+ where
+ F: FnMut(&T) -> bool,
+ {
+ let mut iter = self.iter_mut();
+ while let Some((i, val)) = iter.next() {
+ if pred(val) {
+ self.touch_index(i);
+ return true;
+ }
+ }
+ false
+ }
+
+ /// Iterate over the contents of this cache in order from most-recently-used to
+ /// least-recently-used.
+ pub fn iter(&self) -> Iter<'_, T, N> {
+ Iter {
+ pos: self.head,
+ cache: self,
+ }
+ }
+
+ /// Iterate mutably over the contents of this cache in order from most-recently-used to
+ /// least-recently-used.
+ fn iter_mut(&mut self) -> IterMut<'_, T, N> {
+ IterMut {
+ pos: self.head,
+ cache: self,
+ }
+ }
+
+ /// Touch a given entry, putting it first in the list.
+ #[inline]
+ fn touch_index(&mut self, idx: u16) {
+ if idx != self.head {
+ self.remove(idx);
+ self.push_front(idx);
+ }
+ }
+
+ /// Remove an entry from the linked list.
+ ///
+ /// Note: This only unlinks the entry from the list; it does not remove it from the array.
+ fn remove(&mut self, i: u16) {
+ let prev = self.entries[i as usize].prev;
+ let next = self.entries[i as usize].next;
+
+ if i == self.head {
+ self.head = next;
+ } else {
+ self.entries[prev as usize].next = next;
+ }
+
+ if i == self.tail {
+ self.tail = prev;
+ } else {
+ self.entries[next as usize].prev = prev;
+ }
+ }
+
+ /// Insert a new entry at the head of the list.
+ fn push_front(&mut self, i: u16) {
+ if self.entries.len() == 1 {
+ self.tail = i;
+ } else {
+ self.entries[i as usize].next = self.head;
+ self.entries[self.head as usize].prev = i;
+ }
+ self.head = i;
+ }
+
+ /// Remove the last entry from the linked list. Returns the index of the removed entry.
+ ///
+ /// Note: This only unlinks the entry from the list; it does not remove it from the array.
+ fn pop_back(&mut self) -> u16 {
+ let old_tail = self.tail;
+ let new_tail = self.entries[old_tail as usize].prev;
+ self.tail = new_tail;
+ old_tail
+ }
+}
+
+impl<T, const N: usize> Clone for LRUCache<T, N>
+where
+ T: Clone,
+{
+ fn clone(&self) -> Self {
+ Self {
+ entries: self.entries.clone(),
+ head: self.head,
+ tail: self.tail,
+ }
+ }
+}
+
+impl<T, const N: usize> fmt::Debug for LRUCache<T, N>
+where
+ T: fmt::Debug,
+{
+ fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
+ f.debug_struct("LRUCache")
+ .field("head", &self.head)
+ .field("tail", &self.tail)
+ .field("entries", &self.entries)
+ .finish()
+ }
+}
+
+/// Mutable iterator over values in an `LRUCache`, from most-recently-used to least-recently-used.
+struct IterMut<'a, T, const N: usize> {
+ cache: &'a mut LRUCache<T, N>,
+ pos: u16,
+}
+
+impl<'a, T, const N: usize> IterMut<'a, T, N> {
+ fn next(&mut self) -> Option<(u16, &mut T)> {
+ let index = self.pos;
+ let entry = self.cache.entries.get_mut(index as usize)?;
+
+ self.pos = if index == self.cache.tail {
+ N as u16 // Point past the end of the array to signal we are done.
+ } else {
+ entry.next
+ };
+ Some((index, &mut entry.val))
+ }
+}
+
+/// Iterator over values in an [`LRUCache`], from most-recently-used to least-recently-used.
+pub struct Iter<'a, T, const N: usize> {
+ cache: &'a LRUCache<T, N>,
+ pos: u16,
+}
+
+impl<'a, T, const N: usize> Iterator for Iter<'a, T, N> {
+ type Item = &'a T;
+
+ fn next(&mut self) -> Option<&'a T> {
+ let entry = self.cache.entries.get(self.pos as usize)?;
+
+ self.pos = if self.pos == self.cache.tail {
+ N as u16 // Point past the end of the array to signal we are done.
+ } else {
+ entry.next
+ };
+ Some(&entry.val)
+ }
+}
diff --git a/third_party/rust/uluru/src/tests.rs b/third_party/rust/uluru/src/tests.rs
new file mode 100644
index 0000000000..978e129449
--- /dev/null
+++ b/third_party/rust/uluru/src/tests.rs
@@ -0,0 +1,216 @@
+extern crate std;
+
+use self::std::vec::Vec;
+use super::*;
+
+type TestCache = LRUCache<i32, 4>;
+
+/// Convenience function for test assertions
+fn items<T, const N: usize>(cache: &mut LRUCache<T, N>) -> Vec<T>
+where
+ T: Clone,
+{
+ let mut v = Vec::new();
+ let mut iter = cache.iter_mut();
+ while let Some((_idx, val)) = iter.next() {
+ v.push(val.clone())
+ }
+ v
+}
+
+#[test]
+fn empty() {
+ let mut cache = TestCache::default();
+ assert_eq!(cache.is_empty(), true);
+ assert_eq!(items(&mut cache), []);
+ cache.insert(1);
+ assert_eq!(cache.is_empty(), false);
+}
+
+#[test]
+fn len() {
+ let mut cache = TestCache::default();
+ cache.insert(1);
+ assert_eq!(cache.len(), 1);
+ assert_eq!(items(&mut cache), [1]);
+}
+
+#[test]
+fn insert() {
+ let mut cache = TestCache::default();
+ cache.insert(1);
+ assert_eq!(cache.len(), 1);
+ cache.insert(2);
+ assert_eq!(cache.len(), 2);
+ cache.insert(3);
+ assert_eq!(cache.len(), 3);
+ cache.insert(4);
+ assert_eq!(cache.len(), 4);
+ assert_eq!(
+ items(&mut cache),
+ [4, 3, 2, 1],
+ "Ordered from most- to least-recent."
+ );
+
+ cache.insert(5);
+ assert_eq!(cache.len(), 4);
+ assert_eq!(
+ items(&mut cache),
+ [5, 4, 3, 2],
+ "Least-recently-used item evicted."
+ );
+
+ cache.insert(6);
+ cache.insert(7);
+ cache.insert(8);
+ cache.insert(9);
+ assert_eq!(
+ items(&mut cache),
+ [9, 8, 7, 6],
+ "Least-recently-used item evicted."
+ );
+}
+
+#[test]
+fn lookup() {
+ let mut cache = TestCache::default();
+ cache.insert(1);
+ cache.insert(2);
+ cache.insert(3);
+ cache.insert(4);
+
+ let result = cache.lookup(|x| if *x == 5 { Some(()) } else { None });
+ assert_eq!(result, None, "Cache miss.");
+ assert_eq!(items(&mut cache), [4, 3, 2, 1], "Order not changed.");
+
+ // Cache hit
+ let result = cache.lookup(|x| if *x == 3 { Some(*x * 2) } else { None });
+ assert_eq!(result, Some(6), "Cache hit.");
+ assert_eq!(
+ items(&mut cache),
+ [3, 4, 2, 1],
+ "Matching item moved to front."
+ );
+}
+
+#[test]
+fn clear() {
+ let mut cache = TestCache::default();
+ cache.insert(1);
+ cache.clear();
+ assert_eq!(items(&mut cache), [], "all items evicted");
+
+ cache.insert(1);
+ cache.insert(2);
+ cache.insert(3);
+ cache.insert(4);
+ assert_eq!(items(&mut cache), [4, 3, 2, 1]);
+ cache.clear();
+ assert_eq!(items(&mut cache), [], "all items evicted again");
+}
+
+#[test]
+fn touch() {
+ let mut cache = TestCache::default();
+
+ cache.insert(0);
+ cache.insert(1);
+ cache.insert(2);
+ cache.insert(3);
+
+ cache.touch(|x| *x == 5);
+
+ assert_eq!(items(&mut cache), [3, 2, 1, 0], "Nothing is touched.");
+
+ cache.touch(|x| *x == 1);
+
+ assert_eq!(
+ items(&mut cache),
+ [1, 3, 2, 0],
+ "Touched item is moved to front."
+ );
+}
+
+#[test]
+fn find() {
+ let mut cache = TestCache::default();
+
+ cache.insert(0);
+ cache.insert(1);
+ cache.insert(2);
+ cache.insert(3);
+
+ let result = cache.find(|x| *x == 5).copied();
+
+ assert_eq!(result, None);
+ assert_eq!(items(&mut cache), [3, 2, 1, 0], "Nothing is touched.");
+
+ let result = cache.find(|x| *x == 1).copied();
+
+ assert_eq!(result, Some(1));
+ assert_eq!(
+ items(&mut cache),
+ [1, 3, 2, 0],
+ "Retrieved item is moved to front."
+ );
+}
+
+#[test]
+fn front() {
+ let mut cache = TestCache::default();
+
+ assert_eq!(cache.front(), None, "Nothing is in the front.");
+
+ cache.insert(0);
+ cache.insert(1);
+
+ assert_eq!(
+ cache.front(),
+ Some(&1),
+ "The last inserted item should be in the front."
+ );
+
+ cache.touch(|x| *x == 0);
+
+ assert_eq!(
+ cache.front(),
+ Some(&0),
+ "Touched item should be in the front."
+ );
+}
+
+#[test]
+fn get() {
+ let mut cache = TestCache::default();
+
+ assert_eq!(cache.get(0), None, "Nothing at index 0.");
+
+ cache.insert(42);
+ cache.insert(64);
+
+ assert_eq!(
+ cache.get(0),
+ Some(&64),
+ "The last inserted item should be at index 0."
+ );
+
+ assert_eq!(
+ cache.get(1),
+ Some(&42),
+ "The first inserted item should be at index 1."
+ );
+
+ cache.touch(|x| *x == 42);
+
+ assert_eq!(
+ cache.get(0),
+ Some(&42),
+ "The last touched item should be at index 0."
+ );
+
+ assert_eq!(
+ cache.get(1),
+ Some(&64),
+ "The previously front item should be at index 1."
+ );
+}