summaryrefslogtreecommitdiffstats
path: root/third_party/rust/uniffi-example-sprites
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
commit8dd16259287f58f9273002717ec4d27e97127719 (patch)
tree3863e62a53829a84037444beab3abd4ed9dfc7d0 /third_party/rust/uniffi-example-sprites
parentReleasing progress-linux version 126.0.1-1~progress7.99u1. (diff)
downloadfirefox-8dd16259287f58f9273002717ec4d27e97127719.tar.xz
firefox-8dd16259287f58f9273002717ec4d27e97127719.zip
Merging upstream version 127.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/uniffi-example-sprites')
-rw-r--r--third_party/rust/uniffi-example-sprites/.cargo-checksum.json1
-rw-r--r--third_party/rust/uniffi-example-sprites/Cargo.toml39
-rw-r--r--third_party/rust/uniffi-example-sprites/build.rs7
-rw-r--r--third_party/rust/uniffi-example-sprites/src/lib.rs65
-rw-r--r--third_party/rust/uniffi-example-sprites/src/sprites.udl22
-rw-r--r--third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.kts25
-rw-r--r--third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.py17
-rw-r--r--third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.rb22
-rw-r--r--third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.swift16
-rw-r--r--third_party/rust/uniffi-example-sprites/tests/test_generated_bindings.rs6
10 files changed, 0 insertions, 220 deletions
diff --git a/third_party/rust/uniffi-example-sprites/.cargo-checksum.json b/third_party/rust/uniffi-example-sprites/.cargo-checksum.json
deleted file mode 100644
index 8a890fb65c..0000000000
--- a/third_party/rust/uniffi-example-sprites/.cargo-checksum.json
+++ /dev/null
@@ -1 +0,0 @@
-{"files":{"Cargo.toml":"94385b28fdc7e33b7019fada486124c027d29b3d2b11b57e8d488658386f7974","build.rs":"7e9d92d7c8fc17b359a29117b137ffc4d32f6c10b450d03e30a396339d8c9099","src/lib.rs":"d7984c0c10011b1bd939bce71dae7437ebb9090583b5d1b1cc133c2e5f60ab66","src/sprites.udl":"bfd35f04ba0549301189dfb8fc45b0f39bad00956c324f33be0e845fb7ff78aa","tests/bindings/test_sprites.kts":"06ed115325f37ce59ed6f33e2d651cd2aa352fddcc644580f62a6da6ca075844","tests/bindings/test_sprites.py":"f976f2be7ab8b88e8b84def760a849c0d98f4c7b481f054f92b566325d78d52d","tests/bindings/test_sprites.rb":"009d545bb7167b7218211430cfaeeb143cc30617eedcf3e51baafe752ad43241","tests/bindings/test_sprites.swift":"b2c0a6f4d5edfd7de7c2ba77b838865ffda153a6f364f273456175192d3e6e00","tests/test_generated_bindings.rs":"9a22d693c97fc6d90031cc60f61ece1d9279165ad6a92c9fe937448e126e8de6"},"package":null} \ No newline at end of file
diff --git a/third_party/rust/uniffi-example-sprites/Cargo.toml b/third_party/rust/uniffi-example-sprites/Cargo.toml
deleted file mode 100644
index c6dc9d1f4b..0000000000
--- a/third_party/rust/uniffi-example-sprites/Cargo.toml
+++ /dev/null
@@ -1,39 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2021"
-name = "uniffi-example-sprites"
-version = "0.22.0"
-authors = ["Firefox Sync Team <sync-team@mozilla.com>"]
-publish = false
-license = "MPL-2.0"
-
-[lib]
-name = "uniffi_sprites"
-crate-type = [
- "lib",
- "cdylib",
-]
-
-[dependencies.uniffi]
-version = "0.27"
-path = "../../uniffi"
-
-[dev-dependencies.uniffi]
-version = "0.27"
-path = "../../uniffi"
-features = ["bindgen-tests"]
-
-[build-dependencies.uniffi]
-version = "0.27"
-path = "../../uniffi"
-features = ["build"]
diff --git a/third_party/rust/uniffi-example-sprites/build.rs b/third_party/rust/uniffi-example-sprites/build.rs
deleted file mode 100644
index 26ac3085b8..0000000000
--- a/third_party/rust/uniffi-example-sprites/build.rs
+++ /dev/null
@@ -1,7 +0,0 @@
-/* This Source Code Form is subject to the terms of the Mozilla Public
- * License, v. 2.0. If a copy of the MPL was not distributed with this
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
-
-fn main() {
- uniffi::generate_scaffolding("src/sprites.udl").unwrap();
-}
diff --git a/third_party/rust/uniffi-example-sprites/src/lib.rs b/third_party/rust/uniffi-example-sprites/src/lib.rs
deleted file mode 100644
index d3cc11e408..0000000000
--- a/third_party/rust/uniffi-example-sprites/src/lib.rs
+++ /dev/null
@@ -1,65 +0,0 @@
-/* This Source Code Form is subject to the terms of the Mozilla Public
- * License, v. 2.0. If a copy of the MPL was not distributed with this
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
-
-use std::sync::RwLock;
-
-// A point in two-dimensional space.
-#[derive(Debug, Clone)]
-pub struct Point {
- x: f64,
- y: f64,
-}
-
-// A magnitude and direction in two-dimensional space.
-// For simplicity we represent this as a point relative to the origin.
-#[derive(Debug, Clone)]
-pub struct Vector {
- dx: f64,
- dy: f64,
-}
-
-// Move from the given Point, according to the given Vector.
-pub fn translate(p: &Point, v: Vector) -> Point {
- Point {
- x: p.x + v.dx,
- y: p.y + v.dy,
- }
-}
-
-// An entity in our imaginary world, which occupies a position in space
-// and which can move about over time.
-#[derive(Debug)]
-pub struct Sprite {
- // We must use interior mutability for managing mutable state, hence the `RwLock`.
- current_position: RwLock<Point>,
-}
-
-impl Sprite {
- fn new(initial_position: Option<Point>) -> Sprite {
- Sprite {
- current_position: RwLock::new(initial_position.unwrap_or(Point { x: 0.0, y: 0.0 })),
- }
- }
-
- fn new_relative_to(reference: Point, direction: Vector) -> Sprite {
- Sprite {
- current_position: RwLock::new(translate(&reference, direction)),
- }
- }
-
- fn get_position(&self) -> Point {
- self.current_position.read().unwrap().clone()
- }
-
- fn move_to(&self, position: Point) {
- *self.current_position.write().unwrap() = position;
- }
-
- fn move_by(&self, direction: Vector) {
- let mut current_position = self.current_position.write().unwrap();
- *current_position = translate(&current_position, direction)
- }
-}
-
-uniffi::include_scaffolding!("sprites");
diff --git a/third_party/rust/uniffi-example-sprites/src/sprites.udl b/third_party/rust/uniffi-example-sprites/src/sprites.udl
deleted file mode 100644
index 6781c6cee5..0000000000
--- a/third_party/rust/uniffi-example-sprites/src/sprites.udl
+++ /dev/null
@@ -1,22 +0,0 @@
-
-namespace sprites {
- Point translate([ByRef] Point position, Vector direction);
-};
-
-dictionary Point {
- double x;
- double y;
-};
-
-dictionary Vector {
- double dx;
- double dy;
-};
-
-interface Sprite {
- constructor(Point? initial_position);
- [Name=new_relative_to] constructor(Point reference, Vector direction);
- Point get_position();
- void move_to(Point position);
- void move_by(Vector direction);
-};
diff --git a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.kts b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.kts
deleted file mode 100644
index 42451f28dd..0000000000
--- a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.kts
+++ /dev/null
@@ -1,25 +0,0 @@
-import uniffi.sprites.*;
-
-val sempty = Sprite(null)
-assert( sempty.getPosition() == Point(0.0, 0.0) )
-
-val s = Sprite(Point(0.0, 1.0))
-assert( s.getPosition() == Point(0.0, 1.0) )
-
-s.moveTo(Point(1.0, 2.0))
-assert( s.getPosition() == Point(1.0, 2.0) )
-
-s.moveBy(Vector(-4.0, 2.0))
-assert( s.getPosition() == Point(-3.0, 4.0) )
-
-s.destroy()
-try {
- s.moveBy(Vector(0.0, 0.0))
- assert(false) { "Should not be able to call anything after `destroy`" }
-} catch(e: IllegalStateException) {
- assert(true)
-}
-
-val srel = Sprite.newRelativeTo(Point(0.0, 1.0), Vector(1.0, 1.5))
-assert( srel.getPosition() == Point(1.0, 2.5) )
-
diff --git a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.py b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.py
deleted file mode 100644
index d04742e076..0000000000
--- a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.py
+++ /dev/null
@@ -1,17 +0,0 @@
-from sprites import *
-
-sempty = Sprite(None)
-assert sempty.get_position() == Point(x=0, y=0)
-
-s = Sprite(Point(x=0, y=1))
-assert s.get_position() == Point(x=0, y=1)
-
-s.move_to(Point(x=1, y=2))
-assert s.get_position() == Point(x=1, y=2)
-
-s.move_by(Vector(dx=-4, dy=2))
-assert s.get_position() == Point(x=-3, y=4)
-
-srel = Sprite.new_relative_to(Point(x=0, y=1), Vector(dx=1, dy=1.5))
-assert srel.get_position() == Point(x=1, y=2.5)
-
diff --git a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.rb b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.rb
deleted file mode 100644
index fa73043979..0000000000
--- a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.rb
+++ /dev/null
@@ -1,22 +0,0 @@
-# frozen_string_literal: true
-
-require 'test/unit'
-require 'sprites'
-
-include Test::Unit::Assertions
-include Sprites
-
-sempty = Sprite.new(nil)
-assert_equal sempty.get_position, Point.new(x: 0, y: 0)
-
-s = Sprite.new(Point.new(x: 0, y: 1))
-assert_equal s.get_position, Point.new(x: 0, y: 1)
-
-s.move_to(Point.new(x: 1, y: 2))
-assert_equal s.get_position, Point.new(x: 1, y: 2)
-
-s.move_by(Vector.new(dx: -4, dy: 2))
-assert_equal s.get_position, Point.new(x: -3, y: 4)
-
-srel = Sprite.new_relative_to(Point.new(x: 0, y: 1), Vector.new(dx: 1, dy: 1.5))
-assert_equal srel.get_position, Point.new(x: 1, y: 2.5)
diff --git a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.swift b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.swift
deleted file mode 100644
index d5428ac679..0000000000
--- a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.swift
+++ /dev/null
@@ -1,16 +0,0 @@
-import sprites
-
-let sempty = Sprite(initialPosition: nil)
-assert( sempty.getPosition() == Point(x: 0, y: 0))
-
-let s = Sprite(initialPosition: Point(x: 0, y: 1))
-assert( s.getPosition() == Point(x: 0, y: 1))
-
-s.moveTo(position: Point(x: 1.0, y: 2.0))
-assert( s.getPosition() == Point(x: 1, y: 2))
-
-s.moveBy(direction: Vector(dx: -4, dy: 2))
-assert( s.getPosition() == Point(x: -3, y: 4))
-
-let srel = Sprite.newRelativeTo(reference: Point(x: 0.0, y: 1.0), direction: Vector(dx: 1, dy: 1.5))
-assert( srel.getPosition() == Point(x: 1.0, y: 2.5) )
diff --git a/third_party/rust/uniffi-example-sprites/tests/test_generated_bindings.rs b/third_party/rust/uniffi-example-sprites/tests/test_generated_bindings.rs
deleted file mode 100644
index 00dd779d68..0000000000
--- a/third_party/rust/uniffi-example-sprites/tests/test_generated_bindings.rs
+++ /dev/null
@@ -1,6 +0,0 @@
-uniffi::build_foreign_language_testcases!(
- "tests/bindings/test_sprites.py",
- "tests/bindings/test_sprites.rb",
- "tests/bindings/test_sprites.kts",
- "tests/bindings/test_sprites.swift",
-);