summaryrefslogtreecommitdiffstats
path: root/third_party/rust/void/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/void/README.md
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/void/README.md')
-rw-r--r--third_party/rust/void/README.md39
1 files changed, 39 insertions, 0 deletions
diff --git a/third_party/rust/void/README.md b/third_party/rust/void/README.md
new file mode 100644
index 0000000000..4f86c21cca
--- /dev/null
+++ b/third_party/rust/void/README.md
@@ -0,0 +1,39 @@
+# Void
+
+> The uninhabited void type for use in statically impossible cases.
+
+## [Documentation](https://crates.fyi/crates/void/1.0.1)
+
+The uninhabited type, `enum Void { }` is useful in dealing with cases you
+know to be impossible. For instance, if you are implementing a trait which
+allows for error checking, but your case always succeeds, you can mark the
+error case or type as `Void`, signaling to the compiler it can never happen.
+
+This crate also comes packed with a few traits offering extension methods to
+`Result<T, Void>` and `Result<Void, T>`.
+
+## Usage
+
+Use the crates.io repository; add this to your `Cargo.toml` along
+with the rest of your dependencies:
+
+```toml
+[dependencies]
+void = "1"
+```
+
+Then, use `Void` in your crate:
+
+```rust
+extern crate void;
+use void::Void;
+```
+
+## Author
+
+[Jonathan Reem](https://medium.com/@jreem) is the primary author and maintainer of void.
+
+## License
+
+MIT
+