summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wasm-smith/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/wasm-smith/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/wasm-smith/Cargo.toml')
-rw-r--r--third_party/rust/wasm-smith/Cargo.toml101
1 files changed, 101 insertions, 0 deletions
diff --git a/third_party/rust/wasm-smith/Cargo.toml b/third_party/rust/wasm-smith/Cargo.toml
new file mode 100644
index 0000000000..bebb2807d5
--- /dev/null
+++ b/third_party/rust/wasm-smith/Cargo.toml
@@ -0,0 +1,101 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "wasm-smith"
+version = "0.15.0"
+authors = ["Nick Fitzgerald <fitzgen@gmail.com>"]
+exclude = ["/benches/corpus"]
+description = "A WebAssembly test case generator"
+documentation = "https://docs.rs/wasm-smith"
+readme = "./README.md"
+categories = [
+ "command-line-utilities",
+ "development-tools",
+ "development-tools::testing",
+ "wasm",
+]
+license = "Apache-2.0 WITH LLVM-exception"
+repository = "https://github.com/bytecodealliance/wasm-tools/tree/main/crates/wasm-smith"
+
+[[bench]]
+name = "corpus"
+harness = false
+
+[dependencies.anyhow]
+version = "1.0.58"
+optional = true
+
+[dependencies.arbitrary]
+version = "1.1.0"
+features = ["derive"]
+
+[dependencies.clap]
+version = "4.0.0"
+features = ["derive"]
+optional = true
+
+[dependencies.flagset]
+version = "0.4"
+
+[dependencies.indexmap]
+version = "2.0.0"
+
+[dependencies.leb128]
+version = "0.2.4"
+
+[dependencies.serde]
+version = "1.0.166"
+optional = true
+
+[dependencies.serde_derive]
+version = "1.0.166"
+optional = true
+
+[dependencies.wasm-encoder]
+version = "0.40.0"
+
+[dependencies.wasmparser]
+version = "0.120.0"
+optional = true
+
+[dependencies.wat]
+version = "1.0.84"
+optional = true
+
+[dev-dependencies.criterion]
+version = "0.3.3"
+
+[dev-dependencies.rand]
+version = "0.8.4"
+features = ["small_rng"]
+
+[dev-dependencies.wasmparser]
+version = "0.120.0"
+
+[features]
+_internal_cli = [
+ "anyhow",
+ "clap",
+ "flagset/serde",
+ "serde",
+ "serde_derive",
+ "wasmparser",
+ "wat",
+]
+wasmparser = [
+ "dep:wasmparser",
+ "wasm-encoder/wasmparser",
+]
+
+[target."cfg(not(target_family = \"wasm\"))".dev-dependencies.libfuzzer-sys]
+version = "0.4.0"