summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wasm-smith/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
commitd8bbc7858622b6d9c278469aab701ca0b609cddf (patch)
treeeff41dc61d9f714852212739e6b3738b82a2af87 /third_party/rust/wasm-smith/Cargo.toml
parentReleasing progress-linux version 125.0.3-1~progress7.99u1. (diff)
downloadfirefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.tar.xz
firefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/wasm-smith/Cargo.toml')
-rw-r--r--third_party/rust/wasm-smith/Cargo.toml18
1 files changed, 11 insertions, 7 deletions
diff --git a/third_party/rust/wasm-smith/Cargo.toml b/third_party/rust/wasm-smith/Cargo.toml
index bebb2807d5..3847409e33 100644
--- a/third_party/rust/wasm-smith/Cargo.toml
+++ b/third_party/rust/wasm-smith/Cargo.toml
@@ -12,7 +12,7 @@
[package]
edition = "2021"
name = "wasm-smith"
-version = "0.15.0"
+version = "0.201.0"
authors = ["Nick Fitzgerald <fitzgen@gmail.com>"]
exclude = ["/benches/corpus"]
description = "A WebAssembly test case generator"
@@ -33,7 +33,6 @@ harness = false
[dependencies.anyhow]
version = "1.0.58"
-optional = true
[dependencies.arbitrary]
version = "1.1.0"
@@ -62,14 +61,14 @@ version = "1.0.166"
optional = true
[dependencies.wasm-encoder]
-version = "0.40.0"
+version = "0.201.0"
[dependencies.wasmparser]
-version = "0.120.0"
+version = "0.201.0"
optional = true
[dependencies.wat]
-version = "1.0.84"
+version = "1.201.0"
optional = true
[dev-dependencies.criterion]
@@ -80,11 +79,10 @@ version = "0.8.4"
features = ["small_rng"]
[dev-dependencies.wasmparser]
-version = "0.120.0"
+version = "0.201.0"
[features]
_internal_cli = [
- "anyhow",
"clap",
"flagset/serde",
"serde",
@@ -99,3 +97,9 @@ wasmparser = [
[target."cfg(not(target_family = \"wasm\"))".dev-dependencies.libfuzzer-sys]
version = "0.4.0"
+
+[lints.clippy]
+all = "allow"
+
+[lints.rust]
+unsafe_code = "deny"