summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wgpu-types/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/wgpu-types/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/wgpu-types/Cargo.toml')
-rw-r--r--third_party/rust/wgpu-types/Cargo.toml68
1 files changed, 68 insertions, 0 deletions
diff --git a/third_party/rust/wgpu-types/Cargo.toml b/third_party/rust/wgpu-types/Cargo.toml
new file mode 100644
index 0000000000..9900e77771
--- /dev/null
+++ b/third_party/rust/wgpu-types/Cargo.toml
@@ -0,0 +1,68 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.70"
+name = "wgpu-types"
+version = "0.19.0"
+authors = ["gfx-rs developers"]
+description = "WebGPU types"
+homepage = "https://wgpu.rs/"
+keywords = ["graphics"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/gfx-rs/wgpu"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+targets = [
+ "x86_64-unknown-linux-gnu",
+ "x86_64-apple-darwin",
+ "x86_64-pc-windows-msvc",
+ "wasm32-unknown-unknown",
+]
+
+[lib]
+
+[dependencies]
+bitflags = "2"
+
+[dependencies.serde]
+version = "1"
+features = ["serde_derive"]
+optional = true
+
+[dev-dependencies]
+serde_json = "1.0.111"
+
+[dev-dependencies.serde]
+version = "1"
+features = ["serde_derive"]
+
+[features]
+fragile-send-sync-non-atomic-wasm = []
+strict_asserts = []
+
+[target."cfg(target_arch = \"wasm32\")".dependencies]
+js-sys = "0.3.67"
+
+[target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
+version = "0.3.67"
+features = [
+ "ImageBitmap",
+ "HtmlVideoElement",
+ "HtmlCanvasElement",
+ "OffscreenCanvas",
+]