summaryrefslogtreecommitdiffstats
path: root/third_party/rust/zeitstempel
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /third_party/rust/zeitstempel
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/zeitstempel')
-rw-r--r--third_party/rust/zeitstempel/.cargo-checksum.json1
-rw-r--r--third_party/rust/zeitstempel/Cargo.lock28
-rw-r--r--third_party/rust/zeitstempel/Cargo.toml30
-rw-r--r--third_party/rust/zeitstempel/LICENSE373
-rw-r--r--third_party/rust/zeitstempel/README.md67
-rw-r--r--third_party/rust/zeitstempel/examples/uptime.rs11
-rw-r--r--third_party/rust/zeitstempel/src/fallback.rs31
-rw-r--r--third_party/rust/zeitstempel/src/lib.rs105
-rw-r--r--third_party/rust/zeitstempel/src/linux.rs24
-rw-r--r--third_party/rust/zeitstempel/src/mac.rs17
-rw-r--r--third_party/rust/zeitstempel/src/win.rs42
11 files changed, 729 insertions, 0 deletions
diff --git a/third_party/rust/zeitstempel/.cargo-checksum.json b/third_party/rust/zeitstempel/.cargo-checksum.json
new file mode 100644
index 0000000000..41ae366eae
--- /dev/null
+++ b/third_party/rust/zeitstempel/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.lock":"f4367cf79db4e2936ed1d29eec5d17e950ad7724cc0922a1aad17adca406f794","Cargo.toml":"4143884533d77a494b311a72570fb5a8ca555899053c11ea39f1412d70c6896c","LICENSE":"1f256ecad192880510e84ad60474eab7589218784b9a50bc7ceee34c2b91f1d5","README.md":"6e72f20c8c1f259138f9dc4a5938c66bb769f8b12b5708f42cc6e5ba504baf56","examples/uptime.rs":"b6653b0da04d3b2c4ccf6dac23aa2233f051238fb85c8610ae9f45a105266430","src/fallback.rs":"4486dc895a7157be0a4c551546bada3c7ee3c3f3afd3007aecab4fe10124b511","src/lib.rs":"8dff762057b0d7bf64cd0aec523541d47c09e073d4297f2407adfaf36513eaee","src/linux.rs":"06197928288889ed6447f90fe1da3b6a3feaaec23690a7380cccb81216fef111","src/mac.rs":"d1cf28b7c7975654494b72ca3f109a2d75826b61ec295aa7512c7c120a476ff6","src/win.rs":"7bbb34ce7f341d0d74b0a2b6225f088fe19ae1084913adb7817a552f3b4cf4dd"},"package":"eeea3eb6a30ed24e374f59368d3917c5180a845fdd4ed6f1b2278811a9e826f8"} \ No newline at end of file
diff --git a/third_party/rust/zeitstempel/Cargo.lock b/third_party/rust/zeitstempel/Cargo.lock
new file mode 100644
index 0000000000..ef4e48c0f0
--- /dev/null
+++ b/third_party/rust/zeitstempel/Cargo.lock
@@ -0,0 +1,28 @@
+# This file is automatically @generated by Cargo.
+# It is not intended for manual editing.
+[[package]]
+name = "cfg-if"
+version = "1.0.0"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "baf1de4339761588bc0619e3cbc0120ee582ebb74b53b4efbf79117bd2da40fd"
+
+[[package]]
+name = "libc"
+version = "0.2.86"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "b7282d924be3275cec7f6756ff4121987bc6481325397dde6ba3e7802b1a8b1c"
+
+[[package]]
+name = "once_cell"
+version = "1.5.2"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "13bd41f508810a131401606d54ac32a467c97172d74ba7662562ebba5ad07fa0"
+
+[[package]]
+name = "zeitstempel"
+version = "0.1.1"
+dependencies = [
+ "cfg-if",
+ "libc",
+ "once_cell",
+]
diff --git a/third_party/rust/zeitstempel/Cargo.toml b/third_party/rust/zeitstempel/Cargo.toml
new file mode 100644
index 0000000000..73efa45ec0
--- /dev/null
+++ b/third_party/rust/zeitstempel/Cargo.toml
@@ -0,0 +1,30 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "zeitstempel"
+version = "0.1.1"
+authors = ["Jan-Erik Rediger <jrediger@mozilla.com>"]
+description = "A timestamp you can serialize, and it might include suspend time."
+license = "MPL-2.0"
+repository = "https://github.com/badboy/zeitstempel"
+[dependencies.cfg-if]
+version = "1.0.0"
+
+[dependencies.once_cell]
+version = "1.5.2"
+
+[features]
+win10plus = []
+[target."cfg(any(target_os = \"linux\", target_os = \"android\", target_os = \"macos\", target_os = \"ios\"))".dependencies.libc]
+version = "0.2"
diff --git a/third_party/rust/zeitstempel/LICENSE b/third_party/rust/zeitstempel/LICENSE
new file mode 100644
index 0000000000..a612ad9813
--- /dev/null
+++ b/third_party/rust/zeitstempel/LICENSE
@@ -0,0 +1,373 @@
+Mozilla Public License Version 2.0
+==================================
+
+1. Definitions
+--------------
+
+1.1. "Contributor"
+ means each individual or legal entity that creates, contributes to
+ the creation of, or owns Covered Software.
+
+1.2. "Contributor Version"
+ means the combination of the Contributions of others (if any) used
+ by a Contributor and that particular Contributor's Contribution.
+
+1.3. "Contribution"
+ means Covered Software of a particular Contributor.
+
+1.4. "Covered Software"
+ means Source Code Form to which the initial Contributor has attached
+ the notice in Exhibit A, the Executable Form of such Source Code
+ Form, and Modifications of such Source Code Form, in each case
+ including portions thereof.
+
+1.5. "Incompatible With Secondary Licenses"
+ means
+
+ (a) that the initial Contributor has attached the notice described
+ in Exhibit B to the Covered Software; or
+
+ (b) that the Covered Software was made available under the terms of
+ version 1.1 or earlier of the License, but not also under the
+ terms of a Secondary License.
+
+1.6. "Executable Form"
+ means any form of the work other than Source Code Form.
+
+1.7. "Larger Work"
+ means a work that combines Covered Software with other material, in
+ a separate file or files, that is not Covered Software.
+
+1.8. "License"
+ means this document.
+
+1.9. "Licensable"
+ means having the right to grant, to the maximum extent possible,
+ whether at the time of the initial grant or subsequently, any and
+ all of the rights conveyed by this License.
+
+1.10. "Modifications"
+ means any of the following:
+
+ (a) any file in Source Code Form that results from an addition to,
+ deletion from, or modification of the contents of Covered
+ Software; or
+
+ (b) any new file in Source Code Form that contains any Covered
+ Software.
+
+1.11. "Patent Claims" of a Contributor
+ means any patent claim(s), including without limitation, method,
+ process, and apparatus claims, in any patent Licensable by such
+ Contributor that would be infringed, but for the grant of the
+ License, by the making, using, selling, offering for sale, having
+ made, import, or transfer of either its Contributions or its
+ Contributor Version.
+
+1.12. "Secondary License"
+ means either the GNU General Public License, Version 2.0, the GNU
+ Lesser General Public License, Version 2.1, the GNU Affero General
+ Public License, Version 3.0, or any later versions of those
+ licenses.
+
+1.13. "Source Code Form"
+ means the form of the work preferred for making modifications.
+
+1.14. "You" (or "Your")
+ means an individual or a legal entity exercising rights under this
+ License. For legal entities, "You" includes any entity that
+ controls, is controlled by, or is under common control with You. For
+ purposes of this definition, "control" means (a) the power, direct
+ or indirect, to cause the direction or management of such entity,
+ whether by contract or otherwise, or (b) ownership of more than
+ fifty percent (50%) of the outstanding shares or beneficial
+ ownership of such entity.
+
+2. License Grants and Conditions
+--------------------------------
+
+2.1. Grants
+
+Each Contributor hereby grants You a world-wide, royalty-free,
+non-exclusive license:
+
+(a) under intellectual property rights (other than patent or trademark)
+ Licensable by such Contributor to use, reproduce, make available,
+ modify, display, perform, distribute, and otherwise exploit its
+ Contributions, either on an unmodified basis, with Modifications, or
+ as part of a Larger Work; and
+
+(b) under Patent Claims of such Contributor to make, use, sell, offer
+ for sale, have made, import, and otherwise transfer either its
+ Contributions or its Contributor Version.
+
+2.2. Effective Date
+
+The licenses granted in Section 2.1 with respect to any Contribution
+become effective for each Contribution on the date the Contributor first
+distributes such Contribution.
+
+2.3. Limitations on Grant Scope
+
+The licenses granted in this Section 2 are the only rights granted under
+this License. No additional rights or licenses will be implied from the
+distribution or licensing of Covered Software under this License.
+Notwithstanding Section 2.1(b) above, no patent license is granted by a
+Contributor:
+
+(a) for any code that a Contributor has removed from Covered Software;
+ or
+
+(b) for infringements caused by: (i) Your and any other third party's
+ modifications of Covered Software, or (ii) the combination of its
+ Contributions with other software (except as part of its Contributor
+ Version); or
+
+(c) under Patent Claims infringed by Covered Software in the absence of
+ its Contributions.
+
+This License does not grant any rights in the trademarks, service marks,
+or logos of any Contributor (except as may be necessary to comply with
+the notice requirements in Section 3.4).
+
+2.4. Subsequent Licenses
+
+No Contributor makes additional grants as a result of Your choice to
+distribute the Covered Software under a subsequent version of this
+License (see Section 10.2) or under the terms of a Secondary License (if
+permitted under the terms of Section 3.3).
+
+2.5. Representation
+
+Each Contributor represents that the Contributor believes its
+Contributions are its original creation(s) or it has sufficient rights
+to grant the rights to its Contributions conveyed by this License.
+
+2.6. Fair Use
+
+This License is not intended to limit any rights You have under
+applicable copyright doctrines of fair use, fair dealing, or other
+equivalents.
+
+2.7. Conditions
+
+Sections 3.1, 3.2, 3.3, and 3.4 are conditions of the licenses granted
+in Section 2.1.
+
+3. Responsibilities
+-------------------
+
+3.1. Distribution of Source Form
+
+All distribution of Covered Software in Source Code Form, including any
+Modifications that You create or to which You contribute, must be under
+the terms of this License. You must inform recipients that the Source
+Code Form of the Covered Software is governed by the terms of this
+License, and how they can obtain a copy of this License. You may not
+attempt to alter or restrict the recipients' rights in the Source Code
+Form.
+
+3.2. Distribution of Executable Form
+
+If You distribute Covered Software in Executable Form then:
+
+(a) such Covered Software must also be made available in Source Code
+ Form, as described in Section 3.1, and You must inform recipients of
+ the Executable Form how they can obtain a copy of such Source Code
+ Form by reasonable means in a timely manner, at a charge no more
+ than the cost of distribution to the recipient; and
+
+(b) You may distribute such Executable Form under the terms of this
+ License, or sublicense it under different terms, provided that the
+ license for the Executable Form does not attempt to limit or alter
+ the recipients' rights in the Source Code Form under this License.
+
+3.3. Distribution of a Larger Work
+
+You may create and distribute a Larger Work under terms of Your choice,
+provided that You also comply with the requirements of this License for
+the Covered Software. If the Larger Work is a combination of Covered
+Software with a work governed by one or more Secondary Licenses, and the
+Covered Software is not Incompatible With Secondary Licenses, this
+License permits You to additionally distribute such Covered Software
+under the terms of such Secondary License(s), so that the recipient of
+the Larger Work may, at their option, further distribute the Covered
+Software under the terms of either this License or such Secondary
+License(s).
+
+3.4. Notices
+
+You may not remove or alter the substance of any license notices
+(including copyright notices, patent notices, disclaimers of warranty,
+or limitations of liability) contained within the Source Code Form of
+the Covered Software, except that You may alter any license notices to
+the extent required to remedy known factual inaccuracies.
+
+3.5. Application of Additional Terms
+
+You may choose to offer, and to charge a fee for, warranty, support,
+indemnity or liability obligations to one or more recipients of Covered
+Software. However, You may do so only on Your own behalf, and not on
+behalf of any Contributor. You must make it absolutely clear that any
+such warranty, support, indemnity, or liability obligation is offered by
+You alone, and You hereby agree to indemnify every Contributor for any
+liability incurred by such Contributor as a result of warranty, support,
+indemnity or liability terms You offer. You may include additional
+disclaimers of warranty and limitations of liability specific to any
+jurisdiction.
+
+4. Inability to Comply Due to Statute or Regulation
+---------------------------------------------------
+
+If it is impossible for You to comply with any of the terms of this
+License with respect to some or all of the Covered Software due to
+statute, judicial order, or regulation then You must: (a) comply with
+the terms of this License to the maximum extent possible; and (b)
+describe the limitations and the code they affect. Such description must
+be placed in a text file included with all distributions of the Covered
+Software under this License. Except to the extent prohibited by statute
+or regulation, such description must be sufficiently detailed for a
+recipient of ordinary skill to be able to understand it.
+
+5. Termination
+--------------
+
+5.1. The rights granted under this License will terminate automatically
+if You fail to comply with any of its terms. However, if You become
+compliant, then the rights granted under this License from a particular
+Contributor are reinstated (a) provisionally, unless and until such
+Contributor explicitly and finally terminates Your grants, and (b) on an
+ongoing basis, if such Contributor fails to notify You of the
+non-compliance by some reasonable means prior to 60 days after You have
+come back into compliance. Moreover, Your grants from a particular
+Contributor are reinstated on an ongoing basis if such Contributor
+notifies You of the non-compliance by some reasonable means, this is the
+first time You have received notice of non-compliance with this License
+from such Contributor, and You become compliant prior to 30 days after
+Your receipt of the notice.
+
+5.2. If You initiate litigation against any entity by asserting a patent
+infringement claim (excluding declaratory judgment actions,
+counter-claims, and cross-claims) alleging that a Contributor Version
+directly or indirectly infringes any patent, then the rights granted to
+You by any and all Contributors for the Covered Software under Section
+2.1 of this License shall terminate.
+
+5.3. In the event of termination under Sections 5.1 or 5.2 above, all
+end user license agreements (excluding distributors and resellers) which
+have been validly granted by You or Your distributors under this License
+prior to termination shall survive termination.
+
+************************************************************************
+* *
+* 6. Disclaimer of Warranty *
+* ------------------------- *
+* *
+* Covered Software is provided under this License on an "as is" *
+* basis, without warranty of any kind, either expressed, implied, or *
+* statutory, including, without limitation, warranties that the *
+* Covered Software is free of defects, merchantable, fit for a *
+* particular purpose or non-infringing. The entire risk as to the *
+* quality and performance of the Covered Software is with You. *
+* Should any Covered Software prove defective in any respect, You *
+* (not any Contributor) assume the cost of any necessary servicing, *
+* repair, or correction. This disclaimer of warranty constitutes an *
+* essential part of this License. No use of any Covered Software is *
+* authorized under this License except under this disclaimer. *
+* *
+************************************************************************
+
+************************************************************************
+* *
+* 7. Limitation of Liability *
+* -------------------------- *
+* *
+* Under no circumstances and under no legal theory, whether tort *
+* (including negligence), contract, or otherwise, shall any *
+* Contributor, or anyone who distributes Covered Software as *
+* permitted above, be liable to You for any direct, indirect, *
+* special, incidental, or consequential damages of any character *
+* including, without limitation, damages for lost profits, loss of *
+* goodwill, work stoppage, computer failure or malfunction, or any *
+* and all other commercial damages or losses, even if such party *
+* shall have been informed of the possibility of such damages. This *
+* limitation of liability shall not apply to liability for death or *
+* personal injury resulting from such party's negligence to the *
+* extent applicable law prohibits such limitation. Some *
+* jurisdictions do not allow the exclusion or limitation of *
+* incidental or consequential damages, so this exclusion and *
+* limitation may not apply to You. *
+* *
+************************************************************************
+
+8. Litigation
+-------------
+
+Any litigation relating to this License may be brought only in the
+courts of a jurisdiction where the defendant maintains its principal
+place of business and such litigation shall be governed by laws of that
+jurisdiction, without reference to its conflict-of-law provisions.
+Nothing in this Section shall prevent a party's ability to bring
+cross-claims or counter-claims.
+
+9. Miscellaneous
+----------------
+
+This License represents the complete agreement concerning the subject
+matter hereof. If any provision of this License is held to be
+unenforceable, such provision shall be reformed only to the extent
+necessary to make it enforceable. Any law or regulation which provides
+that the language of a contract shall be construed against the drafter
+shall not be used to construe this License against a Contributor.
+
+10. Versions of the License
+---------------------------
+
+10.1. New Versions
+
+Mozilla Foundation is the license steward. Except as provided in Section
+10.3, no one other than the license steward has the right to modify or
+publish new versions of this License. Each version will be given a
+distinguishing version number.
+
+10.2. Effect of New Versions
+
+You may distribute the Covered Software under the terms of the version
+of the License under which You originally received the Covered Software,
+or under the terms of any subsequent version published by the license
+steward.
+
+10.3. Modified Versions
+
+If you create software not governed by this License, and you want to
+create a new license for such software, you may create and use a
+modified version of this License if you rename the license and remove
+any references to the name of the license steward (except to note that
+such modified license differs from this License).
+
+10.4. Distributing Source Code Form that is Incompatible With Secondary
+Licenses
+
+If You choose to distribute Source Code Form that is Incompatible With
+Secondary Licenses under the terms of this version of the License, the
+notice described in Exhibit B of this License must be attached.
+
+Exhibit A - Source Code Form License Notice
+-------------------------------------------
+
+ This Source Code Form is subject to the terms of the Mozilla Public
+ License, v. 2.0. If a copy of the MPL was not distributed with this
+ file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+If it is not possible or desirable to put the notice in a particular
+file, then You may include the notice in a location (such as a LICENSE
+file in a relevant directory) where a recipient would be likely to look
+for such a notice.
+
+You may add additional accurate notices of copyright ownership.
+
+Exhibit B - "Incompatible With Secondary Licenses" Notice
+---------------------------------------------------------
+
+ This Source Code Form is "Incompatible With Secondary Licenses", as
+ defined by the Mozilla Public License, v. 2.0.
diff --git a/third_party/rust/zeitstempel/README.md b/third_party/rust/zeitstempel/README.md
new file mode 100644
index 0000000000..578f82a178
--- /dev/null
+++ b/third_party/rust/zeitstempel/README.md
@@ -0,0 +1,67 @@
+# zeitstempel
+
+[![Crates.io version](https://img.shields.io/crates/v/zeitstempel.svg?style=flat-square)](https://crates.io/crates/zeitstempel)
+[![docs.rs docs](https://img.shields.io/badge/docs-latest-blue.svg?style=flat-square)](https://docs.rs/zeitstempel)
+[![License: MPL 2.0](https://img.shields.io/github/license/badboy/zeitstempel?style=flat-square)](LICENSE)
+[![Build Status](https://img.shields.io/github/workflow/status/badboy/zeitstempel/CI?style=flat-square)](https://github.com/badboy/zeitstempel/actions?query=workflow%3ACI)
+
+zeitstempel is German for "timestamp".
+
+---
+
+Time's hard. Correct time is near impossible.
+
+This crate has one purpose: give me a timestamp as an integer, coming from a monotonic clock
+source, include time across suspend/hibernation of the host machine and let me compare it to
+other timestamps.
+
+It becomes the developer's responsibility to only compare timestamps obtained from this clock source.
+Timestamps are not comparable across operating system reboots.
+
+# Why not `std::time::Instant`?
+
+[`std::time::Instant`] fulfills some of our requirements:
+
+[`std::time::Instant`]: https://doc.rust-lang.org/1.47.0/std/time/struct.Instant.html
+
+* It's monotonic, guaranteed ([sort of][rustsource]).
+* It can be compared to other timespans.
+
+However:
+
+* It can't be serialized.
+* It's not guaranteed that the clock source it uses contains suspend/hibernation time across all operating systems.
+
+[rustsource]: https://doc.rust-lang.org/1.47.0/src/std/time.rs.html#213-237
+
+# Example
+
+```rust
+use std::{thread, time::Duration};
+
+let start = zeitstempel::now();
+thread::sleep(Duration::from_millis(2));
+
+let diff = Duration::from_nanos(zeitstempel::now() - start);
+assert!(diff >= Duration::from_millis(2));
+```
+
+# Supported operating systems
+
+We support the following operating systems:
+
+* Windows\*
+* macOS
+* Linux
+* Android
+* iOS
+
+For other operating systems there's a fallback to `std::time::Instant`,
+compared against a process-global fixed reference point.
+We don't guarantee that measured time includes time the system spends in sleep or hibernation.
+
+\* To use native Windows 10 functionality enable the `win10plus` feature. Otherwise it will use the fallback.
+
+# License
+
+MPL 2.0. See [LICENSE](LICENSE).
diff --git a/third_party/rust/zeitstempel/examples/uptime.rs b/third_party/rust/zeitstempel/examples/uptime.rs
new file mode 100644
index 0000000000..2cf9b62d59
--- /dev/null
+++ b/third_party/rust/zeitstempel/examples/uptime.rs
@@ -0,0 +1,11 @@
+use std::{thread, time::Duration};
+
+fn main() {
+ let start = zeitstempel::now();
+ println!("Now: {}", start);
+
+ thread::sleep(Duration::from_secs(2));
+
+ let diff = zeitstempel::now() - start;
+ println!("Diff: {} ms", Duration::from_nanos(diff).as_millis());
+}
diff --git a/third_party/rust/zeitstempel/src/fallback.rs b/third_party/rust/zeitstempel/src/fallback.rs
new file mode 100644
index 0000000000..157f4c1a77
--- /dev/null
+++ b/third_party/rust/zeitstempel/src/fallback.rs
@@ -0,0 +1,31 @@
+use std::convert::TryInto;
+use std::time::Instant;
+
+use once_cell::sync::Lazy;
+
+static INIT_TIME: Lazy<Instant> = Lazy::new(Instant::now);
+
+pub fn now_including_suspend() -> u64 {
+ // For Windows:
+ // Instead of relying on figuring out the underlying functions,
+ // we can rely on the fact that `Instant::now` maps to [QueryPerformanceCounter] on Windows,
+ // so by comparing it to another arbitrary timestamp we will get a duration that will include
+ // suspend time.
+ // If we use that as a timestamp we can compare later timestamps to it and that will also
+ // include suspend time.
+ //
+ // [QueryPerformanceCounter]: https://docs.microsoft.com/en-us/windows/win32/api/profileapi/nf-profileapi-queryperformancecounter
+ //
+ // For other operating systems:
+ // This fallback is not used on Linux, where it maps to `CLOCK_MONOTONIC`, which does NOT
+ // include suspend time. But we don't use it there, so no problem.
+ //
+ // This fallback is not used on macOS, where it maps to `mach_absolute_time`, which does NOT
+ // include suspend time. But we don't use it there, so no problem.
+ //
+ // For other operating systems we make no guarantees, other than that we won't panic.
+ let now = Instant::now();
+ now.checked_duration_since(*INIT_TIME)
+ .and_then(|diff| diff.as_nanos().try_into().ok())
+ .unwrap_or(0)
+}
diff --git a/third_party/rust/zeitstempel/src/lib.rs b/third_party/rust/zeitstempel/src/lib.rs
new file mode 100644
index 0000000000..61736f19fa
--- /dev/null
+++ b/third_party/rust/zeitstempel/src/lib.rs
@@ -0,0 +1,105 @@
+//! zeitstempel is German for "timestamp".
+//!
+//! ---
+//!
+//! Time's hard. Correct time is near impossible.
+//!
+//! This crate has one purpose: give me a timestamp as an integer, coming from a monotonic clock
+//! source, include time across suspend/hibernation of the host machine and let me compare it to
+//! other timestamps.
+//!
+//! It becomes the developer's responsibility to only compare timestamps obtained from this clock source.
+//! Timestamps are not comparable across operating system reboots.
+//!
+//! # Why not `std::time::Instant`?
+//!
+//! [`std::time::Instant`] fulfills some of our requirements:
+//!
+//! * It's monotonic, guaranteed ([sort of][rustsource]).
+//! * It can be compared to other timespans.
+//!
+//! However:
+//!
+//! * It can't be serialized.
+//! * It's not guaranteed that the clock source it uses contains suspend/hibernation time across all operating systems.
+//!
+//! [rustsource]: https://doc.rust-lang.org/1.47.0/src/std/time.rs.html#213-237
+//!
+//! # Example
+//!
+//! ```
+//! # use std::{thread, time::Duration};
+//! let start = zeitstempel::now();
+//! thread::sleep(Duration::from_millis(2));
+//!
+//! let diff = Duration::from_nanos(zeitstempel::now() - start);
+//! assert!(diff >= Duration::from_millis(2));
+//! ```
+//!
+//! # Supported operating systems
+//!
+//! We support the following operating systems:
+//!
+//! * Windows\*
+//! * macOS
+//! * Linux
+//! * Android
+//! * iOS
+//!
+//! For other operating systems there's a fallback to `std::time::Instant`,
+//! compared against a process-global fixed reference point.
+//! We don't guarantee that measured time includes time the system spends in sleep or hibernation.
+//!
+//! \* To use native Windows 10 functionality enable the `win10plus` feature. Otherwise it will use the fallback.
+
+#![deny(missing_docs)]
+#![deny(broken_intra_doc_links)]
+
+cfg_if::cfg_if! {
+ if #[cfg(any(target_os = "macos", target_os = "ios"))] {
+ mod mac;
+ use mac as sys;
+ } else if #[cfg(any(target_os = "linux", target_os = "android"))] {
+ mod linux;
+ use linux as sys;
+ } else if #[cfg(all(windows, feature = "win10plus"))] {
+ mod win;
+ use win as sys;
+ } else {
+ mod fallback;
+ use fallback as sys;
+ }
+}
+
+/// Returns a timestamp corresponding to "now".
+///
+/// It can be compared to other timestamps gathered from this API, as long as the host was not
+/// rebooted inbetween.
+///
+///
+/// ## Note
+///
+/// * The difference between two timestamps will include time the system was in sleep or
+/// hibernation.
+/// * The difference between two timestamps gathered from this is in nanoseconds.
+/// * The clocks on some operating systems, e.g. on Windows, are not nanosecond-precise.
+/// The value will still use nanosecond resolution.
+pub fn now() -> u64 {
+ sys::now_including_suspend()
+}
+
+#[cfg(test)]
+mod test {
+ use super::*;
+ use std::thread;
+ use std::time::Duration;
+
+ #[test]
+ fn order() {
+ let ts1 = now();
+ thread::sleep(Duration::from_millis(2));
+ let ts2 = now();
+
+ assert!(ts1 < ts2);
+ }
+}
diff --git a/third_party/rust/zeitstempel/src/linux.rs b/third_party/rust/zeitstempel/src/linux.rs
new file mode 100644
index 0000000000..e8fb8500ca
--- /dev/null
+++ b/third_party/rust/zeitstempel/src/linux.rs
@@ -0,0 +1,24 @@
+const NS_PER_S: u64 = 1_000_000_000;
+
+fn timespec_to_ns(ts: libc::timespec) -> u64 {
+ (ts.tv_sec as u64) * NS_PER_S + (ts.tv_nsec as u64)
+}
+
+/// The time from a clock that cannot be set
+/// and represents monotonic time since some unspecified starting point,
+/// that also includes any time that the system is suspended.
+///
+/// See [`clock_gettime`].
+///
+/// [`clock_gettime`]: https://manpages.debian.org/buster/manpages-dev/clock_gettime.3.en.html
+pub fn now_including_suspend() -> u64 {
+ let mut ts = libc::timespec {
+ tv_sec: 0,
+ tv_nsec: 0,
+ };
+ unsafe {
+ libc::clock_gettime(libc::CLOCK_BOOTTIME, &mut ts);
+ }
+
+ timespec_to_ns(ts)
+}
diff --git a/third_party/rust/zeitstempel/src/mac.rs b/third_party/rust/zeitstempel/src/mac.rs
new file mode 100644
index 0000000000..701daa1696
--- /dev/null
+++ b/third_party/rust/zeitstempel/src/mac.rs
@@ -0,0 +1,17 @@
+use libc::clockid_t;
+
+extern "C" {
+ fn clock_gettime_nsec_np(clock_id: clockid_t) -> u64;
+}
+
+const CLOCK_MONOTONIC_RAW: clockid_t = 4;
+
+/// The time from a clock that increments monotonically,
+/// tracking the time since an arbitrary point.
+///
+/// See [`clock_gettime_nsec_np`].
+///
+/// [`clock_gettime_nsec_np`]: https://opensource.apple.com/source/Libc/Libc-1158.1.2/gen/clock_gettime.3.auto.html
+pub fn now_including_suspend() -> u64 {
+ unsafe { clock_gettime_nsec_np(CLOCK_MONOTONIC_RAW) }
+}
diff --git a/third_party/rust/zeitstempel/src/win.rs b/third_party/rust/zeitstempel/src/win.rs
new file mode 100644
index 0000000000..37e8553498
--- /dev/null
+++ b/third_party/rust/zeitstempel/src/win.rs
@@ -0,0 +1,42 @@
+//! Timestamp implementation for Windows 10+ or Windows Server 2016+.
+//!
+//! Lower versions don't have the necessary API and should use the fallback.
+
+#![cfg(feature = "win10plus")]
+
+/// [PULONGLONG] is a pointer to [ULONGLONG], a 64-bit unsigned integer.
+///
+/// [PULONGLONG]: https://docs.microsoft.com/en-us/windows/win32/winprog/windows-data-types#PULONGLONG
+/// [ULONGLONG]: https://docs.microsoft.com/en-us/windows/win32/winprog/windows-data-types#ulonglong
+type PULONGLONG = *mut u64;
+
+/// Link against Windows' `mincore`.
+#[link(name = "mincore")]
+extern "system" {
+ /// Gets the current interrupt-time count.
+ ///
+ /// See [`QueryInterruptTime`].
+ ///
+ /// [`QueryInterruptTime`]: https://docs.microsoft.com/en-us/windows/win32/api/realtimeapiset/nf-realtimeapiset-queryinterrupttime
+ ///
+ /// Note: we define it ourselves, because it's not actually included in `winapi`.
+ fn QueryInterruptTime(InterruptTime: PULONGLONG);
+}
+
+/// Windows counts time in a system time unit of 100 nanoseconds.
+const SYSTEM_TIME_UNIT: u64 = 100;
+
+/// The time based on the current interrupt-time count.
+/// This includes the suspend time.
+///
+/// See [`QueryInterruptTime`].
+///
+/// [`QueryInterruptTime`]: https://docs.microsoft.com/en-us/windows/win32/api/realtimeapiset/nf-realtimeapiset-queryinterrupttime
+pub fn now_including_suspend() -> u64 {
+ let mut interrupt_time = 0;
+ unsafe {
+ QueryInterruptTime(&mut interrupt_time);
+ }
+
+ interrupt_time * SYSTEM_TIME_UNIT
+}