summaryrefslogtreecommitdiffstats
path: root/toolkit/components/uniffi-fixture-external-types
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /toolkit/components/uniffi-fixture-external-types
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/components/uniffi-fixture-external-types')
-rw-r--r--toolkit/components/uniffi-fixture-external-types/Cargo.toml15
-rw-r--r--toolkit/components/uniffi-fixture-external-types/build.rs7
-rw-r--r--toolkit/components/uniffi-fixture-external-types/src/external-types.udl11
-rw-r--r--toolkit/components/uniffi-fixture-external-types/src/lib.rs18
4 files changed, 51 insertions, 0 deletions
diff --git a/toolkit/components/uniffi-fixture-external-types/Cargo.toml b/toolkit/components/uniffi-fixture-external-types/Cargo.toml
new file mode 100644
index 0000000000..f9ac840c3f
--- /dev/null
+++ b/toolkit/components/uniffi-fixture-external-types/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "uniffi-fixture-external-types"
+edition = "2021"
+version = "0.21.0"
+authors = ["Firefox Sync Team <sync-team@mozilla.com>"]
+license = "MPL-2.0"
+publish = false
+
+[dependencies]
+uniffi-example-geometry = { git = "https://github.com/mozilla/uniffi-rs.git", rev = "afb29ebdc1d9edf15021b1c5332fc9f285bbe13b" }
+uniffi = { workspace = true }
+thiserror = "1.0"
+
+[build-dependencies]
+uniffi = { workspace = true, features = ["build"] }
diff --git a/toolkit/components/uniffi-fixture-external-types/build.rs b/toolkit/components/uniffi-fixture-external-types/build.rs
new file mode 100644
index 0000000000..13f56ca56b
--- /dev/null
+++ b/toolkit/components/uniffi-fixture-external-types/build.rs
@@ -0,0 +1,7 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+fn main() {
+ uniffi::generate_scaffolding("./src/external-types.udl").unwrap();
+}
diff --git a/toolkit/components/uniffi-fixture-external-types/src/external-types.udl b/toolkit/components/uniffi-fixture-external-types/src/external-types.udl
new file mode 100644
index 0000000000..d50fc680f7
--- /dev/null
+++ b/toolkit/components/uniffi-fixture-external-types/src/external-types.udl
@@ -0,0 +1,11 @@
+// A type defined in the `geometry` component
+[External="uniffi_geometry"]
+typedef extern Point;
+
+[External="uniffi_geometry"]
+typedef extern Line;
+
+namespace external_types {
+ double gradient(Line? value);
+ Point? intersection(Line ln1, Line ln2);
+};
diff --git a/toolkit/components/uniffi-fixture-external-types/src/lib.rs b/toolkit/components/uniffi-fixture-external-types/src/lib.rs
new file mode 100644
index 0000000000..2d12332312
--- /dev/null
+++ b/toolkit/components/uniffi-fixture-external-types/src/lib.rs
@@ -0,0 +1,18 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+use uniffi_geometry::{Line, Point};
+
+pub fn gradient(value: Option<Line>) -> f64 {
+ match value {
+ None => 0.0,
+ Some(value) => uniffi_geometry::gradient(value),
+ }
+}
+
+pub fn intersection(ln1: Line, ln2: Line) -> Option<Point> {
+ uniffi_geometry::intersection(ln1, ln2)
+}
+
+include!(concat!(env!("OUT_DIR"), "/external-types.uniffi.rs"));