summaryrefslogtreecommitdiffstats
path: root/toolkit/crashreporter/mozannotation_server/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-15 03:35:49 +0000
commitd8bbc7858622b6d9c278469aab701ca0b609cddf (patch)
treeeff41dc61d9f714852212739e6b3738b82a2af87 /toolkit/crashreporter/mozannotation_server/Cargo.toml
parentReleasing progress-linux version 125.0.3-1~progress7.99u1. (diff)
downloadfirefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.tar.xz
firefox-d8bbc7858622b6d9c278469aab701ca0b609cddf.zip
Merging upstream version 126.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/crashreporter/mozannotation_server/Cargo.toml')
-rw-r--r--toolkit/crashreporter/mozannotation_server/Cargo.toml11
1 files changed, 2 insertions, 9 deletions
diff --git a/toolkit/crashreporter/mozannotation_server/Cargo.toml b/toolkit/crashreporter/mozannotation_server/Cargo.toml
index 3a5834a645..bd3fb283bf 100644
--- a/toolkit/crashreporter/mozannotation_server/Cargo.toml
+++ b/toolkit/crashreporter/mozannotation_server/Cargo.toml
@@ -8,17 +8,10 @@ license = "MPL-2.0"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
-goblin = { version = "0.7", features = ["elf32", "elf64", "pe32", "pe64"] }
-memoffset = "0.8"
mozannotation_client = { path = "../mozannotation_client/" }
+process_reader = { path = "../process_reader/" }
thin-vec = { version = "0.2.7", features = ["gecko-ffi"] }
thiserror = "1.0.38"
[target."cfg(any(target_os = \"linux\", target_os = \"android\"))".dependencies]
-libc = "0.2"
-
-[target."cfg(target_os = \"windows\")".dependencies]
-winapi = { version = "0.3", features = ["minwindef", "memoryapi", "psapi"] }
-
-[target."cfg(target_os = \"macos\")".dependencies]
-mach2 = { version = "0.4" }
+memoffset = "0.8"