summaryrefslogtreecommitdiffstats
path: root/toolkit/crashreporter/mozwer-rust/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 00:47:55 +0000
commit26a029d407be480d791972afb5975cf62c9360a6 (patch)
treef435a8308119effd964b339f76abb83a57c29483 /toolkit/crashreporter/mozwer-rust/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-26a029d407be480d791972afb5975cf62c9360a6.tar.xz
firefox-26a029d407be480d791972afb5975cf62c9360a6.zip
Adding upstream version 124.0.1.upstream/124.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/crashreporter/mozwer-rust/Cargo.toml')
-rw-r--r--toolkit/crashreporter/mozwer-rust/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/toolkit/crashreporter/mozwer-rust/Cargo.toml b/toolkit/crashreporter/mozwer-rust/Cargo.toml
new file mode 100644
index 0000000000..561a10b015
--- /dev/null
+++ b/toolkit/crashreporter/mozwer-rust/Cargo.toml
@@ -0,0 +1,37 @@
+[package]
+name = "mozwer_s"
+version = "0.1.0"
+authors = ["Gabriele Svelto <gsvelto@mozilla.com>"]
+edition = "2018"
+license = "MPL-2.0"
+
+[dependencies]
+libc = "0.2.0"
+mozilla-central-workspace-hack = { version = "0.1", features = ["mozwer_s"], optional = true }
+process_reader = { path = "../process_reader/" }
+rust-ini = "0.10"
+serde = { version = "1.0", features = ["derive"] }
+serde_json = { version = "1.0" }
+uuid = { version = "1.0", features = ["v4"] }
+
+[dependencies.windows-sys]
+version = "0.52"
+features = [
+ "Wdk_System_Threading",
+ "Win32_Foundation",
+ "Win32_Security",
+ "Win32_System_Com",
+ "Win32_System_Diagnostics_Debug",
+ "Win32_System_ErrorReporting",
+ "Win32_System_ProcessStatus",
+ "Win32_System_SystemInformation",
+ "Win32_System_SystemServices",
+ "Win32_System_Threading",
+ "Win32_UI_Shell",
+ "Win32_UI_WindowsAndMessaging",
+]
+
+[lib]
+name = "mozwer_s"
+crate-type = ["staticlib"]
+path = "lib.rs"