summaryrefslogtreecommitdiffstats
path: root/toolkit/library
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 01:14:29 +0000
commitfbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8 (patch)
tree4c1ccaf5486d4f2009f9a338a98a83e886e29c97 /toolkit/library
parentReleasing progress-linux version 124.0.1-1~progress7.99u1. (diff)
downloadfirefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.tar.xz
firefox-fbaf0bb26397aa498eb9156f06d5a6fe34dd7dd8.zip
Merging upstream version 125.0.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/library')
-rw-r--r--toolkit/library/moz.build1
-rw-r--r--toolkit/library/rust/moz.build3
-rw-r--r--toolkit/library/rust/shared/Cargo.toml2
3 files changed, 5 insertions, 1 deletions
diff --git a/toolkit/library/moz.build b/toolkit/library/moz.build
index 76746f3080..185d5f74d0 100644
--- a/toolkit/library/moz.build
+++ b/toolkit/library/moz.build
@@ -245,6 +245,7 @@ if CONFIG["MOZ_WIDGET_TOOLKIT"] == "uikit":
"-framework CoreVideo",
"-framework OpenGLES",
"-framework QuartzCore",
+ "-framework Security",
]
if CONFIG["MOZ_WMF"]:
diff --git a/toolkit/library/rust/moz.build b/toolkit/library/rust/moz.build
index eb2db8f81b..0935410268 100644
--- a/toolkit/library/rust/moz.build
+++ b/toolkit/library/rust/moz.build
@@ -31,6 +31,9 @@ RUST_TESTS = [
"gkrust",
]
+if CONFIG["TARGET_OS"] in ("WINNT", "OSX"):
+ RUST_TESTS += ["nmhproxy"]
+
# Code coverage builds link a bunch of Gecko bindings code from the style
# crate, which is not used by our tests but would cause link errors.
#
diff --git a/toolkit/library/rust/shared/Cargo.toml b/toolkit/library/rust/shared/Cargo.toml
index a3c5bef5f6..4e7ab800a2 100644
--- a/toolkit/library/rust/shared/Cargo.toml
+++ b/toolkit/library/rust/shared/Cargo.toml
@@ -101,7 +101,7 @@ processtools = { path = "../../../components/processtools" }
qcms = { path = "../../../../gfx/qcms", features = ["c_bindings", "neon"], default-features = false }
wpf-gpu-raster = { git = "https://github.com/FirefoxGraphics/wpf-gpu-raster", rev = "99979da091fd58fba8477e7fcdf5ec0727102916" }
-aa-stroke = { git = "https://github.com/FirefoxGraphics/aa-stroke", rev = "96e66f91bb8e8efb80ff144eabd668002aa89650" }
+aa-stroke = { git = "https://github.com/FirefoxGraphics/aa-stroke", rev = "d94278ed9c7020f50232689a26d1277eb0eb74d2" }
url = "2.5.0"